aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2006-05-29 13:46:21 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2006-05-29 13:46:21 +0000
commit712c2236cd7fe08a8f2525346828eb9dd420365e (patch)
treec18db6c855a6dafbc17f24e5629fdd0005ccdbd7
parentb9d7d3572bc90c11eb4c7e3ffb74e332edc4e6dd (diff)
downloadports-712c2236cd7fe08a8f2525346828eb9dd420365e.tar.gz
ports-712c2236cd7fe08a8f2525346828eb9dd420365e.zip
Notes
-rw-r--r--lang/parrot/Makefile7
-rw-r--r--lang/parrot/distinfo6
-rw-r--r--lang/parrot/pkg-plist25
3 files changed, 22 insertions, 16 deletions
diff --git a/lang/parrot/Makefile b/lang/parrot/Makefile
index c3830d758ae6..3a46ac11d949 100644
--- a/lang/parrot/Makefile
+++ b/lang/parrot/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= parrot
-PORTVERSION= 0.4.3
-PORTREVISION= 1
+PORTVERSION= 0.4.4
CATEGORIES= lang perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= ../../authors/id/L/LT/LTOETSCH
@@ -19,8 +18,6 @@ BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
icudata.34:${PORTSDIR}/devel/icu
-BROKEN= Incorrect pkg-plist
-
USE_GCC= 3.4+
USE_PERL5= yes
USE_GMAKE= yes
@@ -37,6 +34,8 @@ CONFIGURE_ARGS= --cc=${CC} --cxx=${CXX} --ld=${CC} --ccflags="${CFLAGS}" \
--prefix=${PREFIX}
# --verbose
+PLIST_SUB+= SHLIB_VER="${PORTVERSION}"
+
post-patch:
${PERL} -pi -e "s=libdir}, 'pkgconfig=prefix}, 'libdata/pkgconfig=" \
${WRKSRC}/tools/dev/install_files.pl
diff --git a/lang/parrot/distinfo b/lang/parrot/distinfo
index f00aa7d1c96f..d272f3d943b2 100644
--- a/lang/parrot/distinfo
+++ b/lang/parrot/distinfo
@@ -1,3 +1,3 @@
-MD5 (parrot-0.4.3.tar.gz) = 7e1d786eb77031d92911b2cbd1752eac
-SHA256 (parrot-0.4.3.tar.gz) = 8eeffc98c23f888911d2ebb876dbcd22cc4742cb47536a23640e19bd6a8a8555
-SIZE (parrot-0.4.3.tar.gz) = 3095684
+MD5 (parrot-0.4.4.tar.gz) = 9fe4e13acb6bbf67fcb1febb59ef0c69
+SHA256 (parrot-0.4.4.tar.gz) = 62fa70dcec0cea149267b6b742e52524f2388dde19d61019ad16dfcfcff359e8
+SIZE (parrot-0.4.4.tar.gz) = 3183785
diff --git a/lang/parrot/pkg-plist b/lang/parrot/pkg-plist
index cde9774646c0..4c08e1e5c525 100644
--- a/lang/parrot/pkg-plist
+++ b/lang/parrot/pkg-plist
@@ -5,11 +5,11 @@ bin/pbc_info
bin/pbc_merge
bin/pdb
bin/pdump
-include/parrot/autoprefix.h
include/parrot/builtin.h
include/parrot/caches.h
include/parrot/cclass.h
include/parrot/charset.h
+include/parrot/compiler.h
include/parrot/config.h
include/parrot/core_pmcs.h
include/parrot/datatypes.h
@@ -22,8 +22,6 @@ include/parrot/enums.h
include/parrot/events.h
include/parrot/exceptions.h
include/parrot/exec.h
-include/parrot/exec_dep.h
-include/parrot/exec_save.h
include/parrot/exit.h
include/parrot/extend.h
include/parrot/extend_vtable.h
@@ -54,7 +52,6 @@ include/parrot/op.h
include/parrot/oplib.h
include/parrot/packfile.h
include/parrot/parrot.h
-include/parrot/perltypes.h
include/parrot/pic.h
include/parrot/platform.h
include/parrot/platform_interface.h
@@ -63,7 +60,6 @@ include/parrot/pmc_freeze.h
include/parrot/pobj.h
include/parrot/register.h
include/parrot/resources.h
-include/parrot/runops_cores.h
include/parrot/settings.h
include/parrot/slice.h
include/parrot/smallobject.h
@@ -90,7 +86,7 @@ include/parrot/oplib/core_ops_switch.h
include/parrot/oplib/ops.h
lib/libparrot.a
lib/libparrot.so
-lib/libparrot.so.0.4.3
+lib/libparrot.so.%%SHLIB_VER%%
lib/parrot/dynext/dynlexpad.so
lib/parrot/dynext/libnci_test.so
lib/parrot/dynext/match_group.so
@@ -166,8 +162,8 @@ lib/parrot/library/JSON/Parser.pir
lib/parrot/library/PGE/Dumper.pir
lib/parrot/library/PGE/Glob.pir
lib/parrot/library/PGE/Hs.pir
-lib/parrot/library/PGE/P6Grammar.pir
lib/parrot/library/PGE/Text.pir
+lib/parrot/library/PGE/Util.pir
lib/parrot/library/SDL/App.pir
lib/parrot/library/SDL/Button.pir
lib/parrot/library/SDL/Color.pir
@@ -226,6 +222,7 @@ libdata/pkgconfig/parrot.pc
%%DOCSDIR%%/docs/overview.pod
%%DOCSDIR%%/docs/parrot.pod
%%DOCSDIR%%/docs/parrotbyte.pod
+%%DOCSDIR%%/docs/pir-tutorial.pod
%%DOCSDIR%%/docs/pmc.pod
%%DOCSDIR%%/docs/porting_intro.pod
%%DOCSDIR%%/docs/practical_notes.pod
@@ -289,8 +286,10 @@ libdata/pkgconfig/parrot.pc
%%DOCSDIR%%/docs/pdds/clip/pdd17_basic_types.pod
%%DOCSDIR%%/docs/pdds/clip/pdd18_security.pod
%%DOCSDIR%%/docs/pdds/clip/pdd19_pir.pod
-%%DOCSDIR%%/docs/pdds/clip/pddXX_exceptions.pod
-%%DOCSDIR%%/docs/pdds/clip/pddXX_io.pod
+%%DOCSDIR%%/docs/pdds/clip/pdd22_io.pod
+%%DOCSDIR%%/docs/pdds/clip/pdd23_exceptions.pod
+%%DOCSDIR%%/docs/pdds/clip/pdd24_events.pod
+%%DOCSDIR%%/docs/pdds/clip/pdd25_threads.pod
%%DOCSDIR%%/docs/pmc/array.pod
%%DOCSDIR%%/docs/pmc/iterator.pod
%%DOCSDIR%%/docs/pmc/perlarray.pod
@@ -530,6 +529,14 @@ libdata/pkgconfig/parrot.pc
%%DOCSDIR%%/examples/subs/no_retval.pir
%%DOCSDIR%%/examples/subs/pasm_sub1.pasm
%%DOCSDIR%%/examples/subs/single_retval.pir
+%%DOCSDIR%%/examples/tge/branch/lib/Branch.pir
+%%DOCSDIR%%/examples/tge/branch/lib/Leaf.pir
+%%DOCSDIR%%/examples/tge/branch/branch.g
+%%DOCSDIR%%/examples/tge/branch/transform.pir
+%%DOCSDIR%%/examples/tge/README
+@dirrm %%DOCSDIR%%/examples/tge/branch/lib
+@dirrm %%DOCSDIR%%/examples/tge/branch
+@dirrm %%DOCSDIR%%/examples/tge
@dirrm %%DOCSDIR%%/examples/subs
@dirrm %%DOCSDIR%%/examples/streams
@dirrm %%DOCSDIR%%/examples/shootout