aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLarry Rosenman <ler@FreeBSD.org>2019-10-16 16:25:07 +0000
committerLarry Rosenman <ler@FreeBSD.org>2019-10-16 16:25:07 +0000
commit81fc1d3d05063dc2e6019cc5a77e3cdba78dc48c (patch)
tree97e568304895a8c452e9b7e9381187ae5e5ceaf2
parent6cfd4fba0f167aa6d2ae03c7c93146eb12f38b24 (diff)
downloadports-81fc1d3d05063dc2e6019cc5a77e3cdba78dc48c.tar.gz
ports-81fc1d3d05063dc2e6019cc5a77e3cdba78dc48c.zip
Notes
-rw-r--r--mail/dovecot/Makefile2
-rw-r--r--mail/dovecot/files/patch-src_master_main.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/mail/dovecot/Makefile b/mail/dovecot/Makefile
index 4b2b9f6dc63f..8ff34e46b23f 100644
--- a/mail/dovecot/Makefile
+++ b/mail/dovecot/Makefile
@@ -9,7 +9,7 @@
PORTNAME= dovecot
PORTVERSION= 2.3.8
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail
MASTER_SITES= https://dovecot.org/releases/2.3/
diff --git a/mail/dovecot/files/patch-src_master_main.c b/mail/dovecot/files/patch-src_master_main.c
new file mode 100644
index 000000000000..8173c702f91a
--- /dev/null
+++ b/mail/dovecot/files/patch-src_master_main.c
@@ -0,0 +1,11 @@
+--- src/master/main.c.orig 2018-11-23 11:06:45 UTC
++++ src/master/main.c
+@@ -862,6 +862,8 @@ int main(int argc, char *argv[])
+ i_fatal("dup2(dev_null_fd) failed: %m");
+ if (!foreground && dup2(dev_null_fd, STDOUT_FILENO) < 0)
+ i_fatal("dup2(dev_null_fd) failed: %m");
++ if (!foreground && dup2(dev_null_fd, STDERR_FILENO) < 0)
++ i_fatal("dup2(dev_null_fd) failed: %m");
+
+ pidfile_path =
+ i_strconcat(set->base_dir, "/"MASTER_PID_FILE_NAME, NULL);