aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-06-18 03:49:09 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-06-18 03:49:09 +0000
commit836c2938d13dd8f3de8529a539c0e99b8b132537 (patch)
tree011ecedd5c814f5703e586c87086601a7a0634a4
parentc4645f731a53ba79207bee6555d94df477deb0fc (diff)
downloadports-836c2938d13dd8f3de8529a539c0e99b8b132537.tar.gz
ports-836c2938d13dd8f3de8529a539c0e99b8b132537.zip
Notes
-rw-r--r--databases/fastdb/Makefile8
-rw-r--r--databases/galera/Makefile11
-rw-r--r--databases/hamsterdb/Makefile6
-rw-r--r--databases/postgresql-plruby/Makefile6
-rw-r--r--databases/rocksdb/Makefile3
-rw-r--r--deskutils/easystroke/Makefile4
-rw-r--r--deskutils/gnome-clocks/Makefile2
-rw-r--r--deskutils/showdown/Makefile2
-rw-r--r--deskutils/xneur/Makefile4
-rw-r--r--devel/aarch64-none-elf-gcc/Makefile1
-rw-r--r--devel/astyle/Makefile2
-rw-r--r--devel/bcc/Makefile5
-rw-r--r--devel/catch/Makefile2
-rw-r--r--devel/chromium-gn/Makefile2
-rw-r--r--devel/cltune/Makefile7
-rw-r--r--devel/codeblocks/Makefile2
-rw-r--r--devel/concurrencykit/Makefile7
-rw-r--r--devel/cpprestsdk/Makefile5
-rw-r--r--devel/cquery/Makefile2
-rw-r--r--devel/doxygen/Makefile2
-rw-r--r--devel/eric6/Makefile4
-rw-r--r--devel/flatbuffers/Makefile2
-rw-r--r--devel/fuzzylite/Makefile2
-rw-r--r--devel/gearmand-devel/Makefile7
-rw-r--r--devel/gearmand/Makefile7
-rw-r--r--devel/gitg0/Makefile2
-rw-r--r--devel/jna/Makefile1
-rw-r--r--devel/libosmocore/Makefile2
-rw-r--r--devel/libspice-server/Makefile2
-rw-r--r--devel/llbuild/Makefile2
-rw-r--r--devel/mongo-cxx-driver/Makefile1
-rw-r--r--devel/py-bullet3/Makefile2
-rw-r--r--devel/py-pip-tools/Makefile4
-rw-r--r--devel/rlvm/Makefile2
-rw-r--r--devel/ruby-qtruby-kde4/Makefile2
-rw-r--r--devel/smack/Makefile2
-rw-r--r--devel/thrift/Makefile2
-rw-r--r--devel/uatraits/Makefile2
-rw-r--r--dns/dnsdbq/Makefile2
-rw-r--r--dns/mdnsd/Makefile2
-rw-r--r--editors/pdfedit/Makefile5
-rw-r--r--editors/tea/Makefile2
-rw-r--r--finance/quickfix/Makefile2
43 files changed, 108 insertions, 36 deletions
diff --git a/databases/fastdb/Makefile b/databases/fastdb/Makefile
index 9cf98e3e47b8..658b44686a61 100644
--- a/databases/fastdb/Makefile
+++ b/databases/fastdb/Makefile
@@ -12,9 +12,7 @@ COMMENT= Main Memory Relational Database Management System
LICENSE= MIT
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
-OPTIONS_DEFINE= DOCS
+BROKEN_powerpc64= fails to compile: unrecognized command line option "-std=gnu++03"
USES= gmake dos2unix
USE_GCC= any
@@ -24,6 +22,10 @@ USE_LDCONFIG= yes
DOS2UNIX_FILES= ${MAKEFILE}
CXXFLAGS+= -D_WANT_SEMUN
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+OPTIONS_DEFINE= DOCS
+
PORTDOCS= FastDB.htm
# The port does not build with C++11 or later (bug 219275).
diff --git a/databases/galera/Makefile b/databases/galera/Makefile
index 5d6659f6aa4c..56f759042f04 100644
--- a/databases/galera/Makefile
+++ b/databases/galera/Makefile
@@ -3,8 +3,8 @@
PORTNAME= galera
PORTVERSION?= 25.3.23
-PORTREVISION= 1
DISTVERSIONPREFIX?= release_
+PORTREVISION= 1
CATEGORIES= databases
MAINTAINER= devel@galeracluster.com
@@ -12,15 +12,12 @@ COMMENT= Synchronous multi-master replication engine
LICENSE= GPLv2
-BUILD_DEPENDS= checkmk:devel/check \
- ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
-LIB_DEPENDS= libboost_date_time.so:devel/boost-libs
-
BROKEN_SSL= openssl-devel
BROKEN_SSL_REASON_openssl-devel= check that SSL devel headers are installed and usable
BROKEN_aarch64= fails to compile: gu_int128.h: use of undeclared identifier '__bswap64_var'
BROKEN_armv6= fails to compile: gu_int128.h: use of undeclared identifier '__bswap64_var'
BROKEN_armv7= fails to compile: gu_int128.h: use of undeclared identifier '__bswap64_var'
+BROKEN_powerpc64= fails to configure: Checking for C library pthread... no
NOT_FOR_ARCHS= i386
# On i386 older versions of clang produce:
# cannot compile this atomic library call yet ... __atomic_add_fetch
@@ -32,6 +29,10 @@ NOT_FOR_ARCHS= i386
# https://tracker.crystax.net/issues/1263
NOT_FOR_ARCHS_REASON_i386=Uses 64 bit atomics that clang cannot generate on i386
+BUILD_DEPENDS= checkmk:devel/check \
+ ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
+LIB_DEPENDS= libboost_date_time.so:devel/boost-libs
+
USES= python:build scons ssl
USE_LDCONFIG= yes
diff --git a/databases/hamsterdb/Makefile b/databases/hamsterdb/Makefile
index f5b21938ddd4..b602dd363bd5 100644
--- a/databases/hamsterdb/Makefile
+++ b/databases/hamsterdb/Makefile
@@ -12,14 +12,16 @@ COMMENT= Lightweight Embedded Database Engine
LICENSE= APACHE20
+BROKEN_powerpc64= fails to configure: checking for the Boost system library... no
+
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
+USES= alias gmake libtool
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-boost=${LOCALBASE}
INSTALL_TARGET= install-strip
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
-USES= alias gmake libtool
-USE_LDCONFIG= yes
HAM_DOCS= README INSTALL ChangeLog TODO AUTHORS CREDITS
diff --git a/databases/postgresql-plruby/Makefile b/databases/postgresql-plruby/Makefile
index 700afcca939c..2bd9e7f67c5d 100644
--- a/databases/postgresql-plruby/Makefile
+++ b/databases/postgresql-plruby/Makefile
@@ -13,14 +13,16 @@ COMMENT= PL/Ruby procedural language for the PostgreSQL database system
LICENSE= BSD2CLAUSE RUBY
LICENSE_COMB= dual
-USE_GITHUB= yes
-GH_ACCOUNT= devrimgunduz
+BROKEN_powerpc64= fails to build: ruby.h:628:35: call to 'ruby_safe_level_2_error' declared with attribute error: $SAFE=2 to 4 are obsolete
USES= uidfix pgsql
WANT_PGSQL= server
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
+USE_GITHUB= yes
+GH_ACCOUNT= devrimgunduz
+
POSTGRESQL_PORT?= databases/postgresql${PGSQL_VER_NODOT}-server
PGSQL_PORTDIR?= ${PORTSDIR}/${POSTGRESQL_PORT}
PGSQL_WRKSRC_CMD= cd ${PGSQL_PORTDIR} && ${MAKE} -V WRKSRC
diff --git a/databases/rocksdb/Makefile b/databases/rocksdb/Makefile
index 8e4f53081159..af13cb377217 100644
--- a/databases/rocksdb/Makefile
+++ b/databases/rocksdb/Makefile
@@ -17,6 +17,7 @@ LICENSE_FILE_GPLv2= ${WRKSRC}/COPYING
BROKEN_DragonFly= does not build on DragonFly BSD using GCC with -Werror
BROKEN_armv6?= does not build: db/c.cc:2281:44: implicit conversion loses integer precision: 'uint64_t' (aka 'unsigned long long') to 'size_t' (aka 'unsigned int')
BROKEN_armv7?= does not build: /nxb-bin/usr/bin/ld: undefined reference to symbol `__gnu_Unwind_Find_exidx@@FBSD_1.4' (try adding -lc) #'`
+BROKEN_powerpc64= does not build: util/crc32c.cc:435:22: 'arch_ppc_probe' was not declared in this scope
BUILD_DEPENDS= bash:shells/bash
LIB_DEPENDS= libgflags.so:devel/gflags \
@@ -25,6 +26,7 @@ LIB_DEPENDS= libgflags.so:devel/gflags \
OPTIONS_DEFINE= DEBUG LZ4 ZSTD
OPTIONS_DEFAULT=LZ4
+USES= compiler:c++11-lib gmake localbase:ldflags shebangfix
ALL_TARGET= shared_lib static_lib all
CFLAGS+= -DOS_FREEBSD
CONFIGURE_ARGS= make_config.mk
@@ -34,7 +36,6 @@ HAS_CONFIGURE= yes
MAKE_ENV= CXX=${CXX} INSTALL_PATH=${STAGEDIR}${PREFIX}
USE_CXXSTD= c++11
USE_LDCONFIG= yes
-USES= compiler:c++11-lib gmake localbase:ldflags shebangfix
PLIST_SUB= PORTVERSION=${PORTVERSION} SHLIB_MAJOR=${PORTVERSION:R:R} SHLIB_MINOR=${PORTVERSION:R:E}
PORTDATA= make_config.mk
diff --git a/deskutils/easystroke/Makefile b/deskutils/easystroke/Makefile
index 69e500216127..8062399443b8 100644
--- a/deskutils/easystroke/Makefile
+++ b/deskutils/easystroke/Makefile
@@ -13,15 +13,17 @@ COMMENT= Easystroke is a gesture-recognition application for X11
LICENSE= ISCL
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_powerpc64= fails to build: handler.cc:560:27: call of overloaded 'abs(float&)' is ambiguous
+
BUILD_DEPENDS= help2man:misc/help2man \
${LOCALBASE}/include/xorg/xserver-properties.h:x11-servers/xorg-server
LIB_DEPENDS= libdbus-1.so:devel/dbus \
libdbus-glib-1.so:devel/dbus-glib \
libboost_serialization.so:devel/boost-libs
+USES= compiler:c++11-lang gettext gmake pkgconfig
USE_GNOME= gtkmm30
USE_XORG= x11 xext xfixes xi xtst
-USES= compiler:c++11-lang gettext gmake pkgconfig
USE_CXXSTD= c++11
INSTALLS_ICONS= yes
diff --git a/deskutils/gnome-clocks/Makefile b/deskutils/gnome-clocks/Makefile
index 18384bb2dceb..1103e5e2c01d 100644
--- a/deskutils/gnome-clocks/Makefile
+++ b/deskutils/gnome-clocks/Makefile
@@ -13,6 +13,8 @@ COMMENT= Clocks for GNOME 3
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc64= fails to compile: unrecognized command line option "-Wno-unused-but-set-variable"
+
BUILD_DEPENDS= itstool:textproc/itstool \
vala:lang/vala
LIB_DEPENDS= libgeoclue-2.so:net/geoclue \
diff --git a/deskutils/showdown/Makefile b/deskutils/showdown/Makefile
index 8282681522cf..c7e1102518fd 100644
--- a/deskutils/showdown/Makefile
+++ b/deskutils/showdown/Makefile
@@ -10,6 +10,8 @@ COMMENT= Simple markdown viewer, written in Vala and GTK 3
LICENSE= GPLv3
+BROKEN_powerpc64= fails to compile: unrecognized command line option "-Wno-incompatible-pointer-types"
+
BUILD_DEPENDS= ${LOCALBASE}/lib/libmarkdown.a:textproc/discount \
valac:lang/vala
LIB_DEPENDS= libsoup-2.4.so:devel/libsoup \
diff --git a/deskutils/xneur/Makefile b/deskutils/xneur/Makefile
index 8bd31e1b7fbb..6180149f3499 100644
--- a/deskutils/xneur/Makefile
+++ b/deskutils/xneur/Makefile
@@ -3,8 +3,8 @@
PORTNAME= xneur
PORTVERSION= 0.17.0
-PORTREVISION= 4
DISTVERSIONSUFFIX=.orig
+PORTREVISION= 4
CATEGORIES= deskutils
MASTER_SITES= https://launchpad.net/~andrew-crew-kuznetsov/+archive/xneur-stable/+files/
DISTNAME= ${PORTNAME}_${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
@@ -14,6 +14,8 @@ COMMENT= Auto keyboard switcher
LICENSE= GPLv2
+BROKEN_powerpc64= fails to compile: text.c:272: nested functions are disabled, use -fnested-functions to re-enable
+
LIB_DEPENDS= libnotify.so:devel/libnotify \
libpcre.so:devel/pcre
diff --git a/devel/aarch64-none-elf-gcc/Makefile b/devel/aarch64-none-elf-gcc/Makefile
index f168c4b23233..cc4ec996f8df 100644
--- a/devel/aarch64-none-elf-gcc/Makefile
+++ b/devel/aarch64-none-elf-gcc/Makefile
@@ -12,6 +12,7 @@ INSTALL_TARGET= install-gcc install-target-libgcc
BROKEN_aarch64= fails to package
BROKEN_mips= configure: error: cannot compute suffix of object files: cannot compile
BROKEN_mips64= configure: error: cannot compute suffix of object files: cannot compile
+BROKEN_powerpc64= fails to compile: libgcc2.c:1846:9: internal compiler error: Segmentation fault
MASTERDIR= ${.CURDIR}/../powerpc64-gcc
diff --git a/devel/astyle/Makefile b/devel/astyle/Makefile
index 724bcdfefa6c..4399db6c5698 100644
--- a/devel/astyle/Makefile
+++ b/devel/astyle/Makefile
@@ -13,6 +13,8 @@ COMMENT= Source code indenter and formatter for C, C++, C\#, and Java
LICENSE= MIT
LICENSE_FILE= ${WRKDIR}/astyle/LICENSE.md
+BROKEN_powerpc64= fails to build: unrecognized command line option "-std=c++11"
+
USES= compiler:c++11-lang dos2unix gmake
ALL_TARGET= astyle
diff --git a/devel/bcc/Makefile b/devel/bcc/Makefile
index c9bda2d758ea..a347dcd525aa 100644
--- a/devel/bcc/Makefile
+++ b/devel/bcc/Makefile
@@ -13,10 +13,11 @@ COMMENT= Bruce's C compiler (with as and ld); can do 16-bit code
LICENSE= GPLv2
+BROKEN_aarch64= fails to link: error adding symbols: File in wrong format
+BROKEN_powerpc64= fails to link: skipping incompatible /usr/lib/libgcc.a when searching for -lgcc
+
USES= uidfix
CONFLICTS= bin86-[0-9]* dev86-[0-9]*
-BROKEN_aarch64= Fails to link: error adding symbols: File in wrong format
-
.include <bsd.port.mk>
diff --git a/devel/catch/Makefile b/devel/catch/Makefile
index e5d10069ee31..d51172c71dfb 100644
--- a/devel/catch/Makefile
+++ b/devel/catch/Makefile
@@ -12,6 +12,8 @@ COMMENT= Header-only test framework for C++
LICENSE= BSL
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+BROKEN_powerpc64= fails to compile: catch_tostring.cpp:206:21: comparison is always true due to limited range of data type
+
USES= compiler:c++14-lang cmake pathfix
USE_GITHUB= yes
GH_ACCOUNT= catchorg
diff --git a/devel/chromium-gn/Makefile b/devel/chromium-gn/Makefile
index 78d52dfeb5b3..acca739825da 100644
--- a/devel/chromium-gn/Makefile
+++ b/devel/chromium-gn/Makefile
@@ -8,6 +8,8 @@ COMMENT= Gn meta build framework
MASTERDIR= ${.CURDIR}/../../www/chromium
+BROKEN_powerpc64= fails to compile: safe_math_clang_gcc_impl.h:132:45: '__builtin_subcb' was not declared in this scope
+
BUILDTYPE= Release
NO_BUILD= yes
diff --git a/devel/cltune/Makefile b/devel/cltune/Makefile
index e394422ab1fb..280a3134fc0d 100644
--- a/devel/cltune/Makefile
+++ b/devel/cltune/Makefile
@@ -11,17 +11,18 @@ COMMENT= Library to tune OpenCL kernels
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_powerpc64= fails to build: GCC version must be at least 4.7
+
BUILD_DEPENDS= opencl>=0:devel/opencl
LIB_DEPENDS= libOpenCL.so:devel/ocl-icd
RUN_DEPENDS= opencl>=0:devel/opencl
+USES= cmake
+USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= CNugteren
GH_PROJECT= CLTune
-USE_LDCONFIG= yes
-USES= cmake
-
PLIST_FILES= include/cltune.h \
lib/libcltune.so \
libdata/pkgconfig/cltune.pc
diff --git a/devel/codeblocks/Makefile b/devel/codeblocks/Makefile
index 60939364122d..e716904a067e 100644
--- a/devel/codeblocks/Makefile
+++ b/devel/codeblocks/Makefile
@@ -14,6 +14,8 @@ COMMENT= Open source, cross-platform, free C/C++ IDE
LICENSE= GPLv3 LGPL3
LICENSE_COMB= multi
+BROKEN_powerpc64= fails to configure: checking for exit in -lboost_system-boost_system... no
+
BUILD_DEPENDS= zip:archivers/zip
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libfontconfig.so:x11-fonts/fontconfig \
diff --git a/devel/concurrencykit/Makefile b/devel/concurrencykit/Makefile
index 45507bc244b9..a89568d9a467 100644
--- a/devel/concurrencykit/Makefile
+++ b/devel/concurrencykit/Makefile
@@ -15,9 +15,10 @@ LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
ONLY_FOR_ARCHS= aarch64 amd64 armv6 armv7 i386 powerpc powerpc64 sparc64
-BROKEN_aarch64= Fails to configure: Detecting machine architecture...failed [unsupported]
-BROKEN_armv6= Fails to configure: Finding suitable compiler........failed [not found]
-BROKEN_armv7= Fails to configure: Finding suitable compiler........failed [not found]
+BROKEN_aarch64= fails to configure: Detecting machine architecture...failed [unsupported]
+BROKEN_armv6= fails to configure: Finding suitable compiler........failed [not found]
+BROKEN_armv7= fails to configure: Finding suitable compiler........failed [not found]
+BROKEN_powerpc64= fails to link: skipping incompatible /usr/lib/libgcc.a when searching for -lgcc
OPTIONS_DEFINE= RTM VMAPACK
OPTIONS_DEFAULT= VMAPACK
diff --git a/devel/cpprestsdk/Makefile b/devel/cpprestsdk/Makefile
index 917493ae76fa..1b6d5c16519c 100644
--- a/devel/cpprestsdk/Makefile
+++ b/devel/cpprestsdk/Makefile
@@ -14,11 +14,10 @@ LICENSE_FILE= ${WRKSRC}/../license.txt
LIB_DEPENDS= libboost_system.so:devel/boost-libs
-USE_GITHUB= yes
-GH_ACCOUNT= Microsoft
-
USES= cmake compiler:c++11-lib ssl
USE_LDCONFIG= yes
+USE_GITHUB= yes
+GH_ACCOUNT= Microsoft
WRKSRC_SUBDIR= Release
CMAKE_OFF= BUILD_SAMPLES BUILD_TESTS
diff --git a/devel/cquery/Makefile b/devel/cquery/Makefile
index 7047cfe19adf..e042ba9bc290 100644
--- a/devel/cquery/Makefile
+++ b/devel/cquery/Makefile
@@ -10,6 +10,8 @@ COMMENT= Highly-scalable, low-latency language server for C/C++/Objective-C
LICENSE= MIT
+BROKEN_powerpc64= fails to build: Checking for 'clang++' (C++ compiler): not found
+
BUILD_DEPENDS= llvm-config60:devel/llvm60
LIB_DEPENDS= libclang.so:devel/llvm60
diff --git a/devel/doxygen/Makefile b/devel/doxygen/Makefile
index f5819c84b53e..de198bdcb1be 100644
--- a/devel/doxygen/Makefile
+++ b/devel/doxygen/Makefile
@@ -15,6 +15,8 @@ COMMENT= Documentation system for C, C++, and other languages
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_powerpc64= fails to link: ../lib/lib_doxygen.a(language.cpp.o)(.text+0xb6c): sibling call optimization to `_ZN12ConfigValuesD1Ev' does not allow automatic multiple TOCs
+
USES= bison cmake:outsource,noninja iconv python shebangfix
ALL_TARGET= all
CMAKE_ARGS+= -DDOC_INSTALL_DIR:PATH=${DOCSDIR_REL}
diff --git a/devel/eric6/Makefile b/devel/eric6/Makefile
index c1eb4105a19c..9dda49c0ed33 100644
--- a/devel/eric6/Makefile
+++ b/devel/eric6/Makefile
@@ -2,8 +2,10 @@
# $FreeBSD$
PKGNAMESUFFIX= -${FLAVOR:U:S/_/-/}
-CATEGORIES= devel python
DISTNAME= ${PORTNAME}-nolang-${DISTVERSION}
+CATEGORIES= devel python
+
+BROKEN_powerpc64= fails to link: libstdc++.so.6: version GLIBCXX_3.4.14 required by /usr/local/lib/qt4/libqscintilla2_qt4.so.13 not found
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/PyQt${PYQTVER}/QtGui.so:x11-toolkits/py-qt${PYQTVER}-gui@${PY_FLAVOR} \
${PYTHON_SITELIBDIR}/PyQt${PYQTVER}/Qsci.so:devel/py-qt${PYQTVER}-qscintilla2@${PY_FLAVOR}
diff --git a/devel/flatbuffers/Makefile b/devel/flatbuffers/Makefile
index 857422adb1fc..568c15455d62 100644
--- a/devel/flatbuffers/Makefile
+++ b/devel/flatbuffers/Makefile
@@ -12,6 +12,8 @@ COMMENT= Memory efficient serialization library
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+BROKEN_powerpc64= fails to compile: base.h:189:32: use of deleted function flatbuffers::EndianSwap(T)
+
USES= cmake:outsource compiler:c++11-lib
USE_LDCONFIG= yes
USE_GITHUB= yes
diff --git a/devel/fuzzylite/Makefile b/devel/fuzzylite/Makefile
index ac471746793d..a6802b12222f 100644
--- a/devel/fuzzylite/Makefile
+++ b/devel/fuzzylite/Makefile
@@ -11,6 +11,8 @@ COMMENT= Fuzzy logic control library in C++
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_powerpc64= fails to compile: unrecognized command line option "-Wno-type-limits"
+
USES= cmake:outsource compiler
USE_GITHUB= yes
USE_LDCONFIG= yes
diff --git a/devel/gearmand-devel/Makefile b/devel/gearmand-devel/Makefile
index f70dde3c1166..3a3a541804f7 100644
--- a/devel/gearmand-devel/Makefile
+++ b/devel/gearmand-devel/Makefile
@@ -11,6 +11,9 @@ PKGNAMESUFFIX= -devel
MAINTAINER= bdrewery@FreeBSD.org
COMMENT= Gearman C Server and Library
+BROKEN_sparc64= fails to build: cannot link with boost
+BROKEN_powerpc64= fails to build: checking for the Boost program_options library... no
+
BUILD_DEPENDS= boost-libs>=0:devel/boost-libs \
${PYTHON_PKGNAMEPREFIX}sphinx>=0:textproc/py-sphinx@${PY_FLAVOR}
LIB_DEPENDS= libevent.so:devel/libevent \
@@ -21,11 +24,9 @@ CONFLICTS= p5-Gearman-Server-1.* gearmand-1.0.*
USERS= gearmand
GROUPS= gearmand
-BROKEN_sparc64= Does not build: cannot link with boost
-
+USES= pathfix perl5 gmake gperf libtool python:build
USE_PERL5= build
GNU_CONFIGURE= yes
-USES= pathfix perl5 gmake gperf libtool python:build
USE_LDCONFIG= yes
USE_RC_SUBR= gearmand
SUB_LIST+= USERS=${USERS} GROUPS=${GROUPS}
diff --git a/devel/gearmand/Makefile b/devel/gearmand/Makefile
index 15bc9cbcf677..e826890def64 100644
--- a/devel/gearmand/Makefile
+++ b/devel/gearmand/Makefile
@@ -10,6 +10,9 @@ MASTER_SITES= http://launchpad.net/gearmand/1.0/${PORTVERSION}/+download/
MAINTAINER= bdrewery@FreeBSD.org
COMMENT= Gearman C Server and Library
+BROKEN_sparc64= fails to build: cannot link with boost
+BROKEN_powerpc64= fails to build: checking for the Boost program_options library... no
+
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=0:textproc/py-sphinx@${PY_FLAVOR}
LIB_DEPENDS= libboost_program_options.so:devel/boost-libs \
libevent.so:devel/libevent \
@@ -20,11 +23,9 @@ CONFLICTS= p5-Gearman-Server-1.* gearmand-1.1.*
USERS= gearmand
GROUPS= gearmand
-BROKEN_sparc64= Does not build: cannot link with boost
-
+USES= pathfix gmake perl5 python:build libtool
USE_PERL5= build
GNU_CONFIGURE= yes
-USES= pathfix gmake perl5 python:build libtool
USE_LDCONFIG= yes
USE_RC_SUBR= gearmand
SUB_LIST+= USERS=${USERS} GROUPS=${GROUPS}
diff --git a/devel/gitg0/Makefile b/devel/gitg0/Makefile
index 5f8ebaaa1a0a..fc9d9d5a99af 100644
--- a/devel/gitg0/Makefile
+++ b/devel/gitg0/Makefile
@@ -14,6 +14,8 @@ COMMENT= GTK-based git repository viewer (gtk2 version)
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc64= fails to link: gitg-branch-actions.o(.text+0x46c): unresolvable R_PPC64_REL24 relocation against symbol gitg_revision_get_subject
+
RUN_DEPENDS= git:devel/git
CONFLICTS= gitg-[0-9]*
diff --git a/devel/jna/Makefile b/devel/jna/Makefile
index 0ed2471500d1..47d4691e2548 100644
--- a/devel/jna/Makefile
+++ b/devel/jna/Makefile
@@ -15,6 +15,7 @@ LICENSE_FILE_APACHE20= ${WRKSRC}/LICENSE.AL
BROKEN_armv6= fails to compile: build.xml: compilation failed
BROKEN_armv7= fails to compile: build.xml: compilation failed
+BROKEN_powerpc64= fails to compile: unrecognized command line option "-Wno-unknown-warning-option"
USES= autoreconf:build gmake libtool
USE_ANT= yes
diff --git a/devel/libosmocore/Makefile b/devel/libosmocore/Makefile
index d1cd8179533b..df38835e4875 100644
--- a/devel/libosmocore/Makefile
+++ b/devel/libosmocore/Makefile
@@ -13,6 +13,8 @@ COMMENT= Common library for all Osmocom projects
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc64= fails to compile: application.c:179: #pragma GCC diagnostic not allowed inside functions
+
LIB_DEPENDS= libpcsclite.so:devel/pcsc-lite \
libtalloc.so:devel/talloc
diff --git a/devel/libspice-server/Makefile b/devel/libspice-server/Makefile
index 997df93c694e..8cdbfc37be2e 100644
--- a/devel/libspice-server/Makefile
+++ b/devel/libspice-server/Makefile
@@ -13,6 +13,8 @@ COMMENT= Implements the server side of the SPICE protocol
LICENSE= GPLv2
+BROKEN_powerpc64= fails to compile: red-channel-client.h:44: redefinition of typedef 'RedChannelClient'
+
LIB_DEPENDS= libopus.so:audio/opus
BUILD_DEPENDS= spice-protocol>=0.12.10:devel/spice-protocol
diff --git a/devel/llbuild/Makefile b/devel/llbuild/Makefile
index 53c7ddf8a189..ffa4cc9d3926 100644
--- a/devel/llbuild/Makefile
+++ b/devel/llbuild/Makefile
@@ -13,6 +13,8 @@ LICENSE= APACHE20 BSD3CLAUSE NCSA
LICENSE_COMB= multi
LICENSE_FILE_APACHE20= ${WRKSRC}/LICENSE.txt
+BROKEN_powerpc64= fails to compile: unrecognized command line option "-Wdocumentation"
+
LIB_DEPENDS= libsqlite3.so:databases/sqlite3
USES= cmake:outsource
diff --git a/devel/mongo-cxx-driver/Makefile b/devel/mongo-cxx-driver/Makefile
index 086015e8d87d..cf9493c0b599 100644
--- a/devel/mongo-cxx-driver/Makefile
+++ b/devel/mongo-cxx-driver/Makefile
@@ -15,6 +15,7 @@ LICENSE_FILE= ${WRKSRC}/APACHE-2.0.txt
BROKEN_SSL= openssl-devel
BROKEN_SSL_REASON_openssl-devel= use of undeclared identifier 'BIO_s_file_internal'
+BROKEN_powerpc64= fails to configure: Checking for C++ library boost_regex... no
LIB_DEPENDS= libboost_system.so:devel/boost-libs
diff --git a/devel/py-bullet3/Makefile b/devel/py-bullet3/Makefile
index 0d5082bb6d66..43b08c2a48a4 100644
--- a/devel/py-bullet3/Makefile
+++ b/devel/py-bullet3/Makefile
@@ -11,6 +11,8 @@ COMMENT= Python version of 3D collision detection library Bullet
LICENSE= ZLIB
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+BROKEN_powerpc64= fails to compile: FontData.h:265:1: narrowing conversion of '-96' from 'int' to 'char' inside { }
+
USES= compiler:c++11-lang localbase python
USE_GITHUB= yes
GH_ACCOUNT= bulletphysics
diff --git a/devel/py-pip-tools/Makefile b/devel/py-pip-tools/Makefile
index 9916aaacb838..615f0b0b2124 100644
--- a/devel/py-pip-tools/Makefile
+++ b/devel/py-pip-tools/Makefile
@@ -13,14 +13,16 @@ COMMENT= Keep your pinned dependencies fresh
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_powerpc64= fails to compile: UnicodeDecodeError: 'ascii' codec can't decode byte 0xe2 in position 6865: ordinal not in range(128)
+
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=0:devel/py-setuptools_scm@${FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>=6:devel/py-click@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}first>=0:devel/py-first@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${FLAVOR}
NO_ARCH= yes
+USES= python
USE_LOCALE= en_US.UTF-8
USE_PYTHON= autoplist concurrent distutils
-USES= python
.include <bsd.port.mk>
diff --git a/devel/rlvm/Makefile b/devel/rlvm/Makefile
index 60897005c790..4d8b0f60ca25 100644
--- a/devel/rlvm/Makefile
+++ b/devel/rlvm/Makefile
@@ -13,6 +13,8 @@ COMMENT= RealLive virtual machine clone
LICENSE= GPLv2 GPLv3 MIT
LICENSE_COMB= multi
+BROKEN_powerpc64= fails to link: gcn_platform.cc: undefined reference to gcn::Exception::Exception
+
BUILD_DEPENDS= ${LOCALBASE}/include/utf8.h:devel/utf8cpp
LIB_DEPENDS= libvorbisfile.so:audio/libvorbis \
libboost_serialization.so:devel/boost-libs \
diff --git a/devel/ruby-qtruby-kde4/Makefile b/devel/ruby-qtruby-kde4/Makefile
index afdaf40fd80d..8f162becd519 100644
--- a/devel/ruby-qtruby-kde4/Makefile
+++ b/devel/ruby-qtruby-kde4/Makefile
@@ -9,6 +9,8 @@ PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
MAINTAINER= kde@FreeBSD.org
COMMENT= Ruby bindings for Qt
+BROKEN_powerpc64= fails to compile: ruby.h:1381: wrong number of arguments specified for '__deprecated__' attribute
+
LIB_DEPENDS= libqwt.so:x11-toolkits/qwt5 \
libqscintilla2_qt4.so:devel/qscintilla2
diff --git a/devel/smack/Makefile b/devel/smack/Makefile
index b72f417f7fe4..6e531b08f025 100644
--- a/devel/smack/Makefile
+++ b/devel/smack/Makefile
@@ -11,6 +11,8 @@ COMMENT= Low-level I/O storage library which packs data
LICENSE= GPLv2
+BROKEN_powerpc64= fails to build: libboost_filesystem.so: undefined reference to std::__cxx11::basic_string
+
LIB_DEPENDS= libboost_iostreams.so:devel/boost-libs \
libsnappy.so:archivers/snappy
diff --git a/devel/thrift/Makefile b/devel/thrift/Makefile
index f84b796e9543..6e88cebf4363 100644
--- a/devel/thrift/Makefile
+++ b/devel/thrift/Makefile
@@ -12,6 +12,8 @@ COMMENT= Framework for scalable cross-language services development
LICENSE= APACHE20
+BROKEN_powerpc64= fails to compile: unrecognized command line option "-Wno-c++11-long-long"
+
USES= autoreconf libtool pkgconfig
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/devel/uatraits/Makefile b/devel/uatraits/Makefile
index fddcf7af2577..7c09245a536d 100644
--- a/devel/uatraits/Makefile
+++ b/devel/uatraits/Makefile
@@ -10,6 +10,8 @@ MASTER_SITES= http://people.freebsd.org/~demon/
MAINTAINER= demon@FreeBSD.org
COMMENT= User-Agent detection library
+BROKEN_powerpc64= fails to link: checking linkage with boost::test... no
+
LIB_DEPENDS= ${PY_BOOST} \
libpcre.so:devel/pcre \
libxml2.so:textproc/libxml2
diff --git a/dns/dnsdbq/Makefile b/dns/dnsdbq/Makefile
index 3b29abb05754..4f9dc734471a 100644
--- a/dns/dnsdbq/Makefile
+++ b/dns/dnsdbq/Makefile
@@ -13,6 +13,8 @@ LICENSE_COMB= multi
LICENSE_FILE_APACHE20= ${WRKSRC}/Apache-2.0
LICENSE_FILE_ISCL= ${WRKSRC}/ISC
+BROKEN_powerpc64= fails to compile: dnsdbq.c:817: passing argument 1 of 'curl_global_init' with different width due to prototype
+
LIB_DEPENDS= libjansson.so:devel/jansson \
libcurl.so:ftp/curl
diff --git a/dns/mdnsd/Makefile b/dns/mdnsd/Makefile
index a3b9826cab5d..1d2f49eb6105 100644
--- a/dns/mdnsd/Makefile
+++ b/dns/mdnsd/Makefile
@@ -15,6 +15,8 @@ COMMENT= Advertise a service via Rendezvous
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_powerpc64= fails to compile: unrecognized command line option "-Wpedantic"
+
USES= cmake:outsource
USE_GITHUB= yes
GH_ACCOUNT= Pro
diff --git a/editors/pdfedit/Makefile b/editors/pdfedit/Makefile
index f519edfda018..18265cc60783 100644
--- a/editors/pdfedit/Makefile
+++ b/editors/pdfedit/Makefile
@@ -12,6 +12,9 @@ COMMENT= PDF document manipulating library
LICENSE= GPLv2
+BROKEN_powerpc64= fails to configure: error: Could not link against boost_program_options
+BROKEN_sparc64= fails to configure: error: Could not link against boost_program_options
+
LIB_DEPENDS= libboost_filesystem.so:devel/boost-libs \
libfreetype.so:print/freetype2 \
libpng.so:graphics/png \
@@ -34,8 +37,6 @@ PORTDOCS= Changelog README AUTHORS
OPTIONS_DEFINE= DOCS
-BROKEN_sparc64= Fails to configure: error: Could not link against boost_program_options
-
post-extract:
${INSTALL_DATA} ${WRKSRC}/doc/AUTHORS ${WRKSRC}
diff --git a/editors/tea/Makefile b/editors/tea/Makefile
index 5dc558d52c71..41a1acdc1033 100644
--- a/editors/tea/Makefile
+++ b/editors/tea/Makefile
@@ -11,6 +11,8 @@ COMMENT= Simple and powerful Qt-based text editor
LICENSE= GPLv3
+BROKEN_powerpc64= fails to link: spellchecker.o:(.text+0xd2c): undefined reference to Hunspell::remove(std::string const&)
+
OPTIONS_SINGLE= TOOLKITS
OPTIONS_SINGLE_TOOLKITS= QT4 QT5
OPTIONS_DEFINE= DOCS
diff --git a/finance/quickfix/Makefile b/finance/quickfix/Makefile
index 578a30e94dec..f1a3ea4114df 100644
--- a/finance/quickfix/Makefile
+++ b/finance/quickfix/Makefile
@@ -11,6 +11,8 @@ COMMENT= Free FIX Protocol Implementation
LICENSE= GPLv3+
+BROKEN_powerpc64= fails to configure: unable to find set_terminate in std or global namespace
+
BUILD_DEPENDS= bash:shells/bash
USES= gmake iconv libtool shebangfix ssl