aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2015-08-30 18:59:14 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2015-08-30 18:59:14 +0000
commit886e433c254f2783204ea6e6c950b8c5c60058e7 (patch)
treed402967793afe24a9befd825242ee667e61ad92e
parent1a5cc4cef4c923e74f266db1b2b278376fdc7c79 (diff)
downloadports-886e433c254f2783204ea6e6c950b8c5c60058e7.tar.gz
ports-886e433c254f2783204ea6e6c950b8c5c60058e7.zip
Notes
-rw-r--r--www/midori/Makefile62
-rw-r--r--www/midori/distinfo4
-rw-r--r--www/midori/files/patch-CMakeLists.txt10
-rw-r--r--www/midori/files/patch-midori__midori-stock.h8
-rw-r--r--www/midori/pkg-plist10
5 files changed, 42 insertions, 52 deletions
diff --git a/www/midori/Makefile b/www/midori/Makefile
index 831f78ce8220..fed9ac0528d7 100644
--- a/www/midori/Makefile
+++ b/www/midori/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= midori
-PORTVERSION= 0.5.10
+PORTVERSION= 0.5.11
CATEGORIES= www xfce
-MASTER_SITES= http://www.midori-browser.org/downloads/
-DISTNAME= ${PORTNAME}_${PORTVERSION}_all_
+MASTER_SITES= https://launchpadlibrarian.net/215909491/ \
+ https://launchpad.net/${PORTNAME}/trunk/${PORTVERSION}/+download/
DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
@@ -27,55 +27,31 @@ CFLAGS+= -Wno-return-type
CMAKE_ARGS= -DUSE_APIDOCS:BOOL=OFF \
-DUSE_GRANITE:BOOL=OFF
-#WRKSRC= ${WRKDIR}/${DISTNAME:C/([a-z]*)_([0-9\.]*)(_all_)/\1-\2/}
-NO_WRKSUBDIR= yes
USE_GNOME= glib20 intltool libxml2
USE_XORG= xscrnsaver
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
-USES= desktop-file-utils pkgconfig cmake gettext tar:bzip2
+USES= cmake desktop-file-utils gettext pkgconfig tar:bzip2
USE_SQLITE= yes
PLIST_SUB= VERSION="${PORTVERSION:R}"
-OPTIONS_DEFINE= GIR ZEITGEIST
-OPTIONS_SINGLE= GTK
-OPTIONS_SINGLE_GTK= GTK2 GTK3
-OPTIONS_DEFAULT= GTK2
-GIR_DESC= GObject Introspection
-ZEITGEIST_DESC= User logs activities
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MGTK2}
-LIB_DEPENDS+= libwebkitgtk-1.0.so:${PORTSDIR}/www/webkit-gtk2
-USE_GNOME+= gtk20
-CMAKE_ARGS+= -DUSE_GTK3:BOOL=OFF
-.endif
-
-.if ${PORT_OPTIONS:MGTK3}
-LIB_DEPENDS+= libwebkitgtk-3.0.so:${PORTSDIR}/www/webkit-gtk3
-USE_GNOME+= gtk30
-CMAKE_ARGS+= -DUSE_GTK3:BOOL=ON \
+OPTIONS_DEFINE= GIR GTK3 ZEITGEIST
+OPTIONS_SUB= yes
+GIR_PREVENTS= GTK3
+GIR_USE= gnome=introspection:build
+GIR_CMAKE_ON= -DUSE_GIR:BOOL=ON
+GTK3_LIB_DEPENDS= libwebkitgtk-3.0.so:${PORTSDIR}/www/webkit-gtk3
+GTK3_USE= gnome=gtk30
+GTK3_CMAKE_ON= -DUSE_GTK3:BOOL=ON \
-DHALF_BRO_INCOM_WEBKIT2:BOOL=OFF
-.endif
-
-.if ${PORT_OPTIONS:MZEITGEIST}
-BROKEN= Doesn't build with zeitgeist >= 0.9.0
-LIB_DEPENDS+= libzeitgeist-2.0.so:${PORTSDIR}/sysutils/zeitgeist
-CMAKE_ARGS+= -DUSE_ZEITGEIST:BOOL=ON
-.else
-CMAKE_ARGS+= -DUSE_ZEITGEIST:BOOL=OFF
-.endif
-
-.if ${PORT_OPTIONS:MGIR} && ${PORT_OPTIONS:MGTK2}
-USE_GNOME+= introspection:build
-CMAKE_ARGS+= -DUSE_GIR:BOOL=ON
-PLIST_SUB+= GIR=""
-.else
-CMAKE_ARGS+= -DUSE_GIR:BOOL=OFF
-PLIST_SUB+= GIR="@comment "
-.endif
+GTK3_LIB_DEPENDS_OFF= libwebkitgtk-1.0.so:${PORTSDIR}/www/webkit-gtk2
+GTK3_USE_OFF= gnome=gtk20
+GTK3_CMAKE_OFF= -DUSE_GTK3:BOOL=OFF
+ZEITGEIST_LIB_DEPENDS= libzeitgeist-2.0.so:${PORTSDIR}/sysutils/zeitgeist
+ZEITGEIST_CMAKE_OFF= -DUSE_ZEITGEIST:BOOL=OFF
+GIR_DESC= Install GObject Introspection Reference manual
+ZEITGEIST_DESC= User logs activities
post-patch:
# Avoid errors with CMake
diff --git a/www/midori/distinfo b/www/midori/distinfo
index 0fcd4920997a..1764fb5a2bae 100644
--- a/www/midori/distinfo
+++ b/www/midori/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xfce4/midori_0.5.10_all_.tar.bz2) = 702344f68d7f034866a46398e35b3c16a5a5f3e431a5d916ea5efc3eaaa3e46f
-SIZE (xfce4/midori_0.5.10_all_.tar.bz2) = 1379519
+SHA256 (xfce4/midori-0.5.11.tar.bz2) = 96191a96be71144ae848a409fae5a1d6d52a00e583f33122081f47ead9c49c3d
+SIZE (xfce4/midori-0.5.11.tar.bz2) = 1428791
diff --git a/www/midori/files/patch-CMakeLists.txt b/www/midori/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..8280fae44c62
--- /dev/null
+++ b/www/midori/files/patch-CMakeLists.txt
@@ -0,0 +1,10 @@
+--- CMakeLists.txt.orig 2015-08-30 11:56:26 UTC
++++ CMakeLists.txt
+@@ -263,7 +263,6 @@ if ((CMAKE_C_COMPILER_ID STREQUAL "GNU"
+ OR (CMAKE_C_COMPILER_ID STREQUAL "Clang" AND CMAKE_C_COMPILER_VERSION VERSION_GREATER "3.0.0"))
+ set(VALA_CFLAGS "${VALA_CFLAGS} -Werror=implicit-function-declaration")
+ set(VALA_CFLAGS "${VALA_CFLAGS} -Wno-incompatible-pointer-types")
+- set(VALA_CFLAGS "${VALA_CFLAGS} -Wno-discarded-qualifiers")
+ set(VALA_CFLAGS "${VALA_CFLAGS} -Wno-deprecated-declarations")
+ else ()
+ set(VALA_CFLAGS "${VALA_CFLAGS} -w")
diff --git a/www/midori/files/patch-midori__midori-stock.h b/www/midori/files/patch-midori__midori-stock.h
index 0c16b8c4a7f2..66bf069f6503 100644
--- a/www/midori/files/patch-midori__midori-stock.h
+++ b/www/midori/files/patch-midori__midori-stock.h
@@ -1,10 +1,12 @@
---- midori/midori-stock.h.orig 2015-04-19 23:50:25 UTC
+--- midori/midori-stock.h.orig 2015-08-30 11:56:26 UTC
+++ midori/midori-stock.h
-@@ -21,11 +21,11 @@
+@@ -20,12 +20,12 @@
+ #define MIDORI_STOCK_WEB_BROWSER "web-browser"
#define STOCK_NEWS_FEED "internet-news-reader"
#define STOCK_STYLE "preferences-desktop-theme"
- #define MIDORI_STOCK_TRANSFER "package"
+-#define MIDORI_STOCK_TRANSFER "package"
-#define MIDORI_STOCK_PLUGINS "application-x-shockwave-flash"
++#define MIDORI_STOCK_TRANSFER "package-x-generic"
+#define MIDORI_STOCK_PLUGINS "application-x-addon"
#define STOCK_BOOKMARK_ADD "bookmark-new"
#define STOCK_IMAGE "image-x-generic"
diff --git a/www/midori/pkg-plist b/www/midori/pkg-plist
index 2e9a43a952c7..82edb3820d13 100644
--- a/www/midori/pkg-plist
+++ b/www/midori/pkg-plist
@@ -1,6 +1,8 @@
bin/midori
etc/xdg/midori/extensions/adblock/config
etc/xdg/midori/search
+%%GIR%%lib/girepository-1.0/Katze-%%VERSION%%.typelib
+%%GIR%%lib/girepository-1.0/Midori-%%VERSION%%.typelib
lib/libmidori-core.so
lib/libmidori-core.so.0.0.0
lib/libmidori-core.so.1
@@ -52,6 +54,9 @@ share/icons/hicolor/16x16/status/internet-news-reader.png
share/icons/hicolor/22x22/apps/midori.png
share/icons/hicolor/22x22/categories/extension.png
share/icons/hicolor/22x22/status/internet-news-reader.png
+share/icons/hicolor/24x24/status/adblock-blocked.svg
+share/icons/hicolor/24x24/status/adblock-disabled.svg
+share/icons/hicolor/24x24/status/adblock-enabled.svg
share/icons/hicolor/scalable/apps/midori.svg
share/icons/hicolor/scalable/categories/extension.svg
share/icons/hicolor/scalable/status/internet-news-reader.svg
@@ -94,6 +99,7 @@ share/locale/ka/LC_MESSAGES/midori.mo
share/locale/kk/LC_MESSAGES/midori.mo
share/locale/km/LC_MESSAGES/midori.mo
share/locale/ko/LC_MESSAGES/midori.mo
+share/locale/ku/LC_MESSAGES/midori.mo
share/locale/ky/LC_MESSAGES/midori.mo
share/locale/lb/LC_MESSAGES/midori.mo
share/locale/lt/LC_MESSAGES/midori.mo
@@ -131,15 +137,11 @@ share/locale/zh_HK/LC_MESSAGES/midori.mo
share/locale/zh_TW/LC_MESSAGES/midori.mo
%%DATADIR%%/res/about.css
%%DATADIR%%/res/adblock.list
-%%DATADIR%%/res/adblock/blocked.png
-%%DATADIR%%/res/adblock/disabled.png
%%DATADIR%%/res/adblock/element_hider.js
-%%DATADIR%%/res/adblock/enabled.png
%%DATADIR%%/res/autosuggestcontrol.css
%%DATADIR%%/res/autosuggestcontrol.js
%%DATADIR%%/res/bookmarks/Create.sql
%%DATADIR%%/res/bookmarks/Import_old_db_bookmarks.sql
-%%DATADIR%%/res/close.png
%%DATADIR%%/res/error.html
%%DATADIR%%/res/flummi/Create.sql
%%DATADIR%%/res/forms/Create.sql