aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-15 14:54:28 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-15 14:54:28 +0000
commit8c0396f6bf6d7be65631e467265aed9157882d13 (patch)
treed4687363ee1e7ea8698aa4359100f209aa0cda35
parentea42e87bab0ad8cf32c20f267005fec1ec2ab5f7 (diff)
downloadports-8c0396f6bf6d7be65631e467265aed9157882d13.tar.gz
ports-8c0396f6bf6d7be65631e467265aed9157882d13.zip
Notes
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-SymbolicX-BigNum/Makefile32
-rw-r--r--math/p5-Math-SymbolicX-BigNum/distinfo3
-rw-r--r--math/p5-Math-SymbolicX-BigNum/pkg-descr8
-rw-r--r--math/p5-Math-SymbolicX-BigNum/pkg-plist7
5 files changed, 51 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 9293d4e3b80b..acdb596d758c 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -192,6 +192,7 @@
SUBDIR += p5-Math-Symbolic
SUBDIR += p5-Math-Symbolic-Custom-CCompiler
SUBDIR += p5-Math-Symbolic-Custom-Contains
+ SUBDIR += p5-Math-SymbolicX-BigNum
SUBDIR += p5-Math-SymbolicX-Inline
SUBDIR += p5-Math-SymbolicX-ParserExtensionFactory
SUBDIR += p5-Math-TrulyRandom
diff --git a/math/p5-Math-SymbolicX-BigNum/Makefile b/math/p5-Math-SymbolicX-BigNum/Makefile
new file mode 100644
index 000000000000..35e6c746427a
--- /dev/null
+++ b/math/p5-Math-SymbolicX-BigNum/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Math-SymbolicX-BigNum
+# Date created: 15 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-SymbolicX-BigNum
+PORTVERSION= 0.02
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Big number support for the Math::Symbolic parser
+
+BUILD_DEPENDS= ${SITE_PERL}/Math/Symbolic.pm:${PORTSDIR}/math/p5-Math-Symbolic \
+ ${SITE_PERL}/Math/SymbolicX/ParserExtensionFactory.pm:${PORTSDIR}/math/p5-Math-SymbolicX-ParserExtensionFactory
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Math::SymbolicX::BigNum.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Math-SymbolicX-BigNum/distinfo b/math/p5-Math-SymbolicX-BigNum/distinfo
new file mode 100644
index 000000000000..688caa7d5e23
--- /dev/null
+++ b/math/p5-Math-SymbolicX-BigNum/distinfo
@@ -0,0 +1,3 @@
+MD5 (Math-SymbolicX-BigNum-0.02.tar.gz) = 5ffbf2697105e69901a489780dba9db3
+SHA256 (Math-SymbolicX-BigNum-0.02.tar.gz) = 19b03be11543133266862eb4cca608a208e506135e4f895a983a0f9bdf1c779d
+SIZE (Math-SymbolicX-BigNum-0.02.tar.gz) = 3453
diff --git a/math/p5-Math-SymbolicX-BigNum/pkg-descr b/math/p5-Math-SymbolicX-BigNum/pkg-descr
new file mode 100644
index 000000000000..32be4b024873
--- /dev/null
+++ b/math/p5-Math-SymbolicX-BigNum/pkg-descr
@@ -0,0 +1,8 @@
+This module adds big number support to Math::Symbolic. It does so by
+extending the parser of the Math::Symbolic module (that is, the one stored
+in $Math::Symbolic::Parser) with certain special functions that create
+arbitrary precision constants. (Math::Symbolic::Variable objects have been
+able to contain arbitrary precision objects since the very beginning.)
+
+WWW: http://search.cpan.org/dist/Math-SymbolicX-BigNum
+Author: Steffen Mueller <symbolic-module@steffen-mueller.net>
diff --git a/math/p5-Math-SymbolicX-BigNum/pkg-plist b/math/p5-Math-SymbolicX-BigNum/pkg-plist
new file mode 100644
index 000000000000..dcf1d970017e
--- /dev/null
+++ b/math/p5-Math-SymbolicX-BigNum/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Math/SymbolicX/BigNum.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/SymbolicX/BigNum/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/SymbolicX/BigNum
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/SymbolicX
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrmtry %%SITE_PERL%%/Math/SymbolicX
+@dirrmtry %%SITE_PERL%%/Math