aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2021-09-27 12:44:11 +0000
committerMathieu Arnold <mat@FreeBSD.org>2021-09-27 13:17:16 +0000
commit8ecddd296f08d19694b3f44916b34f544a0e33ec (patch)
treecf52651af3e71266fc02b2ebb044ea686a388716
parent346b04c8748b3cb90c99249be5791e4309e7f4ea (diff)
downloadports-8ecddd296f08d19694b3f44916b34f544a0e33ec.tar.gz
ports-8ecddd296f08d19694b3f44916b34f544a0e33ec.zip
dns/bind916: update to 9.16.21
Changes: https://downloads.isc.org/isc/bind9/9.16.21/doc/arm/html/notes.html#notes-for-bind-9-16-21 (cherry picked from commit fccfb7d4979a04e260ecc162cdcfe54a0feec9b7)
-rw-r--r--dns/bind916/Makefile2
-rw-r--r--dns/bind916/distinfo6
-rw-r--r--dns/bind916/files/extrapatch-bind-min-override-ttl12
3 files changed, 10 insertions, 10 deletions
diff --git a/dns/bind916/Makefile b/dns/bind916/Makefile
index c7c38968d3e7..3265d09cd51d 100644
--- a/dns/bind916/Makefile
+++ b/dns/bind916/Makefile
@@ -40,7 +40,7 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
USES= compiler:c11 cpe libedit pkgconfig ssl tar:xz
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.16.20
+ISCVERSION= 9.16.21
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind916/distinfo b/dns/bind916/distinfo
index 8345629d7896..ce029531078a 100644
--- a/dns/bind916/distinfo
+++ b/dns/bind916/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1629182644
-SHA256 (bind-9.16.20.tar.xz) = 4d0d93c0d0b63080609e84625f24ff8777f8d164e78a75b1c19c334ce42d5b58
-SIZE (bind-9.16.20.tar.xz) = 5042196
+TIMESTAMP = 1632745650
+SHA256 (bind-9.16.21.tar.xz) = 65da5fd4fb80b7d0d7452876f81fd6d67cdcee54a5e3c1d65610334665dfa815
+SIZE (bind-9.16.21.tar.xz) = 5057816
diff --git a/dns/bind916/files/extrapatch-bind-min-override-ttl b/dns/bind916/files/extrapatch-bind-min-override-ttl
index 1dce8f15d7d6..e1f06078adc4 100644
--- a/dns/bind916/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind916/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
Add the override-cache-ttl feature.
---- bin/named/config.c.orig 2021-07-09 08:02:03 UTC
+--- bin/named/config.c.orig 2021-09-07 09:37:05 UTC
+++ bin/named/config.c
@@ -180,6 +180,7 @@ options {\n\
notify-source *;\n\
@@ -10,9 +10,9 @@ Add the override-cache-ttl feature.
parental-source *;\n\
parental-source-v6 *;\n\
provide-ixfr true;\n\
---- bin/named/server.c.orig 2021-07-09 08:02:03 UTC
+--- bin/named/server.c.orig 2021-09-07 09:37:05 UTC
+++ bin/named/server.c
-@@ -4406,6 +4406,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
+@@ -4411,6 +4411,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
obj = NULL;
@@ -24,7 +24,7 @@ Add the override-cache-ttl feature.
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asduration(obj);
---- lib/dns/include/dns/view.h.orig 2021-07-09 08:02:03 UTC
+--- lib/dns/include/dns/view.h.orig 2021-09-07 09:37:05 UTC
+++ lib/dns/include/dns/view.h
@@ -152,6 +152,7 @@ struct dns_view {
bool requestnsid;
@@ -34,7 +34,7 @@ Add the override-cache-ttl feature.
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2021-07-09 08:02:03 UTC
+--- lib/dns/resolver.c.orig 2021-09-07 09:37:05 UTC
+++ lib/dns/resolver.c
@@ -6476,6 +6476,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_mes
}
@@ -49,7 +49,7 @@ Add the override-cache-ttl feature.
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2021-07-09 08:02:03 UTC
+--- lib/isccfg/namedconf.c.orig 2021-09-07 09:37:05 UTC
+++ lib/isccfg/namedconf.c
@@ -2048,6 +2048,7 @@ static cfg_clausedef_t view_clauses[] = {
#endif /* ifdef HAVE_LMDB */