aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-01-18 16:52:31 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-01-18 16:52:31 +0000
commit8f54ba0123bbf9cbfb24e98dfdbf2d2ea899fd95 (patch)
tree5abcda3ef5626b5f7e19d6c6d1cdc880ec965269
parent584eeea2d7b2c195eb6337767e416530f0341d91 (diff)
Notes
-rw-r--r--devel/ocaml-lacaml/Makefile4
-rw-r--r--math/gretl/Makefile2
-rw-r--r--misc/gretl/Makefile2
-rw-r--r--science/py-scipy/Makefile6
-rw-r--r--science/py-scipy03/Makefile6
5 files changed, 10 insertions, 10 deletions
diff --git a/devel/ocaml-lacaml/Makefile b/devel/ocaml-lacaml/Makefile
index 757ade29a055..b15e36c399f7 100644
--- a/devel/ocaml-lacaml/Makefile
+++ b/devel/ocaml-lacaml/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= ocaml-
MAINTAINER= stas@FreeBSD.org
COMMENT= OCaml interface to BLAS and LAPACK libraries
-LIB_DEPENDS= blas.1:${PORTSDIR}/math/blas \
- lapack.3:${PORTSDIR}/math/lapack
+LIB_DEPENDS= blas.2:${PORTSDIR}/math/blas \
+ lapack.4:${PORTSDIR}/math/lapack
USE_BZIP2= yes
USE_GMAKE= yes
diff --git a/math/gretl/Makefile b/math/gretl/Makefile
index 1277e0152655..5be1a0233d24 100644
--- a/math/gretl/Makefile
+++ b/math/gretl/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Gnu Regression, Econometrics and Time-series Library
BUILD_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
-LIB_DEPENDS= lapack.3:${PORTSDIR}/math/lapack \
+LIB_DEPENDS= lapack.4:${PORTSDIR}/math/lapack \
gmp.7:${PORTSDIR}/math/libgmp4
RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
diff --git a/misc/gretl/Makefile b/misc/gretl/Makefile
index 1277e0152655..5be1a0233d24 100644
--- a/misc/gretl/Makefile
+++ b/misc/gretl/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Gnu Regression, Econometrics and Time-series Library
BUILD_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
-LIB_DEPENDS= lapack.3:${PORTSDIR}/math/lapack \
+LIB_DEPENDS= lapack.4:${PORTSDIR}/math/lapack \
gmp.7:${PORTSDIR}/math/libgmp4
RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
diff --git a/science/py-scipy/Makefile b/science/py-scipy/Makefile
index bf3bd9fc97b2..7b0c7bd72b8c 100644
--- a/science/py-scipy/Makefile
+++ b/science/py-scipy/Makefile
@@ -36,13 +36,13 @@ post-patch:
.include <bsd.port.pre.mk>
.if defined(WITH_ATLAS)
-LIB_DEPENDS+= atlas.1:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
.if !exists(${LOCALBASE}/lib/libalapack.a)
IGNORE= Atlas needs to be built with WITH_STATICLIB for scipy to function properly
.endif
.else
-LIB_DEPENDS+= lapack.3:${PORTSDIR}/math/lapack \
- blas.1:${PORTSDIR}/math/blas
+LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack \
+ blas.2:${PORTSDIR}/math/blas
.endif
post-install:
diff --git a/science/py-scipy03/Makefile b/science/py-scipy03/Makefile
index dc666b7b4ea3..04f0fec39550 100644
--- a/science/py-scipy03/Makefile
+++ b/science/py-scipy03/Makefile
@@ -41,13 +41,13 @@ post-patch:
.include <bsd.port.pre.mk>
.if defined(WITH_ATLAS)
-LIB_DEPENDS+= atlas.1:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
.if !exists(${LOCALBASE}/lib/libalapack.a)
IGNORE= Atlas needs to be built with WITH_STATICLIB for scipy to function properly
.endif
.else
-LIB_DEPENDS+= lapack.3:${PORTSDIR}/math/lapack \
- blas.1:${PORTSDIR}/math/blas
+LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack \
+ blas.2:${PORTSDIR}/math/blas
.endif
post-install: