aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-02-19 16:30:01 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-02-19 16:30:01 +0000
commit91272d283d9dea331e221baeeca1cac941128ac6 (patch)
treef2b0e62910212096d66db528cddb8b6c297830c8
parentc2addfb34580fd71873efc4b515887d2216ac99e (diff)
downloadports-91272d283d9dea331e221baeeca1cac941128ac6.tar.gz
ports-91272d283d9dea331e221baeeca1cac941128ac6.zip
Notes
-rw-r--r--graphics/ocaml-lablgl/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/graphics/ocaml-lablgl/Makefile b/graphics/ocaml-lablgl/Makefile
index 70575abde6c6..8d03451b4af0 100644
--- a/graphics/ocaml-lablgl/Makefile
+++ b/graphics/ocaml-lablgl/Makefile
@@ -12,12 +12,12 @@ PKGNAMEPREFIX= ocaml-
MAINTAINER= bf@FreeBSD.org
COMMENT= OpenGL interface for Objective Caml
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
WRKSRC= ${WRKDIR}/lablGL
+USES= gmake
USE_XORG= x11 xext xmu
USE_GL= glut
-USE_GMAKE= yes
USE_OCAML= yes
USE_OCAML_WASH= yes
ALL_TARGET= all opt
@@ -38,13 +38,11 @@ CONFLICTS= ocaml-notk-[0-9]* ocaml-nox11-[0-9]*
NO_STAGE= yes
.include <bsd.port.options.mk>
-USE_TK= 84+
-INVALID_TK_VER = 86
+USES+= tk:84,85
.if ${PORT_OPTIONS:MTHREADS}
THR_CPP= ${PTHREAD_CFLAGS}
THR_LD = ${PTHREAD_LIBS}
.endif
-.include "${PORTSDIR}/Mk/bsd.tcl.mk"
post-extract:
@${CP} ${WRKSRC}/Makefile.config.freebsd ${WRKSRC}/Makefile.config
@@ -58,7 +56,7 @@ post-patch:
-e "s,^#\(DLLDIR[ \t]*=\).*,\1${PREFIX}/lib/ocaml/stublibs,g" \
-e "/^TKINCLUDES/s,=.*$$,= -I${TCL_INCLUDEDIR} -I${TK_INCLUDEDIR}," \
-e "/^TKLIBS/s,=.*$$,= -L${LOCALBASE}/lib -ltk${TK_VER:S/.//}\
- -ltcl${TCL_VER:S/.//} ${THR_LD}," \
+ -ltcl${TCL_SHLIB_VER} ${THR_LD}," \
${WRKSRC}/Makefile.config
@${REINPLACE_CMD} \