aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-09-10 19:23:23 +0000
committerJohn Marino <marino@FreeBSD.org>2016-09-10 19:23:23 +0000
commit931da8d47263e27157fbd40b6547a6ebc2281276 (patch)
tree345d3288756396548b95ddb66acb8e064e092a58
parent5c58a1ea38a2bc8a389f6770fa2e112a0b5d74f5 (diff)
downloadports-931da8d47263e27157fbd40b6547a6ebc2281276.tar.gz
ports-931da8d47263e27157fbd40b6547a6ebc2281276.zip
Notes
-rw-r--r--lang/swi-pl/Makefile7
-rw-r--r--lang/swi-pl/files/patch-packages_ssl_ssl4pl.c28
2 files changed, 32 insertions, 3 deletions
diff --git a/lang/swi-pl/Makefile b/lang/swi-pl/Makefile
index 48b5fb02c810..22dfbc95ebf2 100644
--- a/lang/swi-pl/Makefile
+++ b/lang/swi-pl/Makefile
@@ -18,14 +18,15 @@ SWIPLDIR= ${PORTNAME:C/-//}-${PORTVERSION}
NOPRECIOUSMAKEVARS= yes
USE_XORG= xft xpm xt
-USES= gmake jpeg libarchive pathfix pkgconfig shebangfix
+USES= gmake jpeg libarchive pathfix pkgconfig shebangfix ssl
MAKE_JOBS_UNSAFE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= ARCH=${ARCH}-${OPSYS:tl}
CONFIGURE_TARGET= ${ARCH}-${OPSYS:tl}
CONFIGURE_ARGS= --with-world --without-jpl --enable-shared
MAKE_ARGS= DISABLE_PKGS=jpl \
- ac_cv_lib_ossp_uuid_uuid_create=no ac_cv_lib_uuid_uuid_create=no
+ ac_cv_lib_ossp_uuid_uuid_create=no \
+ ac_cv_lib_uuid_uuid_create=no
SHEBANG_LANG= swipl
swipl_OLD_CMD= /usr/bin/swipl
@@ -70,6 +71,6 @@ post-patch:
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/xpce-client \
- ${STAGEDIR}${PREFIX}/lib/${SWIPLDIR}/lib/${ARCH}-freebsd/pl2xpce.so
+ ${STAGEDIR}${PREFIX}/lib/${SWIPLDIR}/lib/${ARCH}-${OPSYS:tl}/pl2xpce.so
.include <bsd.port.post.mk>
diff --git a/lang/swi-pl/files/patch-packages_ssl_ssl4pl.c b/lang/swi-pl/files/patch-packages_ssl_ssl4pl.c
new file mode 100644
index 000000000000..3919e181019a
--- /dev/null
+++ b/lang/swi-pl/files/patch-packages_ssl_ssl4pl.c
@@ -0,0 +1,28 @@
+--- packages/ssl/ssl4pl.c.orig 2015-06-09 09:25:57 UTC
++++ packages/ssl/ssl4pl.c
+@@ -1127,8 +1127,12 @@ pl_ssl_context(term_t role, term_t confi
+
+ if (!PL_get_atom(method, &method_name))
+ return PL_domain_error("ssl_method", method);
+- if (method_name == ATOM_sslv3)
++ if (0)
++ { /* never reached */ }
++#ifndef OPENSSL_NO_SSL3
++ else if (method_name == ATOM_sslv3)
+ ssl_method = SSLv3_method();
++#endif
+ #ifdef HAVE_SSLV2_METHOD
+ else if (method_name == ATOM_sslv2)
+ ssl_method = SSLv2_method();
+@@ -1736,9 +1740,11 @@ pl_ssl_session(term_t stream_t, term_t s
+ PL_INTEGER, (int)session->ssl_version))
+ return FALSE;
+
++#ifndef OPENSSL_NO_SSL2
+ if ( !add_key_string(list_t, FUNCTOR_session_key1,
+ session->key_arg_length, session->key_arg) )
+ return FALSE;
++#endif
+
+ if ( !add_key_string(list_t, FUNCTOR_master_key1,
+ session->master_key_length, session->master_key) )