aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2003-01-17 13:45:25 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2003-01-17 13:45:25 +0000
commit99f58c4d7d881d915eefe19640421f64944135f0 (patch)
tree6a9b98c06d0ea25d37dc7f9f8f849262a2364bea
parente7f3157cc4e3e52bdfae8ff2217211a203da55b3 (diff)
downloadports-99f58c4d7d881d915eefe19640421f64944135f0.tar.gz
ports-99f58c4d7d881d915eefe19640421f64944135f0.zip
Notes
-rw-r--r--devel/esdl/Makefile29
-rw-r--r--devel/esdl/files/patch-Makefile59
-rw-r--r--devel/esdl/files/patch-c__src_Makefile23
-rw-r--r--devel/esdl/pkg-plist181
4 files changed, 199 insertions, 93 deletions
diff --git a/devel/esdl/Makefile b/devel/esdl/Makefile
index 1e5849e34e7d..bc03933fc5b3 100644
--- a/devel/esdl/Makefile
+++ b/devel/esdl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= esdl
PORTVERSION= 0.91.1129
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= esdl
@@ -14,33 +15,11 @@ DISTNAME= esdl-${PORTVERSION}.src
MAINTAINER= olgeni@FreeBSD.org
+LIB_DEPENDS= SDL-1.1.4:${PORTSDIR}/devel/sdl12
+BUILD_DEPENDS= erlc:${PORTSDIR}/lang/erlang
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GMAKE= yes
-ESDL_PATH= ${PREFIX}/lib/erlang/lib/esdl-${PORTVERSION}
-
-do-build:
- @cd ${WRKSRC}/c_src && ${GMAKE}
- @cd ${WRKSRC}/test && ${GMAKE}
-
-do-install:
- @${MKDIR} ${ESDL_PATH}
- @${MKDIR} ${ESDL_PATH}/doc
- @${MKDIR} ${ESDL_PATH}/ebin
- @${MKDIR} ${ESDL_PATH}/include
- @${MKDIR} ${ESDL_PATH}/priv
- @${MKDIR} ${ESDL_PATH}/src
- @${FIND} ${ESDL_PATH} -type d | ${XARGS} ${CHMOD} 755
-
- @${INSTALL_DATA} ${WRKSRC}/doc/* ${ESDL_PATH}/doc
- @${INSTALL_DATA} ${WRKSRC}/ebin/* ${ESDL_PATH}/ebin
- @${INSTALL_DATA} ${WRKSRC}/include/* ${ESDL_PATH}/include
- @${INSTALL_DATA} ${WRKSRC}/priv/sdl_driver.so ${ESDL_PATH}/priv
- @${INSTALL_PROGRAM} ${WRKSRC}/priv/sdlwrapper ${ESDL_PATH}/priv
- @${INSTALL_DATA} ${WRKSRC}/src/* ${ESDL_PATH}/src
-
- @${CP} -r ${WRKSRC}/priv ${ESDL_PATH}
- @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${ESDL_PATH}
-
.include <bsd.port.mk>
diff --git a/devel/esdl/files/patch-Makefile b/devel/esdl/files/patch-Makefile
new file mode 100644
index 000000000000..e0e8e3840b7c
--- /dev/null
+++ b/devel/esdl/files/patch-Makefile
@@ -0,0 +1,59 @@
+--- Makefile.orig Wed Dec 25 18:35:43 2002
++++ Makefile Wed Dec 25 18:36:49 2002
+@@ -8,12 +8,13 @@
+ SUBDIRS = c_src src test doc
+
+ DATE = $(shell date +%m%d)
+-REL = esdl-0.91.$(DATE)
+-RELDIR = /tmp/$(REL)
++RELDIR = $(PREFIX)/lib/erlang/lib/esdl
+
+ WWWDIR = /home/dgud/public_html/external/esdl
+ BUPDIR = /tmp/oldesdl/
+
++all: target
++
+ target clean:
+ @for d in $(SUBDIRS); do \
+ if test ! -d $$d ; then \
+@@ -29,8 +30,8 @@
+
+ release: target relsrc relwin www
+
+-relsrc: target
+- @echo Making $(RELDIR).tgz
++install: target
++ @echo Making $(RELDIR)
+ @if test ! -d $(RELDIR) ; then \
+ mkdir $(RELDIR) ; \
+ else \
+@@ -50,11 +51,12 @@
+ mkdir $(RELDIR)/include
+ cp include/*.hrl $(RELDIR)/include
+ mkdir $(RELDIR)/priv
++ cp priv/sdl_driver.so $(RELDIR)/priv
++ cp priv/sdlwrapper $(RELDIR)/priv
+ mkdir $(RELDIR)/src
+ cp src/Makefile* src/*.?rl $(RELDIR)/src
+ mkdir $(RELDIR)/test
+ cp test/Makefile* test/*.erl test/*.wav test/*.bmp $(RELDIR)/test
+- (cd $(RELDIR)/..; gtar zcfv $(REL).src.tar.gz $(REL) )
+ relwin: relsrc
+ cp priv/SDL.dll $(RELDIR)/priv
+ cp priv/sdlwrapper.exe priv/sdl_driver.dll $(RELDIR)/priv
+@@ -63,15 +65,6 @@
+
+ www:
+ @echo Copying files ...
+- @if test ! -d $(BUPDIR) ; then \
+- mkdir $(BUPDIR) ; \
+- else \
+- rm -rf $(BUPDIR)/* ; \
+- fi ;
+- mv $(WWWDIR)/*.gz $(BUPDIR)/
+- mv $(WWWDIR)/*.zip $(BUPDIR)/
+- cp $(RELDIR)/../$(REL).src.tar.gz $(WWWDIR)
+- cp $(RELDIR)/../$(REL).win.zip $(WWWDIR)
+ cp Readme $(WWWDIR)
+ cp doc/*.html $(WWWDIR)/doc
+ $(shell sed 's,esdl-.\..\.....,$(REL),g' $(WWWDIR)/index.html > $(WWWDIR)/index.html.new)
diff --git a/devel/esdl/files/patch-c__src_Makefile b/devel/esdl/files/patch-c__src_Makefile
index b8bd6fef9b74..3c43478e87e8 100644
--- a/devel/esdl/files/patch-c__src_Makefile
+++ b/devel/esdl/files/patch-c__src_Makefile
@@ -1,8 +1,5 @@
-
-$FreeBSD$
-
---- c_src/Makefile.orig Mon Dec 9 23:11:08 2002
-+++ c_src/Makefile Mon Dec 9 23:11:10 2002
+--- c_src/Makefile.orig Wed Dec 25 16:02:09 2002
++++ c_src/Makefile Wed Dec 25 16:03:16 2002
@@ -5,7 +5,7 @@
# $Id: Makefile,v 1.3 2002/09/07 06:02:36 bjorng Exp $
#
@@ -12,7 +9,7 @@ $FreeBSD$
# Uncomment these if your opengl header is located in another directory than
# the usual $(OGLDIR)/include/GL/gl.h
-@@ -15,10 +15,10 @@
+@@ -15,12 +15,12 @@
GL_LIBS = -L$(OGLDIR)/lib -lGL -lGLU
GL_INCS = -I$(OGLDIR)/include/$(GL_INCLUDE_DIR)
@@ -23,5 +20,17 @@ $FreeBSD$
-SDLINCS = $(shell sdl-config --cflags)
+SDLINCS = $(shell sdl11-config --cflags)
- CFLAGS = -g -O2 -funroll-loops -Wall -ffast-math -fpic -fomit-frame-pointer \
+-CFLAGS = -g -O2 -funroll-loops -Wall -ffast-math -fpic -fomit-frame-pointer \
++CFLAGS += -g -funroll-loops -Wall -ffast-math -fpic -fomit-frame-pointer \
$(USE_GL_INCLUDE_DIR) -DSHM -DPTHREADS $(GL_INCS) $(SDLINCS)
+
+ TARGETDIR = ../priv
+@@ -29,7 +29,7 @@
+ ERL_DIR := $(shell echo 'io:format("~s~n",[code:root_dir()]),halt().' | erl | sed 's,^[0-9]*> *,,g' | tail +2)
+ ERLINC = -I$(ERL_DIR)/usr/include
+
+-CC = gcc
++CC ?= gcc
+ GCC_O = $(CC) -c $(CFLAGS) $(INCS) $<
+
+ # Files
diff --git a/devel/esdl/pkg-plist b/devel/esdl/pkg-plist
index 5752c047ac1a..5779a1761d67 100644
--- a/devel/esdl/pkg-plist
+++ b/devel/esdl/pkg-plist
@@ -1,61 +1,120 @@
-lib/erlang/lib/esdl-0.91.1129/doc/Makefile
-lib/erlang/lib/esdl-0.91.1129/doc/gl.html
-lib/erlang/lib/esdl-0.91.1129/doc/glu.html
-lib/erlang/lib/esdl-0.91.1129/doc/index.html
-lib/erlang/lib/esdl-0.91.1129/doc/makedoc.erl
-lib/erlang/lib/esdl-0.91.1129/doc/sdl.html
-lib/erlang/lib/esdl-0.91.1129/doc/sdl_active.html
-lib/erlang/lib/esdl-0.91.1129/doc/sdl_audio.html
-lib/erlang/lib/esdl-0.91.1129/doc/sdl_events.html
-lib/erlang/lib/esdl-0.91.1129/doc/sdl_joystick.html
-lib/erlang/lib/esdl-0.91.1129/doc/sdl_keyboard.html
-lib/erlang/lib/esdl-0.91.1129/doc/sdl_mouse.html
-lib/erlang/lib/esdl-0.91.1129/doc/sdl_util.html
-lib/erlang/lib/esdl-0.91.1129/doc/sdl_video.html
-lib/erlang/lib/esdl-0.91.1129/ebin/gl.beam
-lib/erlang/lib/esdl-0.91.1129/ebin/glu.beam
-lib/erlang/lib/esdl-0.91.1129/ebin/sdl.beam
-lib/erlang/lib/esdl-0.91.1129/ebin/sdl_active.beam
-lib/erlang/lib/esdl-0.91.1129/ebin/sdl_audio.beam
-lib/erlang/lib/esdl-0.91.1129/ebin/sdl_events.beam
-lib/erlang/lib/esdl-0.91.1129/ebin/sdl_joystick.beam
-lib/erlang/lib/esdl-0.91.1129/ebin/sdl_keyboard.beam
-lib/erlang/lib/esdl-0.91.1129/ebin/sdl_mouse.beam
-lib/erlang/lib/esdl-0.91.1129/ebin/sdl_util.beam
-lib/erlang/lib/esdl-0.91.1129/ebin/sdl_video.beam
-lib/erlang/lib/esdl-0.91.1129/include/gl.hrl
-lib/erlang/lib/esdl-0.91.1129/include/glu.hrl
-lib/erlang/lib/esdl-0.91.1129/include/sdl.hrl
-lib/erlang/lib/esdl-0.91.1129/include/sdl_active.hrl
-lib/erlang/lib/esdl-0.91.1129/include/sdl_audio.hrl
-lib/erlang/lib/esdl-0.91.1129/include/sdl_events.hrl
-lib/erlang/lib/esdl-0.91.1129/include/sdl_joystick.hrl
-lib/erlang/lib/esdl-0.91.1129/include/sdl_keyboard.hrl
-lib/erlang/lib/esdl-0.91.1129/include/sdl_mouse.hrl
-lib/erlang/lib/esdl-0.91.1129/include/sdl_video.hrl
-lib/erlang/lib/esdl-0.91.1129/priv/sdl_driver.so
-lib/erlang/lib/esdl-0.91.1129/priv/sdlwrapper
-lib/erlang/lib/esdl-0.91.1129/src/Makefile
-lib/erlang/lib/esdl-0.91.1129/src/Makefile.win32
-lib/erlang/lib/esdl-0.91.1129/src/esdl.hrl
-lib/erlang/lib/esdl-0.91.1129/src/gl.erl
-lib/erlang/lib/esdl-0.91.1129/src/gl_funcs.hrl
-lib/erlang/lib/esdl-0.91.1129/src/glu.erl
-lib/erlang/lib/esdl-0.91.1129/src/glu_funcs.hrl
-lib/erlang/lib/esdl-0.91.1129/src/sdl.erl
-lib/erlang/lib/esdl-0.91.1129/src/sdl_active.erl
-lib/erlang/lib/esdl-0.91.1129/src/sdl_audio.erl
-lib/erlang/lib/esdl-0.91.1129/src/sdl_events.erl
-lib/erlang/lib/esdl-0.91.1129/src/sdl_joystick.erl
-lib/erlang/lib/esdl-0.91.1129/src/sdl_keyboard.erl
-lib/erlang/lib/esdl-0.91.1129/src/sdl_mouse.erl
-lib/erlang/lib/esdl-0.91.1129/src/sdl_util.erl
-lib/erlang/lib/esdl-0.91.1129/src/sdl_util.hrl
-lib/erlang/lib/esdl-0.91.1129/src/sdl_video.erl
-lib/erlang/lib/esdl-0.91.1129/src/sdl_video_funcs.hrl
-@dirrm lib/erlang/lib/esdl-0.91.1129/src
-@dirrm lib/erlang/lib/esdl-0.91.1129/priv
-@dirrm lib/erlang/lib/esdl-0.91.1129/include
-@dirrm lib/erlang/lib/esdl-0.91.1129/ebin
-@dirrm lib/erlang/lib/esdl-0.91.1129/doc
-@dirrm lib/erlang/lib/esdl-0.91.1129
+lib/erlang/lib/esdl/license.terms
+lib/erlang/lib/esdl/Readme.MacOSX-Cocoa
+lib/erlang/lib/esdl/Readme
+lib/erlang/lib/esdl/esdl.pub
+lib/erlang/lib/esdl/Makefile.win32
+lib/erlang/lib/esdl/Makefile.orig
+lib/erlang/lib/esdl/Makefile
+lib/erlang/lib/esdl/api_gen/glufuncs
+lib/erlang/lib/esdl/api_gen/gludefs
+lib/erlang/lib/esdl/api_gen/glfuncs
+lib/erlang/lib/esdl/api_gen/gldefs
+lib/erlang/lib/esdl/api_gen/conv.erl
+lib/erlang/lib/esdl/c_src/CPS.h
+lib/erlang/lib/esdl/c_src/Makefile.orig
+lib/erlang/lib/esdl/c_src/Makefile.macOSX
+lib/erlang/lib/esdl/c_src/Makefile
+lib/erlang/lib/esdl/c_src/SDLMain.m
+lib/erlang/lib/esdl/c_src/hexdump.c
+lib/erlang/lib/esdl/c_src/esdl_wrapper.c
+lib/erlang/lib/esdl/c_src/esdl_video.c
+lib/erlang/lib/esdl/c_src/esdl_util.c
+lib/erlang/lib/esdl/c_src/esdl_stream.c
+lib/erlang/lib/esdl/c_src/esdl_spec.c
+lib/erlang/lib/esdl/c_src/esdl_opengl.c
+lib/erlang/lib/esdl/c_src/esdl_main.c
+lib/erlang/lib/esdl/c_src/esdl_glu.c
+lib/erlang/lib/esdl/c_src/esdl_gen.c
+lib/erlang/lib/esdl/c_src/esdl_events.c
+lib/erlang/lib/esdl/c_src/esdl_driver.c
+lib/erlang/lib/esdl/c_src/esdl_conv.c
+lib/erlang/lib/esdl/c_src/esdl_audio.c
+lib/erlang/lib/esdl/c_src/esdl_video.h
+lib/erlang/lib/esdl/c_src/esdl_util.h
+lib/erlang/lib/esdl/c_src/esdl_opengl.h
+lib/erlang/lib/esdl/c_src/esdl_glu.h
+lib/erlang/lib/esdl/c_src/esdl_events.h
+lib/erlang/lib/esdl/c_src/esdl_conv.h
+lib/erlang/lib/esdl/c_src/esdl_audio.h
+lib/erlang/lib/esdl/c_src/esdl.h
+lib/erlang/lib/esdl/c_src/SDLMain.h
+lib/erlang/lib/esdl/c_src/Makefile.win32
+lib/erlang/lib/esdl/doc/Makefile
+lib/erlang/lib/esdl/doc/sdl_util.html
+lib/erlang/lib/esdl/doc/sdl_mouse.html
+lib/erlang/lib/esdl/doc/sdl_keyboard.html
+lib/erlang/lib/esdl/doc/sdl_joystick.html
+lib/erlang/lib/esdl/doc/sdl_events.html
+lib/erlang/lib/esdl/doc/sdl_audio.html
+lib/erlang/lib/esdl/doc/sdl_active.html
+lib/erlang/lib/esdl/doc/sdl.html
+lib/erlang/lib/esdl/doc/index.html
+lib/erlang/lib/esdl/doc/glu.html
+lib/erlang/lib/esdl/doc/gl.html
+lib/erlang/lib/esdl/doc/makedoc.erl
+lib/erlang/lib/esdl/doc/sdl_video.html
+lib/erlang/lib/esdl/ebin/gl.beam
+lib/erlang/lib/esdl/ebin/sdl_util.beam
+lib/erlang/lib/esdl/ebin/sdl_mouse.beam
+lib/erlang/lib/esdl/ebin/sdl_keyboard.beam
+lib/erlang/lib/esdl/ebin/sdl_joystick.beam
+lib/erlang/lib/esdl/ebin/sdl_events.beam
+lib/erlang/lib/esdl/ebin/sdl_audio.beam
+lib/erlang/lib/esdl/ebin/sdl_active.beam
+lib/erlang/lib/esdl/ebin/sdl.beam
+lib/erlang/lib/esdl/ebin/glu.beam
+lib/erlang/lib/esdl/ebin/sdl_video.beam
+lib/erlang/lib/esdl/include/gl.hrl
+lib/erlang/lib/esdl/include/sdl_mouse.hrl
+lib/erlang/lib/esdl/include/sdl_keyboard.hrl
+lib/erlang/lib/esdl/include/sdl_joystick.hrl
+lib/erlang/lib/esdl/include/sdl_events.hrl
+lib/erlang/lib/esdl/include/sdl_audio.hrl
+lib/erlang/lib/esdl/include/sdl_active.hrl
+lib/erlang/lib/esdl/include/sdl.hrl
+lib/erlang/lib/esdl/include/glu.hrl
+lib/erlang/lib/esdl/include/sdl_video.hrl
+lib/erlang/lib/esdl/priv/sdl_driver.so
+lib/erlang/lib/esdl/priv/sdlwrapper
+lib/erlang/lib/esdl/src/Makefile
+lib/erlang/lib/esdl/src/sdl_video.erl
+lib/erlang/lib/esdl/src/sdl_util.hrl
+lib/erlang/lib/esdl/src/sdl_util.erl
+lib/erlang/lib/esdl/src/sdl_mouse.erl
+lib/erlang/lib/esdl/src/sdl_keyboard.erl
+lib/erlang/lib/esdl/src/sdl_joystick.erl
+lib/erlang/lib/esdl/src/sdl_events.erl
+lib/erlang/lib/esdl/src/sdl_audio.erl
+lib/erlang/lib/esdl/src/sdl_active.erl
+lib/erlang/lib/esdl/src/sdl.erl
+lib/erlang/lib/esdl/src/glu_funcs.hrl
+lib/erlang/lib/esdl/src/glu.erl
+lib/erlang/lib/esdl/src/gl_funcs.hrl
+lib/erlang/lib/esdl/src/gl.erl
+lib/erlang/lib/esdl/src/esdl.hrl
+lib/erlang/lib/esdl/src/Makefile.win32
+lib/erlang/lib/esdl/src/sdl_video_funcs.hrl
+lib/erlang/lib/esdl/test/Makefile
+lib/erlang/lib/esdl/test/PoweredSmall.bmp
+lib/erlang/lib/esdl/test/Powered.bmp
+lib/erlang/lib/esdl/test/sample.wav
+lib/erlang/lib/esdl/test/Boing.wav
+lib/erlang/lib/esdl/test/Beep.wav
+lib/erlang/lib/esdl/test/testsprite.erl
+lib/erlang/lib/esdl/test/testjoy.erl
+lib/erlang/lib/esdl/test/testglutess.erl
+lib/erlang/lib/esdl/test/testgl.erl
+lib/erlang/lib/esdl/test/testbin.erl
+lib/erlang/lib/esdl/test/testaudio.erl
+lib/erlang/lib/esdl/test/erldemo.erl
+lib/erlang/lib/esdl/test/Makefile.win32
+lib/erlang/lib/esdl/test/icon.bmp
+@dirrm lib/erlang/lib/esdl/test
+@dirrm lib/erlang/lib/esdl/src
+@dirrm lib/erlang/lib/esdl/priv
+@dirrm lib/erlang/lib/esdl/include
+@dirrm lib/erlang/lib/esdl/ebin
+@dirrm lib/erlang/lib/esdl/doc
+@dirrm lib/erlang/lib/esdl/c_src
+@dirrm lib/erlang/lib/esdl/api_gen
+@dirrm lib/erlang/lib/esdl