aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-19 12:52:05 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-19 12:52:05 +0000
commit9c8ffe3536b4cdbb752b1f47a019f5c55ef57d28 (patch)
treed79312b6fb94050236dc5b2eeae326a091b4b405
parent13ecb6b82f36d5789de68f50096d0bd702c4e408 (diff)
Notes
-rw-r--r--editors/bitedit/Makefile13
-rw-r--r--editors/bitedit/files/patch-Makefile13
2 files changed, 20 insertions, 6 deletions
diff --git a/editors/bitedit/Makefile b/editors/bitedit/Makefile
index ed94123f9941..edbe7f1ddd70 100644
--- a/editors/bitedit/Makefile
+++ b/editors/bitedit/Makefile
@@ -9,16 +9,17 @@ MASTER_SITES= http://freebsdcluster.org/~mich/software/
MAINTAINER= mich@FreeBSD.org
COMMENT= Bitedit is a simple ncurses program for editing a file
+LICENSE= GPLv2
+
MAKE_ARGS= CFLAGS="${CFLAGS} -DVERSION=\\\"${PORTVERSION}\\\""
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bitedit ${PREFIX}/bin/
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/bitedit.txt ${DOCSDIR}/bitedit.txt
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/bitedit ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/bitedit.txt ${STAGEDIR}${DOCSDIR}/bitedit.txt
.include <bsd.port.mk>
diff --git a/editors/bitedit/files/patch-Makefile b/editors/bitedit/files/patch-Makefile
new file mode 100644
index 000000000000..c10ba06b5086
--- /dev/null
+++ b/editors/bitedit/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- ./Makefile.orig 2003-05-27 14:23:25.000000000 +0200
++++ ./Makefile 2014-02-19 13:50:29.293943342 +0100
+@@ -9,8 +9,8 @@
+ DISTFILE=bitedit-$(VERSION).tar.gz
+
+ DEFINES=-DVERSION=\"$(VERSION)\"
+-CFLAGS=-g -Wall $(DEFINES)
+-LD=$(CC) -g -Wall
++CFLAGS+=-Wall $(DEFINES)
++LD=$(CC) -Wall
+
+
+ all: $(TARGETS)