aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2013-04-18 09:45:10 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2013-04-18 09:45:10 +0000
commit9e2e262bd074e20bbda9a69fbe915b3c5aefb293 (patch)
tree5a2fb565d47779929ca0237c4cae46deb357a923
parent8149e3dbf2cf5217254031a7983dfa30913ed0b1 (diff)
downloadports-9e2e262bd074e20bbda9a69fbe915b3c5aefb293.tar.gz
ports-9e2e262bd074e20bbda9a69fbe915b3c5aefb293.zip
Notes
-rw-r--r--net/httping/Makefile23
1 files changed, 19 insertions, 4 deletions
diff --git a/net/httping/Makefile b/net/httping/Makefile
index e70726014f4b..ba962f78dcd8 100644
--- a/net/httping/Makefile
+++ b/net/httping/Makefile
@@ -3,6 +3,7 @@
PORTNAME= httping
PORTVERSION= 2.2.1
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.vanheusden.com/httping/ \
CRITICAL
@@ -17,17 +18,31 @@ MAKE_JOBS_SAFE= yes
MAN1= httping.1
PLIST_FILES= bin/httping
-OPTIONS_DEFINE= NCURSES
+OPTIONS_DEFINE= NCURSES FFTW SSL
-NCURSES_DESC= ncurses support
+OPTIONS_DEFAULT=NCURSES SSL
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNCURSES}
-LIB_DEPENDS+= fftw3:${PORTSDIR}/math/fftw3
-MAKE_ENV+= SSL=yes NC=yes FW=yes
+MAKE_ENV+= NC=yes
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+.else
+MAKE_ENV+= NC=no
+.endif
+
+.if ${PORT_OPTIONS:MFFTW}
+MAKE_ENV+= FW=yes
+LIB_DEPENDS+= fftw3:${PORTSDIR}/math/fftw3
+.else
+MAKE_ENV+= FW=no
+.endif
+
+.if ${PORT_OPTIONS:MSSL}
+MAKE_ENV+= SSL=yes
+.else
+MAKE_ENV+= SSL=no
.endif
do-install: