aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2011-01-27 08:35:30 +0000
committerPav Lucistnik <pav@FreeBSD.org>2011-01-27 08:35:30 +0000
commitaebf0eb754c8c273345aa6fc52bb094181515b5a (patch)
treedda136c5176c09f57ba2b8b576fd1398ee942416
parent6ac0076929902a77f38f134b82488cd0f744bfe9 (diff)
downloadports-aebf0eb754c8c273345aa6fc52bb094181515b5a.tar.gz
ports-aebf0eb754c8c273345aa6fc52bb094181515b5a.zip
Notes
-rw-r--r--archivers/rpm5/Makefile4
-rw-r--r--devel/dsss/Makefile8
-rw-r--r--devel/gdcm/Makefile8
-rw-r--r--lang/rubinius/Makefile5
4 files changed, 21 insertions, 4 deletions
diff --git a/archivers/rpm5/Makefile b/archivers/rpm5/Makefile
index 9cba0ddf3674..0f86a7c75f04 100644
--- a/archivers/rpm5/Makefile
+++ b/archivers/rpm5/Makefile
@@ -130,6 +130,10 @@ PORTDOCS= *
LIB_DEPENDS+= lzma:${PORTSDIR}/archivers/xz
.endif
+.if ${OSVERSION} <= 701000
+MANUAL_PACKAGE_BUILD= hangs on pointyhat
+.endif
+
post-patch::
@${REINPLACE_CMD} -E -e \
's:\$$\(libdir\)/pkgconfig:${PREFIX}/libdata/pkgconfig:' \
diff --git a/devel/dsss/Makefile b/devel/dsss/Makefile
index 0358c452780d..bbad56ce85ed 100644
--- a/devel/dsss/Makefile
+++ b/devel/dsss/Makefile
@@ -26,6 +26,12 @@ PORTDOCS= *
MAN1= dsss.1 rebuild.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} <= 701000
+MANUAL_PACKAGE_BUILD= hangs on pointyhat
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|share/man|man|' \
${WRKSRC}/dsss.conf
@@ -38,4 +44,4 @@ post-patch:
${WRKSRC}/rebuild/Makefile
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/gdcm/Makefile b/devel/gdcm/Makefile
index b1c1d262cd17..b2883c09c259 100644
--- a/devel/gdcm/Makefile
+++ b/devel/gdcm/Makefile
@@ -45,7 +45,13 @@ post-install:
CMAKE_ARGS+= -DGDCM_DOCUMENTATION:BOOL=NO
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} <= 701000
+MANUAL_PACKAGE_BUILD= hangs on pointyhat
+.endif
+
post-patch:
${REINPLACE_CMD} -e 's| NAMELINK_SKIP||; s| NAMELINK_ONLY||' ${WRKSRC}/CMakeLists.txt
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/lang/rubinius/Makefile b/lang/rubinius/Makefile
index 9ebb2c822f5f..dbccb3a52f42 100644
--- a/lang/rubinius/Makefile
+++ b/lang/rubinius/Makefile
@@ -39,10 +39,11 @@ OPTIONS= GDBM "Enable GDBM support" on
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 700000
-BROKEN= does not build on 6.X
+.if ${OSVERSION} <= 701000
+MANUAL_PACKAGE_BUILD= hangs on pointyhat
.endif
+
.if !defined(WITHOUT_GDBM) || exists(${LOCALBASE}/include/gdbm.h)
LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm
PLIST_SUB+= GDBM=""