aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2017-04-19 06:17:17 +0000
committerMartin Wilke <miwi@FreeBSD.org>2017-04-19 06:17:17 +0000
commitb0527b1c3c76569aa1d34445c419d58cadc81c19 (patch)
treec09858a9ac86d3314ec522a110d671d018588047
parent12e894e605e6a95e338042cd08c23450c281e858 (diff)
downloadports-b0527b1c3c76569aa1d34445c419d58cadc81c19.tar.gz
ports-b0527b1c3c76569aa1d34445c419d58cadc81c19.zip
Notes
-rw-r--r--ftp/py-pyftpdlib/Makefile5
-rw-r--r--net/py-python-heatclient/Makefile4
-rw-r--r--net/py-python-openstackclient/Makefile5
-rw-r--r--news/papercut/Makefile4
-rw-r--r--textproc/makefaq/Makefile4
-rw-r--r--x11-toolkits/py-Pmw/Makefile5
6 files changed, 20 insertions, 7 deletions
diff --git a/ftp/py-pyftpdlib/Makefile b/ftp/py-pyftpdlib/Makefile
index 7c211f36e72e..2911c63b6b21 100644
--- a/ftp/py-pyftpdlib/Makefile
+++ b/ftp/py-pyftpdlib/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pyftpdlib
PORTVERSION= 1.5.2
+PORTREVISION= 1
CATEGORIES= ftp python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,8 +13,10 @@ COMMENT= Python FTP server library
LICENSE= MIT
-USES= python
+USES= python shebangfix
USE_PYTHON= autoplist distutils
+SHEBANG_FILES= demo/*.py
+NO_ARCH= yes
OPTIONS_DEFINE= SENDFILE OPENSSL
OPTIONS_DEFAULT= SENDFILE OPENSSL
diff --git a/net/py-python-heatclient/Makefile b/net/py-python-heatclient/Makefile
index 03f319dca8cf..cbea42dbbbfb 100644
--- a/net/py-python-heatclient/Makefile
+++ b/net/py-python-heatclient/Makefile
@@ -3,6 +3,7 @@
PORTNAME= python-heatclient
PORTVERSION= 1.7.0
+PORTREVISION= 1
CATEGORIES= net python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -30,7 +31,8 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}six>=1.9.0:devel/py-six \
NO_ARCH= yes
-USES= python
+USES= python shebangfix
USE_PYTHON= autoplist distutils
+SHEBANG_FILES= heatclient/tests/functional/hooks/post_test_hook.sh
.include <bsd.port.mk>
diff --git a/net/py-python-openstackclient/Makefile b/net/py-python-openstackclient/Makefile
index 73fbd3cc6cc1..adacbc0670b6 100644
--- a/net/py-python-openstackclient/Makefile
+++ b/net/py-python-openstackclient/Makefile
@@ -3,6 +3,7 @@
PORTNAME= python-openstackclient
PORTVERSION= 3.7.0
+PORTREVISION= 1
CATEGORIES= net python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -26,8 +27,10 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Babel>=2.3.4:devel/py-babel \
${PYTHON_PKGNAMEPREFIX}python-cinderclient>=0:net/py-python-cinderclient \
${PYTHON_PKGNAMEPREFIX}python-neutronclient>=0:net/py-python-neutronclient
-USES= python
+USES= python shebangfix
USE_PYTHON= distutils autoplist noegginfo
NO_ARCH= yes
+SHEBANG_FILES= openstackclient/tests/functional/post_test_hook.sh \
+ openstackclient/tests/functional/post_test_hook_tips.sh
.include <bsd.port.mk>
diff --git a/news/papercut/Makefile b/news/papercut/Makefile
index 1010952b21a5..acbe2e1ddeeb 100644
--- a/news/papercut/Makefile
+++ b/news/papercut/Makefile
@@ -3,6 +3,7 @@
PORTNAME= papercut
PORTVERSION= 0.9.13
+PORTREVISION= 1
CATEGORIES= news python
MASTER_SITES= http://pessoal.org/papercut/
@@ -14,9 +15,10 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:databases/py-MySQLdb
-USES= python
+USES= python shebangfix
NO_BUILD= yes
NO_ARCH= yes
+SHEBANG_FILES= *.py auth/*.py storage/*.py
do-configure:
${CP} ${FILESDIR}/papercut-wrapper ${WRKDIR}/papercut-wrapper
diff --git a/textproc/makefaq/Makefile b/textproc/makefaq/Makefile
index 38ddd99e4656..50d3593e8e43 100644
--- a/textproc/makefaq/Makefile
+++ b/textproc/makefaq/Makefile
@@ -3,6 +3,7 @@
PORTNAME= makefaq
PORTVERSION= 2.5
+PORTREVISION= 1
CATEGORIES= textproc python
MASTER_SITES= SF
@@ -11,9 +12,10 @@ COMMENT= Makefaq is a Python program that creates a (FAQ)
LICENSE= GPLv2+
-USES= python tar:tgz
+USES= python shebangfix tar:tgz
NO_BUILD= yes
NO_ARCH= yes
+SHEBANG_FILES= makefaq.py
PLIST_FILES= bin/makefaq.py man/man1/makefaq.1.gz
PORTDOCS= BUGS CREDITS ChangeLog README TODO UPGRADING faq.html
diff --git a/x11-toolkits/py-Pmw/Makefile b/x11-toolkits/py-Pmw/Makefile
index 21fe46a36db9..b2aac27a00cd 100644
--- a/x11-toolkits/py-Pmw/Makefile
+++ b/x11-toolkits/py-Pmw/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Pmw
PORTVERSION= 1.3.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11-toolkits python
MASTER_SITES= SF/${PORTNAME:tl}/${PORTNAME}/${PORTNAME}.${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,8 +16,9 @@ OPTIONS_DEFINE= DOCS EXAMPLES
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter
LIB_DEPENDS= libBLT25.so:x11-toolkits/blt
-USES= python
+USES= python shebangfix
USE_PYTHON= distutils
+SHEBANG_FILES= Pmw/Pmw_1_3/bin/bundlepmw.py
WRKSRC= ${WRKDIR}/${DISTNAME}/src
PMWVERSION= ${DISTNAME:R:S/./_/g}