aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce M Simpson <bms@FreeBSD.org>2009-12-02 06:06:47 +0000
committerBruce M Simpson <bms@FreeBSD.org>2009-12-02 06:06:47 +0000
commitb0f638efbb98635b2820855ab8cfe6f262926d70 (patch)
treeb9ea16cc14dfe1139f185fab566e684d0a633cf4
parent28f8b104b7ad139f5f2569514ca33b5d1adf7a1e (diff)
downloadports-b0f638efbb98635b2820855ab8cfe6f262926d70.tar.gz
ports-b0f638efbb98635b2820855ab8cfe6f262926d70.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/chrpath/Makefile23
-rw-r--r--devel/chrpath/distinfo3
-rw-r--r--devel/chrpath/files/patch-Makefile.in11
-rw-r--r--devel/chrpath/files/patch-elf.c11
-rw-r--r--devel/chrpath/pkg-descr2
6 files changed, 51 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0772c94eab0d..fccf31afaf9d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -159,6 +159,7 @@
SUBDIR += cgit
SUBDIR += cgprof
SUBDIR += charva
+ SUBDIR += chrpath
SUBDIR += cil
SUBDIR += cl-asdf
SUBDIR += cl-asdf-clisp
diff --git a/devel/chrpath/Makefile b/devel/chrpath/Makefile
new file mode 100644
index 000000000000..e50f6e8c47d6
--- /dev/null
+++ b/devel/chrpath/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: chrpath
+# Date created: 2009-12-01
+# Whom: bms
+#
+# $FreeBSD$
+#
+
+PORTNAME= chrpath
+PORTVERSION= 0.13
+CATEGORIES= devel sysutils
+MASTER_SITES= http://ftp.tux.org/pub/X-Windows/ftp.hungry.com/chrpath/
+
+MAINTAINER= bms@FreeBSD.org
+COMMENT= Tool to modify DT_RPATH in existing ELF binaries
+
+GNU_CONFIGURE= yes
+
+MAN1= chrpath.1
+
+PLIST_FILES= bin/chrpath
+PORTDOCS= *
+
+.include <bsd.port.mk>
diff --git a/devel/chrpath/distinfo b/devel/chrpath/distinfo
new file mode 100644
index 000000000000..c4d07e9f5729
--- /dev/null
+++ b/devel/chrpath/distinfo
@@ -0,0 +1,3 @@
+MD5 (chrpath-0.13.tar.gz) = b73072a8fbba277558c50364b65bb407
+SHA256 (chrpath-0.13.tar.gz) = c1aa5342eac0daad81b8da05aa282ae1ccd6f68bc75ca94064304f541eed071b
+SIZE (chrpath-0.13.tar.gz) = 125129
diff --git a/devel/chrpath/files/patch-Makefile.in b/devel/chrpath/files/patch-Makefile.in
new file mode 100644
index 000000000000..0dfdaff3d120
--- /dev/null
+++ b/devel/chrpath/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2009-12-01 20:39:04.000000000 +0000
++++ Makefile.in 2009-12-01 20:39:13.000000000 +0000
+@@ -66,7 +66,7 @@
+
+ SUBDIRS = testsuite deb
+
+-docdir = $(prefix)/doc/$(PACKAGE)-$(VERSION)
++docdir = $(prefix)/share/doc/$(PACKAGE)
+
+ doc_DATA = AUTHORS COPYING ChangeLog INSTALL NEWS README
+
diff --git a/devel/chrpath/files/patch-elf.c b/devel/chrpath/files/patch-elf.c
new file mode 100644
index 000000000000..340cae861a9e
--- /dev/null
+++ b/devel/chrpath/files/patch-elf.c
@@ -0,0 +1,11 @@
+--- elf.c.orig 2003-12-19 21:07:00.000000000 +0000
++++ elf.c 2009-12-01 20:39:21.000000000 +0000
+@@ -55,7 +55,7 @@
+ if (ehdr->e_phentsize != sizeof(Elf_Phdr))
+ {
+ fprintf(stderr, "section size was read as %d, not %d!\n",
+- ehdr->e_phentsize, sizeof(Elf_Phdr));
++ ehdr->e_phentsize, (int)sizeof(Elf_Phdr));
+ close(fd);
+ return -1;
+ }
diff --git a/devel/chrpath/pkg-descr b/devel/chrpath/pkg-descr
new file mode 100644
index 000000000000..3b6e8419cc58
--- /dev/null
+++ b/devel/chrpath/pkg-descr
@@ -0,0 +1,2 @@
+chrpath allows you to modify the dynamic library load path (rpath) of
+compiled programs. Only removing and modifying the rpath is supported.