aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-05-30 13:43:35 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-05-30 13:43:35 +0000
commitb105d88344288e2002c593f9cbcc75007ee1258a (patch)
tree2a592eb204ff0e6d659761274de61cba24711414
parent7cc93816658adeda53bdd3b2ea667067a01719e2 (diff)
downloadports-b105d88344288e2002c593f9cbcc75007ee1258a.tar.gz
ports-b105d88344288e2002c593f9cbcc75007ee1258a.zip
Notes
-rw-r--r--x11-toolkits/plib/Makefile15
-rw-r--r--x11-toolkits/plib/distinfo6
-rw-r--r--x11-toolkits/plib/files/patch-src::sl::slPortability.h11
-rw-r--r--x11-toolkits/plib/files/patch-src_js_jsBSD.cxx48
-rw-r--r--x11-toolkits/plib/files/patch-src_ssgAux_ssgaSky.h20
5 files changed, 14 insertions, 86 deletions
diff --git a/x11-toolkits/plib/Makefile b/x11-toolkits/plib/Makefile
index 667931e70674..d0f7119336ad 100644
--- a/x11-toolkits/plib/Makefile
+++ b/x11-toolkits/plib/Makefile
@@ -6,20 +6,27 @@
#
PORTNAME= plib
-PORTVERSION= 1.8.4
-PORTREVISION= 5
+PORTVERSION= 1.8.5
CATEGORIES= x11-toolkits
MASTER_SITES= http://plib.sourceforge.net/dist/
MAINTAINER= ports@FreeBSD.org
COMMENT= A portable library for joystick/sound/OpenGL GUI/3D math
+USE_GNOME= gnometarget
USE_GL= glu
USE_GMAKE= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
CXXFLAGS+= -fPIC
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread||g ; \
+ s|-ldl||g ; \
+ s|-lc_r||g' ${WRKSRC}/configure
post-build:
${CC} ${CFLAGS} -o ${WRKDIR}/plib-jscal ${FILESDIR}/jsBSDCal.c
diff --git a/x11-toolkits/plib/distinfo b/x11-toolkits/plib/distinfo
index 1fd89bc99fa9..c8b44834f2a1 100644
--- a/x11-toolkits/plib/distinfo
+++ b/x11-toolkits/plib/distinfo
@@ -1,3 +1,3 @@
-MD5 (plib-1.8.4.tar.gz) = 5e3f289a9d1c5de0b1cfdec76bf139e6
-SHA256 (plib-1.8.4.tar.gz) = 79e71d02fc2d7c984a4341239ed1d89ced743db2d6d4f83c30c422edaa6020e1
-SIZE (plib-1.8.4.tar.gz) = 793758
+MD5 (plib-1.8.5.tar.gz) = 47a6fbf63668c1eed631024038b2ea90
+SHA256 (plib-1.8.5.tar.gz) = 485b22bf6fdc0da067e34ead5e26f002b76326f6371e2ae006415dea6a380a32
+SIZE (plib-1.8.5.tar.gz) = 779133
diff --git a/x11-toolkits/plib/files/patch-src::sl::slPortability.h b/x11-toolkits/plib/files/patch-src::sl::slPortability.h
deleted file mode 100644
index b48641b6ae12..000000000000
--- a/x11-toolkits/plib/files/patch-src::sl::slPortability.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/sl/slPortability.h.orig Sat Sep 7 17:54:59 2002
-+++ ./src/sl/slPortability.h Sat Sep 7 17:55:22 2002
-@@ -74,7 +74,7 @@
- # if defined(__linux__)
- # include <linux/soundcard.h>
- # elif defined(__FreeBSD__)
--# include <machine/soundcard.h>
-+# include <sys/soundcard.h>
- # else
- /*
- Tom thinks this file may be <sys/soundcard.h> under some
diff --git a/x11-toolkits/plib/files/patch-src_js_jsBSD.cxx b/x11-toolkits/plib/files/patch-src_js_jsBSD.cxx
deleted file mode 100644
index 12bfa1f86e75..000000000000
--- a/x11-toolkits/plib/files/patch-src_js_jsBSD.cxx
+++ /dev/null
@@ -1,48 +0,0 @@
---- src/js/jsBSD.cxx.orig Wed Jan 12 02:22:26 2005
-+++ src/js/jsBSD.cxx Wed Dec 7 10:35:27 2005
-@@ -44,6 +44,8 @@
- #define HAVE_USB_JS 1
- #endif
-
-+#include <string.h>
-+#include <errno.h>
- #include <sys/ioctl.h>
- #if defined(__FreeBSD__)
- # include <sys/joystick.h>
-@@ -312,7 +314,7 @@
- int buttons [ _JS_MAX_AXES ] ;
-
- rawRead ( buttons, axes ) ;
-- error = axes[0] < -1000000000.0f ;
-+ error = axes[0] < -1000000000.0f && axes[1] < -1000000000.0f ;
- if ( error )
- return ;
-
-@@ -321,7 +323,11 @@
- joyfile = fopen ( joyfname, "r" ) ;
- error = ( joyfile == NULL ) ;
- if ( error )
-+ {
-+ ulSetError ( UL_WARNING, "unable to open calibration file %s (%s), joystick %i disabled (you can generate the calibration file with the plib-jscal utility)",
-+ joyfname, strerror ( errno ), id + 1 );
- return ;
-+ }
-
- noargs = fscanf ( joyfile, "%d%f%f%f%f%f%f", &in_no_axes,
- &min [ 0 ], &center [ 0 ], &max [ 0 ],
-@@ -445,8 +451,13 @@
-
- if ( axes != NULL )
- {
-- axes[0] = (float) os->ajs.x ;
-- axes[1] = (float) os->ajs.y ;
-+ if ( os->ajs.x >= -1000000000 )
-+ os->cache_axes[0] = os->ajs.x;
-+ if ( os->ajs.y >= -1000000000 )
-+ os->cache_axes[1] = os->ajs.y;
-+
-+ axes[0] = os->cache_axes[0];
-+ axes[1] = os->cache_axes[1];
- }
-
- return;
diff --git a/x11-toolkits/plib/files/patch-src_ssgAux_ssgaSky.h b/x11-toolkits/plib/files/patch-src_ssgAux_ssgaSky.h
deleted file mode 100644
index 7b3c18351dd9..000000000000
--- a/x11-toolkits/plib/files/patch-src_ssgAux_ssgaSky.h
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/ssgAux/ssgaSky.h.orig Fri Apr 6 03:58:33 2007
-+++ src/ssgAux/ssgaSky.h Fri Apr 6 03:58:45 2007
-@@ -104,7 +104,7 @@
- ssgaCelestialBodyList ( int init = 3 )
- : ssgSimpleList ( sizeof(ssgaCelestialBody*), init ) { }
-
-- ssgaCelestialBodyList::~ssgaCelestialBodyList () { removeAll(); }
-+ ~ssgaCelestialBodyList () { removeAll(); }
-
- int getNum (void) { return total ; }
-
-@@ -192,7 +192,7 @@
- ssgaCloudLayerList ( int init = 3 )
- : ssgSimpleList ( sizeof(ssgaCloudLayer*), init ) { }
-
-- ssgaCloudLayerList::~ssgaCloudLayerList () { removeAll(); }
-+ ~ssgaCloudLayerList () { removeAll(); }
-
- int getNum (void) { return total ; }
-