aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-04-19 11:17:36 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-04-19 11:17:36 +0000
commitb53fd2df7b4d6c390b7f0247ed9fd619f2bd9287 (patch)
tree44d0683410d41b0b511da371490569c8fc37be28
parent9f5dbeb28e8521f3bcdb55f60b9cffb0972971fc (diff)
downloadports-b53fd2df7b4d6c390b7f0247ed9fd619f2bd9287.tar.gz
ports-b53fd2df7b4d6c390b7f0247ed9fd619f2bd9287.zip
Notes
-rw-r--r--net/whois/Makefile21
-rw-r--r--net/whois/distinfo4
-rw-r--r--net/whois/files/have_nls-patch10
-rw-r--r--net/whois/files/patch-aa37
-rw-r--r--net/whois/files/patch-ac30
-rw-r--r--net/whois/pkg-plist44
6 files changed, 109 insertions, 37 deletions
diff --git a/net/whois/Makefile b/net/whois/Makefile
index e76088c173a6..dbacff7a0296 100644
--- a/net/whois/Makefile
+++ b/net/whois/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= whois
-PORTVERSION= 4.6.13
+PORTVERSION= 4.6.14
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_DEBIAN_POOL}
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -16,20 +16,35 @@ COMMENT= Marco d'Itri whois client
MAN1= whois.1
-USE_GETTEXT= yes
USE_ICONV= yes
USE_PERL5_BUILD= yes
USE_REINPLACE= yes
-USE_GMAKE= yes
USE_GETOPT_LONG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAKE_ENV= LDFLAGS="${LDFLAGS}"
MAKE_ARGS= OPTS=""
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+LDFLAGS+= -lintl
+PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
+NO_PO= yes
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s|prefix\=/usr/local|prefix\=${PREFIX}|g ; \
s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e "s|/usr/share|${PREFIX}/share|g" ${WRKSRC}/po/Makefile
+ @if [ -n "${NO_PO}" ]; \
+ then ${PATCH} ${PATCH_ARGS} < ${FILESDIR}/have_nls-patch; \
+ fi
+
+post-install:
+ @if [ ! -n "${NO_PO}" ]; \
+ then cd ${WRKSRC}/po && ${MAKE} install; \
+ fi
.include <bsd.port.mk>
diff --git a/net/whois/distinfo b/net/whois/distinfo
index 0d350782283c..2103e88020ad 100644
--- a/net/whois/distinfo
+++ b/net/whois/distinfo
@@ -1,2 +1,2 @@
-MD5 (whois_4.6.13.tar.gz) = 66068605f636ce79a017f1bc770251a3
-SIZE (whois_4.6.13.tar.gz) = 50400
+MD5 (whois_4.6.14.tar.gz) = fab689586c30fad567d7d1f924e9c937
+SIZE (whois_4.6.14.tar.gz) = 50570
diff --git a/net/whois/files/have_nls-patch b/net/whois/files/have_nls-patch
new file mode 100644
index 000000000000..94dd6b29acc2
--- /dev/null
+++ b/net/whois/files/have_nls-patch
@@ -0,0 +1,10 @@
+--- config.h.old Mon Apr 19 10:54:11 2004
++++ config.h Mon Apr 19 10:54:17 2004
+@@ -24,7 +24,6 @@
+ /* which versions? */
+ # define HAVE_GETOPT_LONG
+ # define HAVE_GETADDRINFO
+-# define ENABLE_NLS
+ # define LOCALEDIR "/usr/local/share/locale"
+ #endif
+
diff --git a/net/whois/files/patch-aa b/net/whois/files/patch-aa
index dc97e3fd4770..311f780c0898 100644
--- a/net/whois/files/patch-aa
+++ b/net/whois/files/patch-aa
@@ -1,7 +1,7 @@
-*** work/whois-4.6.6/Makefile Thu Dec 5 01:22:15 2002
---- Makefile Thu Oct 2 10:53:29 2003
+*** work/whois-4.6.13/Makefile Tue Feb 10 17:24:29 2004
+--- Makefile Thu Apr 15 16:11:14 2004
***************
-*** 9,16 ****
+*** 9,24 ****
#LDFLAGS=-lintl
# FreeBSD
@@ -10,29 +10,46 @@
# OS/2 EMX
#LDFLAGS=-lsocket -Zexe -Dstrncasecmp=strnicmp
---- 9,16 ----
+
+! ifdef HAVE_LIBIDN
+ LIBIDN += -lidn
+ CFLAGS += -DHAVE_LIBIDN
+! endif
+
+ PERL=perl
+
+--- 9,24 ----
#LDFLAGS=-lintl
# FreeBSD
-! LDFLAGS+=-L%%LOCALBASE%%/lib -lintl
-! CFLAGS+=-I%%LOCALBASE%%/include
+! LDFLAGS+=-L/usr/local/lib
+! CFLAGS+=-I/usr/local/include
# OS/2 EMX
#LDFLAGS=-lsocket -Zexe -Dstrncasecmp=strnicmp
+
+! .ifdef HAVE_LIBIDN
+ LIBIDN += -lidn
+ CFLAGS += -DHAVE_LIBIDN
+! .endif
+
+ PERL=perl
+
***************
-*** 35,41 ****
+*** 42,49 ****
install: whois
install -m 0755 whois $(BASEDIR)$(prefix)/bin/
strip $(BASEDIR)$(prefix)/bin/whois
! install -m 0644 whois.1 $(BASEDIR)$(prefix)/share/man/man1/
- cd po && $(MAKE) $@
+! cd po && $(MAKE) $@
---- 35,41 ----
+ distclean: clean
+--- 42,48 ----
install: whois
install -m 0755 whois $(BASEDIR)$(prefix)/bin/
strip $(BASEDIR)$(prefix)/bin/whois
! install -m 0644 whois.1 $(BASEDIR)$(prefix)/man/man1/
- cd po && $(MAKE) $@
+ distclean: clean
diff --git a/net/whois/files/patch-ac b/net/whois/files/patch-ac
new file mode 100644
index 000000000000..da130295e525
--- /dev/null
+++ b/net/whois/files/patch-ac
@@ -0,0 +1,30 @@
+*** work/whois-4.6.13/po/Makefile Thu Apr 15 15:58:17 2004
+--- po/Makefile Thu Apr 15 15:58:47 2004
+***************
+*** 7,12 ****
+--- 7,14 ----
+
+ POTFILES=../whois.c ../mkpasswd.c
+
++ .SUFFIXES: .po .mo
++
+ all: $(PACKAGE).pot $(CATALOGS)
+
+ $(PACKAGE).pot: $(POTFILES)
+***************
+*** 31,37 ****
+ fi; \
+ done
+
+! %.mo: %.po
+ msgfmt --statistics --check --verbose --output-file=$@ $<
+
+ clean:
+--- 33,39 ----
+ fi; \
+ done
+
+! .po.mo:
+ msgfmt --statistics --check --verbose --output-file=$@ $<
+
+ clean:
diff --git a/net/whois/pkg-plist b/net/whois/pkg-plist
index d4b98acb1367..e7589ad8a343 100644
--- a/net/whois/pkg-plist
+++ b/net/whois/pkg-plist
@@ -1,23 +1,23 @@
bin/whois
-share/locale/de/LC_MESSAGES/whois.mo
-share/locale/el/LC_MESSAGES/whois.mo
-share/locale/es/LC_MESSAGES/whois.mo
-share/locale/fr/LC_MESSAGES/whois.mo
-share/locale/it/LC_MESSAGES/whois.mo
-share/locale/no/LC_MESSAGES/whois.mo
-share/locale/pl/LC_MESSAGES/whois.mo
-@unexec rmdir %D/share/locale/pl/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/pl 2>/dev/null || true
-@unexec rmdir %D/share/locale/no/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/no 2>/dev/null || true
-@unexec rmdir %D/share/locale/it/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/it 2>/dev/null || true
-@unexec rmdir %D/share/locale/fr/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/fr 2>/dev/null || true
-@unexec rmdir %D/share/locale/es/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/es 2>/dev/null || true
-@unexec rmdir %D/share/locale/el/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/el 2>/dev/null || true
-@unexec rmdir %D/share/locale/de/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/de 2>/dev/null || true
-@unexec rmdir %D/share/locale 2>/dev/null || true
+%%NLS%%share/locale/de/LC_MESSAGES/whois.mo
+%%NLS%%share/locale/el/LC_MESSAGES/whois.mo
+%%NLS%%share/locale/es/LC_MESSAGES/whois.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/whois.mo
+%%NLS%%share/locale/it/LC_MESSAGES/whois.mo
+%%NLS%%share/locale/no/LC_MESSAGES/whois.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/whois.mo
+%%NLS%%@unexec rmdir %D/share/locale/pl/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/pl 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/no/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/no 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/it/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/it 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/fr/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/fr 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/es/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/es 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/el/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/el 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/de/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/de 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale 2>/dev/null || true