aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2015-02-21 20:15:11 +0000
committerKurt Jaeger <pi@FreeBSD.org>2015-02-21 20:15:11 +0000
commitb7cb41d4c0a0cbb82967aa7f6d37a0d316570fed (patch)
treed113e338f0b3bee5e9d045f37bbaf74cede18d75
parent6b4a1450e86b4517913b447514e4cc9f688a5021 (diff)
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/phpunit/Makefile32
-rw-r--r--devel/phpunit/distinfo2
-rw-r--r--devel/phpunit/pkg-descr4
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 37e623175c79..63aa0244a836 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3546,6 +3546,7 @@
SUBDIR += phpbt
SUBDIR += phpsh
SUBDIR += phptags
+ SUBDIR += phpunit
SUBDIR += physfs
SUBDIR += physfs-devel
SUBDIR += picp
diff --git a/devel/phpunit/Makefile b/devel/phpunit/Makefile
new file mode 100644
index 000000000000..164a39bab2cf
--- /dev/null
+++ b/devel/phpunit/Makefile
@@ -0,0 +1,32 @@
+# Created by: Torsten Zühlsdorff (<ports@toco-domains.de>)
+# $FreeBSD$
+
+PORTNAME= phpunit
+PORTVERSION= 4.5.0
+CATEGORIES= devel www
+MASTER_SITES= https://phar.phpunit.de/ \
+ http://ports.toco-domains.de/
+EXTRACT_SUFX= .phar
+
+MAINTAINER= ports@toco-domains.de
+COMMENT= Testing framework for unit tests
+
+LICENSE= BSD3CLAUSE
+
+CONFLICTS= pear-PHPUnit-[123]*
+
+USE_PHP= dom json spl pcre phar
+
+NO_BUILD= yes
+
+PLIST_FILES= bin/phpunit
+
+# Download isn't compressed or aggregated, it's just the single file
+do-extract:
+ ${CP} ${DISTDIR}/${DISTFILES} ${WRKDIR}/${PORTNAME}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} \
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/devel/phpunit/distinfo b/devel/phpunit/distinfo
new file mode 100644
index 000000000000..844db8975e3a
--- /dev/null
+++ b/devel/phpunit/distinfo
@@ -0,0 +1,2 @@
+SHA256 (phpunit-4.5.0.phar) = 3b33307128be5d4460eb344763b73ffa9d06b7be13a0db3c7e10566e64fb37b1
+SIZE (phpunit-4.5.0.phar) = 3411356
diff --git a/devel/phpunit/pkg-descr b/devel/phpunit/pkg-descr
new file mode 100644
index 000000000000..92eb3ee395ed
--- /dev/null
+++ b/devel/phpunit/pkg-descr
@@ -0,0 +1,4 @@
+PHPUnit is a regression testing framework used by the developer
+who implements unit tests in PHP.
+
+WWW: http://www.phpunit.de