aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2005-12-04 21:33:54 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2005-12-04 21:33:54 +0000
commitbad81ce6c9a45a5d62e25555708c9941ca645cd1 (patch)
tree3555ad1bb35ffc2e8590c05921e7cd2ec2761808
parentc60af73299383753a96712afed6f0feef505ff6b (diff)
downloadports-bad81ce6c9a45a5d62e25555708c9941ca645cd1.tar.gz
ports-bad81ce6c9a45a5d62e25555708c9941ca645cd1.zip
Notes
-rw-r--r--misc/gopod/Makefile19
-rw-r--r--misc/gopod/distinfo6
-rw-r--r--misc/gopod/files/extra-patch-gui.c (renamed from misc/gopod/files/extra-patch-main.c)12
-rw-r--r--misc/gtk-gopod/Makefile2
4 files changed, 24 insertions, 15 deletions
diff --git a/misc/gopod/Makefile b/misc/gopod/Makefile
index d37799a0bef1..0c8aed5caa1c 100644
--- a/misc/gopod/Makefile
+++ b/misc/gopod/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gopod
-PORTVERSION= 1.3
+PORTVERSION= 1.4
CATEGORIES= misc
MASTER_SITES= http://gopod.free-go.net/gopod/ \
http://critical.ch/distfiles/
@@ -20,6 +20,8 @@ HAS_CONFIGURE= yes
USE_GMAKE= yes
USE_REINPLACE= yes
+MAKE_ARGS+= CC="${CC}"
+
RESTRICTED= "Unclear legal status in EU countries"
.if ${PKGNAMEPREFIX} == ""
@@ -29,13 +31,20 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/console-version
PORTDOCS= README_EN README_FR
+post-extract:
+ @${FIND} -E ${WRKDIR} -type f -iregex ".*\.(c|h)" -print0 | \
+ ${XARGS} -0 ${REINPLACE_CMD} -e 's/[[:cntrl:]]*$$//'
+
post-patch:
.if ${PKGNAMEPREFIX} == "gtk-"
- @${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|' ${WRKSRC}/main.c
-.endif
- @${REINPLACE_CMD} -e 's/[[:cntrl:]]*$$//' ${WRKSRC}/main.c
- @${REINPLACE_CMD} -e 's|\($$(CC)\)|\1 ${CFLAGS}|; /strip/d' \
+ @${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|' ${WRKSRC}/gui.c
+ @${REINPLACE_CMD} -E \
+ 's/^(CFLAGS|LDFLAGS).*=/\1+=/; s|(OS_FLAGS\))|\1 $${CFLAGS}|' \
${WRKSRC}/Makefile
+.else
+ @${REINPLACE_CMD} -e 's|\($$(CC)\)|\1 $${CFLAGS}|; /strip/d' \
+ ${WRKSRC}/Makefile
+.endif
do-install:
.if ${PKGNAMEPREFIX} == ""
diff --git a/misc/gopod/distinfo b/misc/gopod/distinfo
index 3c4dea6fecb1..b4174002cdef 100644
--- a/misc/gopod/distinfo
+++ b/misc/gopod/distinfo
@@ -1,3 +1,3 @@
-MD5 (goPod-1.3_linux_bsd.tar.gz) = 2b1878b09524d2efebf3c59b8b7434a3
-SHA256 (goPod-1.3_linux_bsd.tar.gz) = 085b82ae5c26b3a7fb289ae21f78596d3c275bfcc4f95c7e17aacb9256d3d2c4
-SIZE (goPod-1.3_linux_bsd.tar.gz) = 91614
+MD5 (goPod-1.4_linux_bsd.tar.gz) = dac233ab5c1eb2702421d86d146cf12b
+SHA256 (goPod-1.4_linux_bsd.tar.gz) = ef84802cabeb884682e5acfedd5c4525ce74c6e1a45c3f8a79556cc0e5ddba22
+SIZE (goPod-1.4_linux_bsd.tar.gz) = 92914
diff --git a/misc/gopod/files/extra-patch-main.c b/misc/gopod/files/extra-patch-gui.c
index 08551e8910bd..a230de68ee0c 100644
--- a/misc/gopod/files/extra-patch-main.c
+++ b/misc/gopod/files/extra-patch-gui.c
@@ -1,8 +1,8 @@
---- main.c.orig Tue Oct 25 10:57:30 2005
-+++ main.c Tue Oct 25 10:59:23 2005
-@@ -5,11 +5,11 @@
- #include <gtk/gtk.h>
+--- gui.c.orig Sun Dec 4 14:32:24 2005
++++ gui.c Sun Dec 4 14:33:20 2005
+@@ -3,11 +3,11 @@
#include "gfx/mask.xpm"
+ #include "gopod.h"
-#define GFX_GO "gfx/go.png"
-#define GFX_GO_ "gfx/go_.png"
@@ -14,6 +14,6 @@
+#define GFX_NOTDETECTED "%%DATADIR%%/notdetected.png"
+#define GFX_CAPPED "%%DATADIR%%/capped.png"
+#define GFX_UNCAPPED "%%DATADIR%%/uncapped.png"
+ #define SQUARE(x) ((x)*(x))
- #if defined(__LINUX__)
- #define DEV "/dev/sd%c"
+ GtkWidget *pWindow;
diff --git a/misc/gtk-gopod/Makefile b/misc/gtk-gopod/Makefile
index 54ebd8b5c6f1..073462c28d5a 100644
--- a/misc/gtk-gopod/Makefile
+++ b/misc/gtk-gopod/Makefile
@@ -17,7 +17,7 @@ USE_GNOME= gtk20
RESTRICTED= "Unclear legal status in EU countries"
PLIST= ${.CURDIR}/pkg-plist
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-main.c
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-gui.c
WRKSRC= ${WRKDIR}/${DISTNAME}/gtk-version
DATAFILES= capped.png go.png go_.png mask.xpm notdetected.png uncapped.png