aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-27 07:45:19 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-27 07:45:19 +0000
commitc045a86372edce2c21237882d5368cd74dc6bacf (patch)
tree0e588c7090e385bc0aed850deb6734d7a96985aa
parentbf1f5c64da1f1bf5bc30af9a7d59aad9e80c90bd (diff)
Notes
-rw-r--r--print/alignmargins/Makefile20
1 files changed, 7 insertions, 13 deletions
diff --git a/print/alignmargins/Makefile b/print/alignmargins/Makefile
index ec3794520830..b9649ff0010f 100644
--- a/print/alignmargins/Makefile
+++ b/print/alignmargins/Makefile
@@ -16,26 +16,20 @@ COMMENT= Utility script to generate custom margins in PPDs for CUPS
NO_BUILD= yes
USES= perl5
-NO_STAGE= yes
do-extract:
- @${RM} -rf ${WRKDIR}
- @${MKDIR} ${WRKDIR}
@${MKDIR} ${WRKSRC}
- @for distfile in ${EXTRACT_ONLY}; do \
- if ! (cd ${WRKDIR} && ${CP} ${_DISTDIR}/$$distfile ${WRKSRC});\
- then \
- exit 1; \
- fi \
- done
+.for f in ${DISTFILES}
+ @${CP} ${DISTDIR}/${DIST_SUBDIR}/${f} ${WRKSRC}
+.endfor
post-patch:
- ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
-e 's|%%DATADIR%%|${DATADIR}|g' \
${WRKSRC}/alignmargins
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/alignmargins ${LOCALBASE}/bin
- ${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/align.ps ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/align.ps ${STAGEDIR}${DATADIR}
.include <bsd.port.mk>