aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-09-22 10:48:57 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-09-22 10:48:57 +0000
commitcb9a2b582c78cfb0c7bbe285c417c9362b3213d3 (patch)
treec94257e28b8e5f01fe14d767f8a4ade36ad9d111
parentb71796d585770ba247cf80126abc37abf7e80c7f (diff)
downloadports-cb9a2b582c78cfb0c7bbe285c417c9362b3213d3.tar.gz
ports-cb9a2b582c78cfb0c7bbe285c417c9362b3213d3.zip
Notes
-rw-r--r--cad/klayout/files/patch-config-Makefile.conf2
-rw-r--r--databases/libmemcached/Makefile2
-rw-r--r--databases/mariadb100-server/Makefile1
-rw-r--r--databases/mariadb101-server/Makefile1
-rw-r--r--databases/mariadb102-server/Makefile1
-rw-r--r--databases/mariadb55-server/Makefile1
-rw-r--r--databases/redis-devel/Makefile3
-rw-r--r--databases/redis/Makefile3
-rw-r--r--databases/twemproxy/Makefile3
-rw-r--r--databases/virtuoso/Makefile4
-rw-r--r--devel/gearmand-devel/Makefile3
-rw-r--r--devel/gearmand/Makefile3
-rw-r--r--devel/google-perftools/Makefile3
-rw-r--r--devel/libosmocore/Makefile2
-rw-r--r--games/adgali/Makefile3
-rw-r--r--games/spring/Makefile8
-rw-r--r--games/super_methane_brothers/Makefile3
-rw-r--r--games/ufoai/Makefile4
-rw-r--r--lang/rubinius/Makefile4
-rw-r--r--multimedia/audacious-gtk3/Makefile6
-rw-r--r--multimedia/audacious/Makefile6
-rw-r--r--multimedia/avidemux/Makefile.common5
-rw-r--r--multimedia/tvheadend/Makefile4
-rw-r--r--net/mpich2/Makefile2
-rw-r--r--polish/ekg/Makefile3
-rw-r--r--ports-mgmt/packagekit/Makefile3
-rw-r--r--sysutils/boxbackup/Makefile6
-rw-r--r--sysutils/htop/Makefile3
-rw-r--r--textproc/zorba/Makefile8
-rw-r--r--textproc/zorba/files/patch-CMakeLists.txt2
-rw-r--r--www/links-hacked/Makefile3
-rw-r--r--www/mod_spdy/Makefile2
-rw-r--r--www/mod_spdy/files/patch-base.gypi4
-rw-r--r--x11-wm/afterstep-stable/Makefile7
-rw-r--r--x11-wm/afterstep-stable/files/patch-configure6
-rw-r--r--x11-wm/afterstep-stable/files/patch-libAfterBase-configure2
-rw-r--r--x11-wm/afterstep-stable/files/patch-libAfterConf-Makefile.in2
-rw-r--r--x11-wm/afterstep-stable/files/patch-libAfterImage-configure4
38 files changed, 42 insertions, 90 deletions
diff --git a/cad/klayout/files/patch-config-Makefile.conf b/cad/klayout/files/patch-config-Makefile.conf
index 9198fd8baeab..2acd58ad4d77 100644
--- a/cad/klayout/files/patch-config-Makefile.conf
+++ b/cad/klayout/files/patch-config-Makefile.conf
@@ -34,7 +34,7 @@
+LOPT=${LDFLAGS} -g -Wl,-E -o
+LOPT_SO=${LDFLAGS} -g -shared -o
+
-+LIBS=${PTHREAD_LIBS} -L$(QTLIB) -lQtGui -lQtCore -lQtXml -lQtNetwork -lQtSql -lQtDesigner -lrt -lm -lcrypt -lz -L$(LOCALBASE)/lib -lexecinfo
++LIBS=${PTHREAD_LIBS} -L$(QTLIB) -lQtGui -lQtCore -lQtXml -lQtNetwork -lQtSql -lQtDesigner -lrt -lm -lcrypt -lz -lexecinfo
+
+.PHONY: install
+install:
diff --git a/databases/libmemcached/Makefile b/databases/libmemcached/Makefile
index 45ce603e74e3..274ac131943f 100644
--- a/databases/libmemcached/Makefile
+++ b/databases/libmemcached/Makefile
@@ -23,7 +23,7 @@ CONFIGURE_ARGS= --without-memcached \
--without-sphinx-build \
--enable-libmemcachedprotocol
-LIBS+= -L${LOCALBASE}/lib -lexecinfo
+LIBS+= -lexecinfo
CXXFLAGS+= -D__STDC_CONSTANT_MACROS -pthread
OPTIONS_DEFINE= DEBUG DTRACE MEMASLAP SASL
diff --git a/databases/mariadb100-server/Makefile b/databases/mariadb100-server/Makefile
index 0b60e3b4bd4d..22521698bfeb 100644
--- a/databases/mariadb100-server/Makefile
+++ b/databases/mariadb100-server/Makefile
@@ -59,7 +59,6 @@ CMAKE_ARGS+= -DINSTALL_DOCDIR="share/doc/mariadb" \
-DWITH_LIBEDIT=0 \
-DWITH_SSL=${OPENSSLBASE} \
-DWITH_LIBWRAP=1 \
- -DEXECINFO_ROOT=${LOCALBASE} \
-DCOMPILATION_COMMENT="FreeBSD Ports"
DATADIR= ${PREFIX}/share/mysql
diff --git a/databases/mariadb101-server/Makefile b/databases/mariadb101-server/Makefile
index 2354ba4c5d7d..e6166eb4cfe0 100644
--- a/databases/mariadb101-server/Makefile
+++ b/databases/mariadb101-server/Makefile
@@ -90,7 +90,6 @@ CMAKE_ARGS+= -DINSTALL_DOCDIR="share/doc/mysql" \
-DWITH_LIBWRAP=1 \
-DWITH_SSL=${OPENSSLBASE} \
-DKRB5_CONFIG=${KRB5CONFIG} \
- -DEXECINFO_ROOT=${LOCALBASE} \
-DCOMPILATION_COMMENT="FreeBSD Ports"
DATADIR= ${PREFIX}/share/mysql
diff --git a/databases/mariadb102-server/Makefile b/databases/mariadb102-server/Makefile
index b4916af78180..afc4c55d6730 100644
--- a/databases/mariadb102-server/Makefile
+++ b/databases/mariadb102-server/Makefile
@@ -93,7 +93,6 @@ CMAKE_ARGS+= -DINSTALL_DOCDIR="share/doc/mysql" \
-DCURSES_CURSES_LIBRARY="/usr/lib/libcurses.so" \
-DCURSES_FORM_LIBRARY="/usr/lib/libform.so" \
-DCURSES_CURSES_LIBRARY="/usr/lib/libncurses.so" \
- -DEXECINFO_ROOT="${LOCALBASE}" \
-DICONV_LIBRARIES="${ICONV_LIB_PATH}" \
-DKRB5_CONFIG="${KRB5CONFIG}" \
-DCURSES_NCURSES_LIBRARY="${NCURSESLIB}/libncurses.so" \
diff --git a/databases/mariadb55-server/Makefile b/databases/mariadb55-server/Makefile
index 6404076fa5ee..28580286c70f 100644
--- a/databases/mariadb55-server/Makefile
+++ b/databases/mariadb55-server/Makefile
@@ -46,7 +46,6 @@ CMAKE_ARGS+= -DINSTALL_DOCDIR="share/doc/mysql" \
-DWITH_UNIT_TESTS=0 \
-DWITH_LIBWRAP=1 \
-DWITH_SSL=yes \
- -DEXECINFO_ROOT=${LOCALBASE} \
-DCOMPILATION_COMMENT="FreeBSD Ports"
DATADIR= ${PREFIX}/share/mysql
diff --git a/databases/redis-devel/Makefile b/databases/redis-devel/Makefile
index d834628b9d8f..ebb9130c596a 100644
--- a/databases/redis-devel/Makefile
+++ b/databases/redis-devel/Makefile
@@ -58,8 +58,7 @@ LDFLAGS+= -Wl,-E
USES+= tcl:build
.endif
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lpthread -lm -lexecinfo
+LDFLAGS+= -lpthread -lm -lexecinfo
CONFLICTS?= redis-3.*
diff --git a/databases/redis/Makefile b/databases/redis/Makefile
index a7780d672da7..826a8a31a7f5 100644
--- a/databases/redis/Makefile
+++ b/databases/redis/Makefile
@@ -47,8 +47,7 @@ LDFLAGS+= -Wl,-E
USES+= tcl:build
.endif
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lpthread -lm -lexecinfo
+LDFLAGS+= -lpthread -lm -lexecinfo
CONFLICTS?= redis-devel-3.*
diff --git a/databases/twemproxy/Makefile b/databases/twemproxy/Makefile
index 19eb8477db7e..e753a0bccc69 100644
--- a/databases/twemproxy/Makefile
+++ b/databases/twemproxy/Makefile
@@ -16,8 +16,7 @@ GH_ACCOUNT= twitter
USES= autoreconf libtool
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo
+LDFLAGS+= -lexecinfo
PLIST_FILES= sbin/nutcracker \
man/man8/nutcracker.8.gz \
diff --git a/databases/virtuoso/Makefile b/databases/virtuoso/Makefile
index 2d2f41cd246c..813fb58d6ece 100644
--- a/databases/virtuoso/Makefile
+++ b/databases/virtuoso/Makefile
@@ -41,8 +41,8 @@ CONFIGURE_ARGS= --with-readline\
--with-layout=freebsd\
--datadir="${PREFIX}"\
--localstatedir="${PREFIX}"
-CPPFLAGS+= -std=gnu89 ${IODBC_CPPFLAGS} -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo
+CPPFLAGS+= -std=gnu89 ${IODBC_CPPFLAGS}
+LDFLAGS+= -lexecinfo
MAKE_ENV= PATH=${LOCALBASE}/bin:${PATH}\
ISQL=isql-vt
USE_RC_SUBR= virtuoso
diff --git a/devel/gearmand-devel/Makefile b/devel/gearmand-devel/Makefile
index fd5a312cd234..8962a92cb39f 100644
--- a/devel/gearmand-devel/Makefile
+++ b/devel/gearmand-devel/Makefile
@@ -32,8 +32,7 @@ SUB_LIST+= USERS=${USERS} GROUPS=${GROUPS}
CONFIGURE_ARGS+=--with-lib-prefix=${LOCALBASE} --with-boost=${LOCALBASE} \
--localstatedir=/var/db/${PORTNAME} --enable-static
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo
+LDFLAGS+= -lexecinfo
OPTIONS_DEFINE= DRIZZLE MEMCACHED PGSQL SQLITE MYSQL HIREDIS TOKYOCAB
OPTIONS_DEFAULT=SQLITE
diff --git a/devel/gearmand/Makefile b/devel/gearmand/Makefile
index 0154c283429a..589189c277b8 100644
--- a/devel/gearmand/Makefile
+++ b/devel/gearmand/Makefile
@@ -31,8 +31,7 @@ SUB_LIST+= USERS=${USERS} GROUPS=${GROUPS}
CONFIGURE_ARGS+=--with-lib-prefix=${LOCALBASE} --with-boost=${LOCALBASE} \
--localstatedir=/var/db/${PORTNAME} --enable-static
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo
+LDFLAGS+= -lexecinfo
OPTIONS_DEFINE= DRIZZLE MEMCACHED PGSQL SQLITE MYSQL HIREDIS TOKYOCAB
OPTIONS_DEFAULT=SQLITE
diff --git a/devel/google-perftools/Makefile b/devel/google-perftools/Makefile
index 8835ec2956ab..4adcd870b6a3 100644
--- a/devel/google-perftools/Makefile
+++ b/devel/google-perftools/Makefile
@@ -28,8 +28,7 @@ USES= compiler gmake libtool
USE_LDCONFIG= yes
TEST_TARGET= check
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib -lexecinfo
+LIBS+= -lexecinfo
OPTIONS_DEFINE= DOCS
OPTIONS_DEFAULT=PAGE8K ALIGN16
diff --git a/devel/libosmocore/Makefile b/devel/libosmocore/Makefile
index 1002bfa76a1d..d30d03612f0d 100644
--- a/devel/libosmocore/Makefile
+++ b/devel/libosmocore/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libpcsclite.so:devel/pcsc-lite
USES= alias autoreconf gmake libtool pathfix pkgconfig
GNU_CONFIGURE= yes
-LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo
+LDFLAGS+= -lexecinfo
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
PORTDOCS= *
diff --git a/games/adgali/Makefile b/games/adgali/Makefile
index 81801a798763..7ab60847d7f5 100644
--- a/games/adgali/Makefile
+++ b/games/adgali/Makefile
@@ -25,8 +25,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-compile-optim=no
INSTALL_TARGET= install-strip
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo
+LDFLAGS+= -lexecinfo
OPTIONS_DEFINE= DOCS
diff --git a/games/spring/Makefile b/games/spring/Makefile
index 09db4c439c32..9a3f3a62f39a 100644
--- a/games/spring/Makefile
+++ b/games/spring/Makefile
@@ -44,12 +44,6 @@ CMAKE_ARGS= -DDATADIR:STRING="share/${PORTNAME}" \
WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}
-.if exists(/usr/lib/libexecinfo.so)
-LEI_PREFIX= /usr
-.else
-LEI_PREFIX= ${LOCALBASE}
-.endif
-
# Do not exctract bundled copies of header files for 3rd-party packages:
EXTRACT_AFTER_ARGS=--no-same-owner --no-same-permissions --exclude ${WRKSRC:T}/include
@@ -101,7 +95,7 @@ post-patch:
${WRKSRC}/rts/System/Sync/FPUCheck.cpp
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/rts/build/cmake/*.cmake
- @${REINPLACE_CMD} -e 's|execinfo|${LEI_PREFIX}/lib/libexecinfo.so|' \
+ @${REINPLACE_CMD} -e 's|execinfo|/usr/lib/libexecinfo.so|' \
${WRKSRC}/rts/CMakeLists.txt \
${WRKSRC}/rts/builds/dedicated/CMakeLists.txt
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' \
diff --git a/games/super_methane_brothers/Makefile b/games/super_methane_brothers/Makefile
index 1bf096d44267..5f09d6b49597 100644
--- a/games/super_methane_brothers/Makefile
+++ b/games/super_methane_brothers/Makefile
@@ -19,8 +19,7 @@ USES= gmake pkgconfig tar:tgz
MAKE_ENV= METHANE_FLAGS="${CPPFLAGS}" METHANE_LIBS="${LIBS}"
MAKE_JOBS_UNSAFE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib -lexecinfo
+LIBS+= -lexecinfo
DATADIR= ${PREFIX}/share/methane
diff --git a/games/ufoai/Makefile b/games/ufoai/Makefile
index 9d82c92e44d4..c47b4067b6b5 100644
--- a/games/ufoai/Makefile
+++ b/games/ufoai/Makefile
@@ -29,9 +29,7 @@ USES= compiler:c++11-lang gettext gmake jpeg openal:soft pkgconfig \
python:build tar:bzip2
HAS_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-release --target-os=freebsd
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -lpthread -L${LOCALBASE}/lib -lexecinfo
-CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -lpthread -lexecinfo
DATADIR= share/${PORTNAME}
SUB_FILES= pkg-message
diff --git a/lang/rubinius/Makefile b/lang/rubinius/Makefile
index 1d254dd06ab7..b8539c384d48 100644
--- a/lang/rubinius/Makefile
+++ b/lang/rubinius/Makefile
@@ -90,10 +90,6 @@ LLVM40_VARS= LLVM_CONFIG=llvm-config40 \
.include <bsd.port.pre.mk>
-.if !exists(/usr/lib/libexecinfo.so)
-CONFIGURE_ARGS+= --with-opt-dir "${LOCALBASE}"
-.endif
-
.if ${ARCH} == "sparc64"
BROKEN= Does not compile on sparc64
.elif ${ARCH} == "amd64"
diff --git a/multimedia/audacious-gtk3/Makefile b/multimedia/audacious-gtk3/Makefile
index 2c69d56748f3..b46b5ff03aa0 100644
--- a/multimedia/audacious-gtk3/Makefile
+++ b/multimedia/audacious-gtk3/Makefile
@@ -49,10 +49,10 @@ EXECINFO_DESC= Build with libexecinfo support
.include <bsd.port.options.mk>
post-patch:
-.if ${PORT_OPTIONS:MEXECINFO} || exists(${LOCALBASE}/lib/libexecinfo.so)
- @${REINPLACE_CMD} 's|-lm |-lm -L${LOCALBASE}/lib -lexecinfo |' \
+.if ${PORT_OPTIONS:MEXECINFO}
+ @${REINPLACE_CMD} 's|-lm |-lm -lexecinfo |' \
${WRKSRC}/src/audacious/Makefile
- @${REINPLACE_CMD} 's|-laudcore|-laudcore -L${LOCALBASE}/lib -lexecinfo|' \
+ @${REINPLACE_CMD} 's|-laudcore|-laudcore -lexecinfo|' \
${WRKSRC}/audacious.pc.in
.endif
${REINPLACE_CMD} -e 's| $${MFLAGS}||g' \
diff --git a/multimedia/audacious/Makefile b/multimedia/audacious/Makefile
index ed84fb73b108..9148a3ef5b06 100644
--- a/multimedia/audacious/Makefile
+++ b/multimedia/audacious/Makefile
@@ -44,10 +44,10 @@ EXECINFO_DESC= Build with libexecinfo support
.include <bsd.port.options.mk>
post-patch:
-.if ${PORT_OPTIONS:MEXECINFO} || exists(${LOCALBASE}/lib/libexecinfo.so)
- @${REINPLACE_CMD} 's|-lm |-lm -L${LOCALBASE}/lib -lexecinfo |' \
+.if ${PORT_OPTIONS:MEXECINFO}
+ @${REINPLACE_CMD} 's|-lm |-lm -lexecinfo |' \
${WRKSRC}/src/audacious/Makefile
- @${REINPLACE_CMD} 's|-laudcore|-laudcore -L${LOCALBASE}/lib -lexecinfo|' \
+ @${REINPLACE_CMD} 's|-laudcore|-laudcore -lexecinfo|' \
${WRKSRC}/audacious.pc.in
.endif
${REINPLACE_CMD} -e 's| $${MFLAGS}||g' \
diff --git a/multimedia/avidemux/Makefile.common b/multimedia/avidemux/Makefile.common
index 8653bfe09873..0a314c600c0c 100644
--- a/multimedia/avidemux/Makefile.common
+++ b/multimedia/avidemux/Makefile.common
@@ -76,13 +76,8 @@ CFLAGS+= -fno-omit-frame-pointer
#MAKE_ENV+= ARCH=x86_64
#CONFIGURE_ENV+= ARCH=x86_64
.endif
-.if !exists(/usr/lib/libexecinfo.so)
-CMAKE_ARGS+= -DLIBEXECINFO_INCLUDE_DIR=${LOCALBASE}/include
-CMAKE_ARGS+= -DLIBEXECINFO_LIBRARY_DIR=${LOCALBASE}/lib/libexecinfo.so
-.else
CMAKE_ARGS+= -DLIBEXECINFO_INCLUDE_DIR=/usr/include
CMAKE_ARGS+= -DLIBEXECINFO_LIBRARY_DIR=-lexecinfo
-.endif
# We haven't ALSA(Never) & Aften(Yet) on FreeBSD
CMAKE_ARGS+= -DARTS:BOOL=OFF -DALSA:BOOL=OFF -DAFTEN:BOOL=OFF
diff --git a/multimedia/tvheadend/Makefile b/multimedia/tvheadend/Makefile
index 298fe4714757..4f2b64ec2400 100644
--- a/multimedia/tvheadend/Makefile
+++ b/multimedia/tvheadend/Makefile
@@ -48,8 +48,8 @@ SUB_LIST+= TVHUSER="${TVHUSER}" \
CONFIGURE_ENV+= PLATFORM=freebsd
CONFIGURE_ARGS+=--disable-dvbscan --disable-zlib --disable-hdhomerun_static \
--disable-bintray_cache --disable-ffmpeg_static --disable-pie
-CFLAGS+= -I${LOCALBASE}/include -Wno-conversion -Wno-int-to-pointer-cast
-LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo -lssl -lcrypto -lz
+CFLAGS+= -Wno-conversion -Wno-int-to-pointer-cast
+LDFLAGS+= -lexecinfo -lssl -lcrypto -lz
OPTIONS_DEFINE= AVAHI DVBCSA HDHOMERUN INOTIFY TRANSCODING XMLTV
OPTIONS_DEFAULT=DVBCSA HDHOMERUN INOTIFY
diff --git a/net/mpich2/Makefile b/net/mpich2/Makefile
index fba459a8ebc5..51f34d43cd18 100644
--- a/net/mpich2/Makefile
+++ b/net/mpich2/Makefile
@@ -49,7 +49,7 @@ CONFIGURE_ENV= FCFLAGS="${FFLAGS}" \
.if ${FFLAGS} == "-O"
FFLAGS= -O2
.endif
-LDFLAGS+= -lpthread -L${LOCALBASE}/lib -lexecinfo
+LDFLAGS+= -lpthread -lexecinfo
MAKE_ENV= CCACHE_DISABLE=yes PACKAGE=${PORTNAME}
NOCCACHE= yes
diff --git a/polish/ekg/Makefile b/polish/ekg/Makefile
index 4f70cdc5dec9..a3b57c73ed2b 100644
--- a/polish/ekg/Makefile
+++ b/polish/ekg/Makefile
@@ -21,8 +21,7 @@ CONFIGURE_ARGS= --without-libungif \
--without-libjpeg \
--disable-ui-gtk
-CFLAGS+= -I/usr/include -I${LOCALBASE}/include
-LDFLAGS+= -lncurses -L${LOCALBASE}/lib -lexecinfo -pthread
+LDFLAGS+= -lncurses -lexecinfo -pthread
OPTIONS_DEFINE= ASPELL OPENSSL
OPTIONS_DEFAULT= OPENSSL
diff --git a/ports-mgmt/packagekit/Makefile b/ports-mgmt/packagekit/Makefile
index 16475096f9d5..bec6fe564b41 100644
--- a/ports-mgmt/packagekit/Makefile
+++ b/ports-mgmt/packagekit/Makefile
@@ -28,8 +28,7 @@ SHEBANG_FILES= backends/test/helpers/search-name.sh \
USE_GNOME= glib20 intltool introspection
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib -lexecinfo
+LIBS+= -lexecinfo
CONFIGURE_ARGS+=--with-security-framework=polkit \
--localstatedir=/var \
--disable-static \
diff --git a/sysutils/boxbackup/Makefile b/sysutils/boxbackup/Makefile
index 0da754644077..5582e8de6d81 100644
--- a/sysutils/boxbackup/Makefile
+++ b/sysutils/boxbackup/Makefile
@@ -20,11 +20,7 @@ GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf aclocal autoheader
ACLOCAL_ARGS+= -I ${WRKSRC}/infrastructure/m4
CFLAGS+= -I${OPENSSLINC}
-LDFLAGS+= -L${OPENSSLLIB}
-
-.if exists(/usr/lib/libexecinfo.so)
-LDFLAGS+= -lexecinfo
-.endif
+LDFLAGS+= -L${OPENSSLLIB} -lexecinfo
MAKE_JOBS_UNSAFE=yes
diff --git a/sysutils/htop/Makefile b/sysutils/htop/Makefile
index 26d25cf68398..5ba3c183f7f9 100644
--- a/sysutils/htop/Makefile
+++ b/sysutils/htop/Makefile
@@ -13,8 +13,7 @@ LICENSE= GPLv2
RUN_DEPENDS= lsof:sysutils/lsof
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib -lexecinfo
+LIBS+= -lexecinfo
CONFIGURE_ARGS= --enable-unicode
USES= autoreconf libtool ncurses
diff --git a/textproc/zorba/Makefile b/textproc/zorba/Makefile
index ba18e075093d..b18682a0124a 100644
--- a/textproc/zorba/Makefile
+++ b/textproc/zorba/Makefile
@@ -50,12 +50,6 @@ PLIST_SUB+= FULLVERSION=${PORTVERSION} \
MIDVERSION=${PORTVERSION:R} \
MINVERSION=${PORTVERSION:R:R}
-.if exists(/usr/lib/libexecinfo.so)
-LOC_EXECINFO= /usr/lib/libexecinfo.so
-.else
-LOC_EXECINFO= ${LOCALBASE}/lib/libexecinfo.so
-.endif
-
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPHP}
@@ -91,7 +85,7 @@ BUILD_DEPENDS+= swig2.0:devel/swig20
.endif
post-patch:
- ${REINPLACE_CMD} -e 's|%%LIBEXECINFO%%|${LOC_EXECINFO}|' \
+ ${REINPLACE_CMD} \
-e 's|FreeBSD|${OPSYS}|g' ${WRKSRC}/CMakeLists.txt
${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/cmake_modules/FindPHP5.cmake
diff --git a/textproc/zorba/files/patch-CMakeLists.txt b/textproc/zorba/files/patch-CMakeLists.txt
index d116c45a837d..6a53f85f2d92 100644
--- a/textproc/zorba/files/patch-CMakeLists.txt
+++ b/textproc/zorba/files/patch-CMakeLists.txt
@@ -18,7 +18,7 @@
+# execinfo
+#
+IF(FREEBSD)
-+ SET(requiredlibs ${requiredlibs} "%%LIBEXECINFO%%")
++ SET(requiredlibs ${requiredlibs} "/usr/lib/libexecinfo.so")
+ENDIF(FREEBSD)
+
+#
diff --git a/www/links-hacked/Makefile b/www/links-hacked/Makefile
index 5155a1dfffc2..b9c74ce65ff2 100644
--- a/www/links-hacked/Makefile
+++ b/www/links-hacked/Makefile
@@ -18,8 +18,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ssl --without-pmshell --without-atheos --without-fb
CFLAGS+= -Wno-error=return-type
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo
+LDFLAGS+= -lexecinfo
CONFLICTS= links-[0-9]*
diff --git a/www/mod_spdy/Makefile b/www/mod_spdy/Makefile
index 3d6b1976b92c..1a2a5afc1714 100644
--- a/www/mod_spdy/Makefile
+++ b/www/mod_spdy/Makefile
@@ -38,7 +38,7 @@ GYP_DEFINES+= \
system_include_path_httpd=${LOCALBASE}/include/apache22 \
system_include_path_apr=${LOCALBASE}/include/apr-1 \
system_include_path_aprutil=${LOCALBASE}/include/apr-1 \
- system_include_path_execinfo=${LOCALBASE}/include \
+ system_include_path_execinfo=/usr/include \
include_dirs=${LOCALBASE}/include
SUB_FILES+= mod_spdy.conf
diff --git a/www/mod_spdy/files/patch-base.gypi b/www/mod_spdy/files/patch-base.gypi
index 2fd1a7baa2b1..6ae78a6ca390 100644
--- a/www/mod_spdy/files/patch-base.gypi
+++ b/www/mod_spdy/files/patch-base.gypi
@@ -1,10 +1,12 @@
+FIXME: this feels a bit silly now.
+
--- base/base.gypi.org 2012-03-31 16:28:56.347804000 +0900
+++ base/base.gypi 2012-03-31 17:03:22.470770534 +0900
@@ -7,6 +7,7 @@
'variables': {
'base_target': 0,
'chromium_root': '<(DEPTH)/third_party/chromium/src',
-+ 'system_include_path_execinfo%': '%%LOCALBASE%%/include',
++ 'system_include_path_execinfo%': '/usr/include',
},
'target_conditions': [
# This part is shared between the targets defined below. Only files and
diff --git a/x11-wm/afterstep-stable/Makefile b/x11-wm/afterstep-stable/Makefile
index 54ca1d689273..aeceab702c5d 100644
--- a/x11-wm/afterstep-stable/Makefile
+++ b/x11-wm/afterstep-stable/Makefile
@@ -56,10 +56,6 @@ PLIST_SUB+= GNOME=""
PLIST_SUB+= GNOME="@comment "
.endif
-.if !exists(/usr/lib/libexecinfo.so)
-STATIC_LIBEXECINFO= ${LOCALBASE}/lib/libexecinfo.a
-.endif
-
post-extract:
${CP} ${FILESDIR}/monitor_bsd.xpm \
${WRKSRC}/afterstep/desktop/icons/xml/monitor-bsd.xpm
@@ -85,9 +81,6 @@ post-patch:
@${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},g' \
${WRKSRC}/${f}
.endfor
- @${REINPLACE_CMD} \
- -e 's,%%STATIC_LIBEXECINFO%%,${STATIC_LIBEXECINFO},g' \
- ${WRKSRC}/configure
.if exists(${PREFIX}/share/gnome/wm-properties)
pre-install:
diff --git a/x11-wm/afterstep-stable/files/patch-configure b/x11-wm/afterstep-stable/files/patch-configure
index cbbc10624a2a..d53965cab59f 100644
--- a/x11-wm/afterstep-stable/files/patch-configure
+++ b/x11-wm/afterstep-stable/files/patch-configure
@@ -5,7 +5,7 @@
if test "x$enable_staticlibs" = "xyes"; then
- AFTERBASE_LIB="../../libAfterBase/libAfterBase.a"
-+ AFTERBASE_LIB="../../libAfterBase/libAfterBase.a %%STATIC_LIBEXECINFO%%"
++ AFTERBASE_LIB="../../libAfterBase/libAfterBase.a
AFTERIMAGE_LIB="../../libAfterImage/libAfterImage.a"
AFTERSTEP_LIB="../../libAfterStep/libAfterStep.a"
AFTERCONF_LIB="../../libAfterConf/libAfterConf.a"
@@ -14,7 +14,7 @@
LIBINSTALL="install.cyg"
else
- AFTERBASE_LIB="../../libAfterBase/libAfterBase.so"
-+ AFTERBASE_LIB="../../libAfterBase/libAfterBase.so %%STATIC_LIBEXECINFO%%"
++ AFTERBASE_LIB="../../libAfterBase/libAfterBase.so
AFTERIMAGE_LIB="../../libAfterImage/libAfterImage.so"
AFTERSTEP_LIB="../../libAfterStep/libAfterStep.so"
AFTERCONF_LIB="../../libAfterConf/libAfterConf.so"
@@ -23,7 +23,7 @@
fi
-AFTERBASE_STATIC_LIB="../../libAfterBase/libAfterBase.a"
-+AFTERBASE_STATIC_LIB="../../libAfterBase/libAfterBase.a %%STATIC_LIBEXECINFO%%"
++AFTERBASE_STATIC_LIB="../../libAfterBase/libAfterBase.a
AFTERIMAGE_STATIC_LIB="../../libAfterImage/libAfterImage.a"
AFTERSTEP_STATIC_LIB="../../libAfterStep/libAfterStep.a"
AFTERCONF_STATIC_LIB="../../libAfterConf/libAfterConf.a"
diff --git a/x11-wm/afterstep-stable/files/patch-libAfterBase-configure b/x11-wm/afterstep-stable/files/patch-libAfterBase-configure
index fa125f4bc0f2..f66c555be866 100644
--- a/x11-wm/afterstep-stable/files/patch-libAfterBase-configure
+++ b/x11-wm/afterstep-stable/files/patch-libAfterBase-configure
@@ -4,7 +4,7 @@
-+execinfo_libs="-L%%LOCALBASE%%/lib -lexecinfo"
++execinfo_libs="-lexecinfo"
+LIBS="$execinfo_libs $LIBS"
for ac_func in backtrace_symbols_fd backtrace_symbols backtrace
do
diff --git a/x11-wm/afterstep-stable/files/patch-libAfterConf-Makefile.in b/x11-wm/afterstep-stable/files/patch-libAfterConf-Makefile.in
index 787ecc9307db..2bcd822903bc 100644
--- a/x11-wm/afterstep-stable/files/patch-libAfterConf-Makefile.in
+++ b/x11-wm/afterstep-stable/files/patch-libAfterConf-Makefile.in
@@ -5,7 +5,7 @@
LIBS_PRIVATE = ../libAfterConf/libAfterConf.a ../libAfterStep/libAfterStep.a\
- ../libAfterImage/libAfterImage.a ../libAfterBase/libAfterBase.a
-+ ../libAfterImage/libAfterImage.a ../libAfterBase/libAfterBase.a -L%%LOCALBASE%%/lib -lexecinfo
++ ../libAfterImage/libAfterImage.a ../libAfterBase/libAfterBase.a -lexecinfo
LIB_INCS= afterconf.h
diff --git a/x11-wm/afterstep-stable/files/patch-libAfterImage-configure b/x11-wm/afterstep-stable/files/patch-libAfterImage-configure
index 40bff32e6985..b044ede80708 100644
--- a/x11-wm/afterstep-stable/files/patch-libAfterImage-configure
+++ b/x11-wm/afterstep-stable/files/patch-libAfterImage-configure
@@ -5,10 +5,10 @@
AFTERBASE_C=
if test "x$have_x" != "xyes" -a "x$have_gif" = "xyes"; then
- AFTERIMAGE_LIBS="$AFTERIMAGE_LIBS -lAfterBase"
-+ AFTERIMAGE_LIBS="$AFTERIMAGE_LIBS -lAfterBase -L%%LOCALBASE%%/lib -lexecinfo"
++ AFTERIMAGE_LIBS="$AFTERIMAGE_LIBS -lAfterBase -lexecinfo"
else
- AFTERIMAGE_LIBS="-lAfterBase $AFTERIMAGE_LIBS"
-+ AFTERIMAGE_LIBS="-lAfterBase -L%%LOCALBASE%%/lib -lexecinfo $AFTERIMAGE_LIBS"
++ AFTERIMAGE_LIBS="-lAfterBase -lexecinfo $AFTERIMAGE_LIBS"
fi
if test -r "../libAfterBase/astypes.h"; then
AFTERIMAGE_APPS_LIBS="-L../ -L../../libAfterBase -lAfterImage $AFTERIMAGE_LIBS"