aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2013-01-06 16:26:53 +0000
committerSteve Wills <swills@FreeBSD.org>2013-01-06 16:26:53 +0000
commitcdc55ad872963e32699e49a9665f87ab802c933b (patch)
treed3e527755edc1b32a81f30d65fb5cee7cb29978d
parent55f17a4bbbd935891a1a1b0f8312eb90b806ef68 (diff)
downloadports-cdc55ad872963e32699e49a9665f87ab802c933b.tar.gz
ports-cdc55ad872963e32699e49a9665f87ab802c933b.zip
Notes
-rw-r--r--sysutils/puppet/Makefile14
-rw-r--r--sysutils/puppet/distinfo4
-rw-r--r--sysutils/puppet/files/optpatch-package_origin4
-rw-r--r--sysutils/puppet/files/puppet.in7
-rw-r--r--sysutils/puppet/pkg-plist3
5 files changed, 15 insertions, 17 deletions
diff --git a/sysutils/puppet/Makefile b/sysutils/puppet/Makefile
index bcac919dfb57..520a97b73e51 100644
--- a/sysutils/puppet/Makefile
+++ b/sysutils/puppet/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= puppet
-PORTVERSION= 3.0.1
-PORTREVISION= 2
+PORTVERSION= 3.0.2
+PORTREVISION= 0
CATEGORIES= sysutils
MASTER_SITES= http://downloads.puppetlabs.com/puppet/
@@ -24,6 +24,7 @@ PORTEXAMPLES= *
USERS= puppet
GROUPS= puppet
SUB_FILES+= pkg-message
+SUB_LIST= RUBY=${RUBY}
MANCOMPRESSED= yes
MAN5= puppet.conf.5
@@ -87,13 +88,12 @@ do-install:
post-install:
${INSTALL} -d ${ETCDIR}
${INSTALL} -m 0755 -o puppet -g puppet -d /var/puppet
- ${INSTALL} -m 0755 -o puppet -g puppet -d /var/run/puppet
${INSTALL} -m 0644 ${WRKSRC}/conf/auth.conf ${ETCDIR}/auth.conf-dist
- ${RUBY} -I ${RUBY_SITELIBDIR} ${PREFIX}/bin/puppet --genconfig \
+ ${RUBY} -I ${RUBY_SITELIBDIR} ${PREFIX}/bin/puppet master --genconfig \
--confdir=${ETCDIR} \
- --rundir=/var/run/puppet | \
- ${SED} -e 's/genconfig = true/# genconfig = false/' | \
- ${SED} -e 's/factdest =/# factdest =/' \
+ --rundir=/var/run/puppet \
+ --vardir=/var/lib/puppet \
+ --logdir=/var/log/puppet \
> ${ETCDIR}/puppet.conf-dist
@${ECHO} ${RUBY_SITELIBDIR}/puppet.rb | \
${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
diff --git a/sysutils/puppet/distinfo b/sysutils/puppet/distinfo
index 70531b4df724..70da7d78acc5 100644
--- a/sysutils/puppet/distinfo
+++ b/sysutils/puppet/distinfo
@@ -1,2 +1,2 @@
-SHA256 (puppet-3.0.1.tar.gz) = 5e4d0cfdd6989faf4f6c5c76c0d3bcfa0364e380549be1a2f7c3abd22b0b562b
-SIZE (puppet-3.0.1.tar.gz) = 1505102
+SHA256 (puppet-3.0.2.tar.gz) = e4d73ae9953764b0c70c1327c9105ec9a17f03b33d50e622611491c886796d6b
+SIZE (puppet-3.0.2.tar.gz) = 1534566
diff --git a/sysutils/puppet/files/optpatch-package_origin b/sysutils/puppet/files/optpatch-package_origin
index 971cb41066a3..92756545efce 100644
--- a/sysutils/puppet/files/optpatch-package_origin
+++ b/sysutils/puppet/files/optpatch-package_origin
@@ -30,8 +30,8 @@
- def self.listcmd
- command(:pkginfo)
-+ @@lock = Mutex.new
-+ @@ports_index = nil
++ class_variable_set(:@@lock, Mutex.new)
++ class_variable_set(:@@ports_index, new)
+
+ # fix bug in URI::FTP merge method that tries to set typecode
+ # even when other is a string.
diff --git a/sysutils/puppet/files/puppet.in b/sysutils/puppet/files/puppet.in
index d98c9d5d64f3..c741d40c14f6 100644
--- a/sysutils/puppet/files/puppet.in
+++ b/sysutils/puppet/files/puppet.in
@@ -5,6 +5,7 @@
# PROVIDE: puppet
# REQUIRE: NETWORK
+# KEYWORD: shutdown
#
# Add the following lines to /etc/rc.conf to enable the puppet agent:
@@ -20,13 +21,13 @@ load_rc_config "$name"
: ${puppet_enable="NO"}
: ${puppet_rundir="/var/run/puppet"}
-: ${puppet_flags="--rundir=${puppet_rundir}"}
-command_interpreter="%%PREFIX%%/bin/ruby18"
command="%%PREFIX%%/bin/puppet"
-command_args="agent ${puppet_flags}"
+command_args="agent ${puppet_flags} --rundir=${puppet_rundir}"
+command_interpreter=%%RUBY%%
unset puppet_flags
pidfile="${puppet_rundir}/agent.pid"
+start_precmd="install -d -o puppet -g puppet ${pidfile%/*}"
run_rc_command "$1"
diff --git a/sysutils/puppet/pkg-plist b/sysutils/puppet/pkg-plist
index ae04afb3cb73..fa8545bcfeea 100644
--- a/sysutils/puppet/pkg-plist
+++ b/sysutils/puppet/pkg-plist
@@ -7,9 +7,6 @@ bin/puppet
%%ETCDIR%%/auth.conf-dist
@dirrmtry etc/puppet
@unexec rmdir /var/puppet 2>/dev/null || true
-@unexec rmdir /var/run/puppet 2>/dev/null || true
-@exec /bin/mkdir -p /var/run/puppet
-@exec /usr/sbin/chown -Rh puppet:puppet /var/run/puppet
@exec /bin/mkdir -p /var/puppet
@exec /usr/sbin/chown -Rh puppet:puppet /var/puppet
@dirrm %%RUBY_SITELIBDIR%%/hiera/backend