aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-12-12 19:57:07 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-12-12 19:57:07 +0000
commitd1bf378aa017f2d0890a89bad5f70d26d1496bee (patch)
treec4da63ee2bba982d4ba798ea29fbc557d46868a8
parentf748db01eef4adb5b7a49613b66fa8828582c8be (diff)
audio/csound: 6.12.2 -> 6.12.2-83
Reported by: GH issue notification
Notes
Notes: svn path=/head/; revision=487322
-rw-r--r--audio/csound/Makefile6
-rw-r--r--audio/csound/distinfo6
-rw-r--r--audio/csound/files/patch-CMakeLists.txt12
-rw-r--r--audio/csound/files/patch-cmake_Modules_FindFAUST.cmake6
4 files changed, 16 insertions, 14 deletions
diff --git a/audio/csound/Makefile b/audio/csound/Makefile
index 211f239e97dc..47a19d15ddde 100644
--- a/audio/csound/Makefile
+++ b/audio/csound/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= csound
-DISTVERSION= 6.12.2
-PORTREVISION= 3
+DISTVERSION= 6.12.2-83
+DISTVERSIONSUFFIX= -gdf2edd269
CATEGORIES= audio lang
MAINTAINER= yuri@FreeBSD.org
@@ -79,7 +79,7 @@ FAUST_CMAKE_ON= -DFAUST_LLVM_VERSION:STRING=${FAUST_LLVM_VERSION}
FLUIDSYNTH_DESC= Building FluidSynth opcodes
FLUIDSYNTH_LIB_DEPENDS= libfluidsynth.so:audio/fluidsynth
FLUIDSYNTH_CMAKE_BOOL= BUILD_FLUID_OPCODES
-FLUIDSYNTH_BROKEN= FluidSynth 2.x is broken upstream: https://github.com/csound/csound/issues/1078#issuecomment-441459803
+xFLUIDSYNTH_BROKEN= FluidSynth 2.x is broken upstream: https://github.com/csound/csound/issues/1078#issuecomment-441459803
HDF5_DESC= Build HDF5 read/write opcodes
HDF5_LIB_DEPENDS= libhdf5.so:science/hdf5 \
diff --git a/audio/csound/distinfo b/audio/csound/distinfo
index 9c3eb56ef563..3eb7e3409847 100644
--- a/audio/csound/distinfo
+++ b/audio/csound/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1542488559
-SHA256 (csound-csound-6.12.2_GH0.tar.gz) = 39f4872b896eb1cbbf596fcacc0f2122fd3e5ebbb5cec14a81b4207d6b8630ff
-SIZE (csound-csound-6.12.2_GH0.tar.gz) = 26297850
+TIMESTAMP = 1544642888
+SHA256 (csound-csound-6.12.2-83-gdf2edd269_GH0.tar.gz) = e14038c44fd954bea0fcb34af994757ca5f4fe75f99c80a1e8df867d5b9e7eee
+SIZE (csound-csound-6.12.2-83-gdf2edd269_GH0.tar.gz) = 26295519
diff --git a/audio/csound/files/patch-CMakeLists.txt b/audio/csound/files/patch-CMakeLists.txt
index 2d6f0f93e3dd..17afbd946d21 100644
--- a/audio/csound/files/patch-CMakeLists.txt
+++ b/audio/csound/files/patch-CMakeLists.txt
@@ -1,4 +1,4 @@
---- CMakeLists.txt.orig 2018-11-07 14:05:23 UTC
+--- CMakeLists.txt.orig 2018-12-12 19:23:43 UTC
+++ CMakeLists.txt
@@ -164,8 +164,8 @@ endif()
@@ -35,7 +35,7 @@
set(LINUX YES)
else()
set(LINUX NO)
-@@ -527,15 +527,17 @@ find_package(FLTK )
+@@ -527,9 +527,11 @@ find_package(FLTK )
# LIST_REPLACE(FLTK_LIBRARIES 2 "fltk_images_SHARED")
# endif()
#endif()
@@ -43,13 +43,15 @@
-find_package(Java)
-find_package(JNI)
+if (BUILD_FAUST_OPCODES)
-+ find_package(FAUST)
++ find_package(FAUST)
+endif()
+#find_package(Java)
+#find_package(JNI)
find_package(LIBLO)
find_package(LUAJIT)
find_package(MUSICXML)
+@@ -540,7 +542,7 @@ find_package(MUSICXML)
+
find_package(PORTSMF)
find_package(PythonLibs 2.7)
-if(NOT STK_LOCAL)
@@ -57,7 +59,7 @@
find_package(STK)
endif()
find_package(SWIG)
-@@ -1245,11 +1247,11 @@ if(CURL_FOUND)
+@@ -1251,11 +1253,11 @@ if(USE_CURL AND CURL_FOUND)
endif()
# Linux does not have a separate libintl, it is part of libc
@@ -71,7 +73,7 @@
list(APPEND libcsound_LIBS ${LIBINTL_LIBRARY})
endif()
list(APPEND libcsound_CFLAGS -DGNU_GETTEXT)
-@@ -1269,8 +1271,8 @@ endif()
+@@ -1275,8 +1277,8 @@ endif()
if(LINUX)
message(STATUS "Building on Linux.")
diff --git a/audio/csound/files/patch-cmake_Modules_FindFAUST.cmake b/audio/csound/files/patch-cmake_Modules_FindFAUST.cmake
index 40e45b4557cc..d554b2cd42c1 100644
--- a/audio/csound/files/patch-cmake_Modules_FindFAUST.cmake
+++ b/audio/csound/files/patch-cmake_Modules_FindFAUST.cmake
@@ -1,4 +1,4 @@
---- cmake/Modules/FindFAUST.cmake.orig 2018-11-17 16:56:13 UTC
+--- cmake/Modules/FindFAUST.cmake.orig 2018-12-12 19:23:43 UTC
+++ cmake/Modules/FindFAUST.cmake
@@ -27,7 +27,7 @@ if(FAUST_FOUND)
# This is a static build of faust, hence
@@ -7,5 +7,5 @@
- find_program(LLVM_CONFIG llvm-config HINTS /usr/bin /usr/local/bin /usr/local/opt/llvm/bin)
+ find_program(LLVM_CONFIG llvm-config${FAUST_LLVM_VERSION} HINTS /usr/bin /usr/local/bin /usr/local/opt/llvm/bin)
if(NOT LLVM_CONFIG)
- message(FATAL_ERROR "Using a static Faust library requires LLVM tooling to be present in the path")
- endif()
+ message(WARNING "Using a static Faust library requires LLVM tooling to be present in the path.")
+ UNSET(FAUST_FOUND)