aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2019-02-16 17:13:24 +0000
committerKoop Mast <kwm@FreeBSD.org>2019-02-16 17:13:24 +0000
commitd46064a146ec58e8dde07b7ab64c39e401a438db (patch)
tree688d7bc057a755e056ec8275e3cd20927b0ee967
parent2786ad6c885ca0d5dccccfcc95f7dc680254143e (diff)
downloadports-d46064a146ec58e8dde07b7ab64c39e401a438db.tar.gz
ports-d46064a146ec58e8dde07b7ab64c39e401a438db.zip
Notes
-rw-r--r--x11-themes/gtk-arc-themes/Makefile3
-rw-r--r--x11-toolkits/gtk30/Makefile7
-rw-r--r--x11-toolkits/gtk30/distinfo6
-rw-r--r--x11-toolkits/gtk30/files/patch-gdk_wayland_gdkdevice-wayland.c15
-rw-r--r--x11-toolkits/gtk30/pkg-plist9
5 files changed, 17 insertions, 23 deletions
diff --git a/x11-themes/gtk-arc-themes/Makefile b/x11-themes/gtk-arc-themes/Makefile
index f9bb48e67cca..b399952c1e7b 100644
--- a/x11-themes/gtk-arc-themes/Makefile
+++ b/x11-themes/gtk-arc-themes/Makefile
@@ -21,9 +21,10 @@ USE_GITHUB= yes
GH_ACCOUNT= horst3180
GH_PROJECT= arc-theme
-USES= autoreconf pkgconfig
+USES= autoreconf gnome pkgconfig
GNU_CONFIGURE= yes
USE_GNOME= gtk20 gtk30
NO_ARCH= yes
+CONFIGURE_ARGS= --with-gnome=3.22
.include <bsd.port.mk>
diff --git a/x11-toolkits/gtk30/Makefile b/x11-toolkits/gtk30/Makefile
index 96bb2ea28f80..c27ad8cfe626 100644
--- a/x11-toolkits/gtk30/Makefile
+++ b/x11-toolkits/gtk30/Makefile
@@ -4,8 +4,7 @@
# adwaita-icon-theme, gnome-themes-standard and mate-themes
PORTNAME= gtk
-PORTVERSION= 3.22.30
-PORTREVISION= 4
+PORTVERSION= 3.24.5
CATEGORIES= x11-toolkits
MASTER_SITES= GNOME/sources/gtk+/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
PKGNAMESUFFIX= 3
@@ -33,7 +32,6 @@ USE_PERL5= build
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_GNOME= atk cairo gdkpixbuf2 introspection:build pango
-#gtk-update-icon-cache
USES= compiler:c11 gettext gmake gnome libtool localbase \
pathfix perl5 pkgconfig tar:xz
USE_XORG= xext xrender x11 xinerama xi xrandr xcursor xfixes xdamage \
@@ -44,7 +42,7 @@ CPPFLAGS+= -fno-omit-frame-pointer
INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
-LIBVERSION= 0.2200.30
+LIBVERSION= 0.2404.1
PLIST_SUB+= LIBVERSION=${LIBVERSION}
GLIB_SCHEMAS= org.gtk.Demo.gschema.xml \
@@ -84,6 +82,7 @@ WAYLAND_BUILD_DEPENDS= wayland-protocols>=0:graphics/wayland-protocols \
WAYLAND_LIB_DEPENDS= libwayland-egl.so:graphics/wayland \
libxkbcommon.so:x11/libxkbcommon
WAYLAND_RUN_DEPENDS= wayland-protocols>=0:graphics/wayland-protocols
+WAYLAND_USES= gl
WAYLAND_USE= GL=egl
post-patch:
diff --git a/x11-toolkits/gtk30/distinfo b/x11-toolkits/gtk30/distinfo
index 78cfa842702a..effd1813ec48 100644
--- a/x11-toolkits/gtk30/distinfo
+++ b/x11-toolkits/gtk30/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1524773157
-SHA256 (gnome/gtk+-3.22.30.tar.xz) = a1a4a5c12703d4e1ccda28333b87ff462741dc365131fbc94c218ae81d9a6567
-SIZE (gnome/gtk+-3.22.30.tar.xz) = 18946084
+TIMESTAMP = 1549709459
+SHA256 (gnome/gtk+-3.24.5.tar.xz) = 0be5fb0d302bc3de26ab58c32990d895831e2b7c7418d0ffea1206d6a3ddb02f
+SIZE (gnome/gtk+-3.24.5.tar.xz) = 21012108
diff --git a/x11-toolkits/gtk30/files/patch-gdk_wayland_gdkdevice-wayland.c b/x11-toolkits/gtk30/files/patch-gdk_wayland_gdkdevice-wayland.c
deleted file mode 100644
index 0fb5b0655623..000000000000
--- a/x11-toolkits/gtk30/files/patch-gdk_wayland_gdkdevice-wayland.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- gdk/wayland/gdkdevice-wayland.c.orig 2018-03-25 16:25:12 UTC
-+++ gdk/wayland/gdkdevice-wayland.c
-@@ -38,11 +38,9 @@
-
- #include <xkbcommon/xkbcommon.h>
-
--#include <linux/input.h>
--
- #include <sys/time.h>
- #include <sys/mman.h>
--#include <linux/input.h>
-+#include <dev/evdev/input.h>
-
- #define BUTTON_BASE (BTN_LEFT - 1) /* Used to translate to 1-indexed buttons */
-
diff --git a/x11-toolkits/gtk30/pkg-plist b/x11-toolkits/gtk30/pkg-plist
index b7b245f3a956..afcb37bff0b5 100644
--- a/x11-toolkits/gtk30/pkg-plist
+++ b/x11-toolkits/gtk30/pkg-plist
@@ -249,6 +249,9 @@ include/gtk-3.0/gtk/gtkentrycompletion.h
include/gtk-3.0/gtk/gtkenums.h
include/gtk-3.0/gtk/gtkeventbox.h
include/gtk-3.0/gtk/gtkeventcontroller.h
+include/gtk-3.0/gtk/gtkeventcontrollerkey.h
+include/gtk-3.0/gtk/gtkeventcontrollermotion.h
+include/gtk-3.0/gtk/gtkeventcontrollerscroll.h
include/gtk-3.0/gtk/gtkexpander.h
include/gtk-3.0/gtk/gtkfilechooser.h
include/gtk-3.0/gtk/gtkfilechooserbutton.h
@@ -270,6 +273,7 @@ include/gtk-3.0/gtk/gtkgesturemultipress.h
include/gtk-3.0/gtk/gtkgesturepan.h
include/gtk-3.0/gtk/gtkgesturerotate.h
include/gtk-3.0/gtk/gtkgesturesingle.h
+include/gtk-3.0/gtk/gtkgesturestylus.h
include/gtk-3.0/gtk/gtkgestureswipe.h
include/gtk-3.0/gtk/gtkgesturezoom.h
include/gtk-3.0/gtk/gtkglarea.h
@@ -425,6 +429,7 @@ lib/gtk-3.0/%%GTK3_VERSION%%/immodules/im-ti-er.so
lib/gtk-3.0/%%GTK3_VERSION%%/immodules/im-ti-et.so
lib/gtk-3.0/%%GTK3_VERSION%%/immodules/im-viqr.so
%%WAYLAND%%lib/gtk-3.0/%%GTK3_VERSION%%/immodules/im-wayland.so
+%%WAYLAND%%lib/gtk-3.0/%%GTK3_VERSION%%/immodules/im-waylandgtk.so
lib/gtk-3.0/%%GTK3_VERSION%%/immodules/im-xim.so
%%CLOUDPRINT%%lib/gtk-3.0/%%GTK3_VERSION%%/printbackends/libprintbackend-cloudprint.so
%%CUPS%%lib/gtk-3.0/%%GTK3_VERSION%%/printbackends/libprintbackend-cups.so
@@ -711,6 +716,9 @@ share/gir-1.0/Gtk-3.0.gir
%%DATADIR%%-doc/html/gtk3/GtkEntryCompletion.html
%%DATADIR%%-doc/html/gtk3/GtkEventBox.html
%%DATADIR%%-doc/html/gtk3/GtkEventController.html
+%%DATADIR%%-doc/html/gtk3/GtkEventControllerKey.html
+%%DATADIR%%-doc/html/gtk3/GtkEventControllerMotion.html
+%%DATADIR%%-doc/html/gtk3/GtkEventControllerScroll.html
%%DATADIR%%-doc/html/gtk3/GtkExpander.html
%%DATADIR%%-doc/html/gtk3/GtkFileChooser.html
%%DATADIR%%-doc/html/gtk3/GtkFileChooserButton.html
@@ -734,6 +742,7 @@ share/gir-1.0/Gtk-3.0.gir
%%DATADIR%%-doc/html/gtk3/GtkGesturePan.html
%%DATADIR%%-doc/html/gtk3/GtkGestureRotate.html
%%DATADIR%%-doc/html/gtk3/GtkGestureSingle.html
+%%DATADIR%%-doc/html/gtk3/GtkGestureStylus.html
%%DATADIR%%-doc/html/gtk3/GtkGestureSwipe.html
%%DATADIR%%-doc/html/gtk3/GtkGestureZoom.html
%%DATADIR%%-doc/html/gtk3/GtkGrid.html