aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-12-21 14:55:52 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-12-21 14:55:52 +0000
commitd7f16adbb0920190ff15818bfe87b54f9c3b938e (patch)
treec5f3756857decf6bc39b5fb87fb9067da355063c
parentea8da1b8ec1fdf61d60c1f8685808576a29a6e8b (diff)
downloadports-d7f16adbb0920190ff15818bfe87b54f9c3b938e.tar.gz
ports-d7f16adbb0920190ff15818bfe87b54f9c3b938e.zip
Notes
-rw-r--r--comms/gnuradio/Makefile14
-rw-r--r--comms/svxlink/Makefile8
2 files changed, 11 insertions, 11 deletions
diff --git a/comms/gnuradio/Makefile b/comms/gnuradio/Makefile
index f43605d2c7ce..6cf01647735c 100644
--- a/comms/gnuradio/Makefile
+++ b/comms/gnuradio/Makefile
@@ -2,7 +2,7 @@
PORTNAME= gnuradio
PORTVERSION= 3.7.9.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= comms astro hamradio
MASTER_SITES= http://gnuradio.org/releases/gnuradio/ \
LOCAL/db
@@ -63,11 +63,11 @@ LIBSTRIP_FILES= analog atsc audio blocks channels digital dtv fcd fec fft\
filter noaa pager pmt qtgui runtime trellis video-sdl\
vocoder wavelet wxgui
-OPTIONS_DEFINE= UHD TESTING
+OPTIONS_DEFINE= UHD TESTING DOXYGEN
# Unfortunately building docs on i386 fails
-##OPTIONS_EXCLUDE_${i386}= DOCS
+##OPTIONS_EXCLUDE_${i386}= DOXYGEN
# Yay. building docs is broken on 10 and HEAD too so turn them all off
-OPTIONS_EXCLUDE= DOCS
+OPTIONS_EXCLUDE= DOXYGEN
OPTIONS_DEFAULT= UHD
OPTIONS_SUB= yes
UHD_DESC= Include UHD support from Ettus
@@ -75,15 +75,15 @@ TESTING_DESC= Include testing support
PLIST_SUB+= PORTVERSION=${PORTVERSION}
-DOCS_BUILD_DEPENDS= doxygen:devel/doxygen \
+DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen \
${LOCALBASE}/bin/sphinx-apidoc:textproc/py-sphinx \
dot:graphics/graphviz \
xmlto:textproc/xmlto \
freefont-ttf>0:x11-fonts/freefont-ttf
-DOCS_CMAKE_ON= -DENABLE_DOXYGEN:STRING="ON" \
+DOXYGEN_CMAKE_ON= -DENABLE_DOXYGEN:STRING="ON" \
-DENABLE_DOCS:STRING="ON" \
-DENABLE_BAD_BOOST="ON"
-DOCS_CMAKE_OFF= -DENABLE_DOXYGEN:STRING="OFF" \
+DOXYGEN_CMAKE_OFF= -DENABLE_DOXYGEN:STRING="OFF" \
-DENABLE_DOCS:STRING="OFF" \
-DENABLE_BAD_BOOST="ON"
HAVE_PORTDOCS= YES
diff --git a/comms/svxlink/Makefile b/comms/svxlink/Makefile
index 150fac055754..1037d611defe 100644
--- a/comms/svxlink/Makefile
+++ b/comms/svxlink/Makefile
@@ -34,7 +34,7 @@ CMAKE_ARGS+= -DUSE_QT:BOOL=NO
USE_LDCONFIG= yes
ALL_TARGET?= all man
-OPTIONS_DEFINE= DOCS STATIC
+OPTIONS_DEFINE= DOXYGEN STATIC
STATIC_DESC= Build and install static libraries
STATIC_CMAKE_ON= -DBUILD_STATIC_LIBS=YES
.if ${PORTNAME}==svxlink
@@ -47,9 +47,9 @@ ALSA_CMAKE_ON= -DUSE_ALSA:BOOL=ON
OSS_CMAKE_OFF= -DUSE_OSS:BOOL=OFF
OSS_CMAKE_ON= -DUSE_OSS:BOOL=ON
.endif
-DOCS_ALL_TARGET=doc
-DOCS_CMAKE_OFF= -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen:BOOL=TRUE
-DOCS_BUILD_DEPENDS= doxygen:devel/doxygen \
+DOXYGEN_ALL_TARGET=doc
+DOXYGEN_CMAKE_OFF= -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen:BOOL=TRUE
+DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen \
dot:graphics/graphviz
OPTIONS_SUB= yes
PORTDOCS= *