aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2013-01-06 21:01:02 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2013-01-06 21:01:02 +0000
commitd8f8f1de2141072b20e14769e9656cd522ab7b7f (patch)
treebdbe465dbee75f02a4f60d37f01412b240b6d68c
parent10329684c5095a58c65d19584b05981b7a03fb94 (diff)
downloadports-d8f8f1de2141072b20e14769e9656cd522ab7b7f.tar.gz
ports-d8f8f1de2141072b20e14769e9656cd522ab7b7f.zip
Notes
-rw-r--r--net/exabgp/Makefile5
-rw-r--r--net/exabgp/distinfo4
-rw-r--r--net/exabgp/files/exabgp.env2
-rw-r--r--net/exabgp/files/exabgp.in20
-rw-r--r--net/exabgp/files/pkg-message.in3
-rw-r--r--net/exabgp/pkg-plist37
6 files changed, 45 insertions, 26 deletions
diff --git a/net/exabgp/Makefile b/net/exabgp/Makefile
index f7ebf43fc45d..bbc2bbc9ac71 100644
--- a/net/exabgp/Makefile
+++ b/net/exabgp/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= exabgp
-PORTVERSION= 3.0.10
+PORTVERSION= 3.1.1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
EXTRACT_SUFX= .tgz
@@ -45,4 +45,7 @@ do-install:
${CP} ${FILESDIR}/exabgp.env ${ETCDIR} ; \
fi
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.mk>
diff --git a/net/exabgp/distinfo b/net/exabgp/distinfo
index 6d9074a9d6b1..22375eecaacd 100644
--- a/net/exabgp/distinfo
+++ b/net/exabgp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (exabgp-3.0.10.tgz) = c512b7b99d912a685d700abaad79dcb0f1de1eac13cd59641aef19fdd7542625
-SIZE (exabgp-3.0.10.tgz) = 317500
+SHA256 (exabgp-3.1.1.tgz) = 628e05956b0ea0dbac1342c278ac938f9cfb1553e2c8343cb173641f4afc9894
+SIZE (exabgp-3.1.1.tgz) = 335308
diff --git a/net/exabgp/files/exabgp.env b/net/exabgp/files/exabgp.env
index 09aa4fa04e75..352883c3f338 100644
--- a/net/exabgp/files/exabgp.env
+++ b/net/exabgp/files/exabgp.env
@@ -8,7 +8,7 @@ user = '_bgpd'
all = false
configuration = false
daemon = true
-destination = '/var/log/exabgp.log'
+destination = '/var/log/exabgp/exabgp.log'
enable = true
level = INFO
message = false
diff --git a/net/exabgp/files/exabgp.in b/net/exabgp/files/exabgp.in
index e4e0555c70c9..0645945c8208 100644
--- a/net/exabgp/files/exabgp.in
+++ b/net/exabgp/files/exabgp.in
@@ -19,7 +19,6 @@ load_rc_config $name
exabgp_enable=${exabgp_enable:-"NO"}
exabgp_conf=${exabgp_conf:-"%%ETCDIR%%/exabgp.conf"}
-exabgp_logfile=${exabgp_log:-"/var/log/exabgp.log"}
pidfile=/var/run/${name}/${name}.pid
@@ -28,21 +27,22 @@ required_files=${exabgp_conf}
command="%%PYTHON_SITELIBDIR%%/${name}/application.py"
procname="%%PYTHON_CMD%%"
-start_precmd="exabgp_precmd"
start_cmd="exabgp_start"
extra_commands="reload"
-exabgp_precmd()
-{
- install -d -o _bgpd -g _bgpd -m 755 /var/run/${name}
- touch ${exabgp_logfile}
- chown _bgpd:_bgpd ${exabgp_logfile}
-}
-
exabgp_start()
{
- echo "Starting ${name}..."
+ if [ -z "$rc_fast" -a -n "$rc_pid" ]; then
+ echo 1>&2 "${name} already running? (pid=$rc_pid)."
+ return 1
+ fi
+
+ echo "Starting ${name}."
+
+ install -d -o _bgpd -g _bgpd -m 755 /var/run/${name}
+ install -d -o _bgpd -g _bgpd -m 755 /var/log/${name}
rm -f ${pidfile}
+
${procname} ${command} -c %%ETCDIR%% ${exabgp_conf}
}
diff --git a/net/exabgp/files/pkg-message.in b/net/exabgp/files/pkg-message.in
index 3a9a72e6fbf5..41f9016d83c9 100644
--- a/net/exabgp/files/pkg-message.in
+++ b/net/exabgp/files/pkg-message.in
@@ -2,3 +2,6 @@ Sample configurations are located in %%EXAMPLESDIR%%.
Please create %%ETCDIR%%/exabgp.conf based on one of the above examples and
add exabgp_enable="YES" to /etc/rc.conf
+
+For information on using MD5 signatures, please visit the examples page at:
+https://code.google.com/p/exabgp/wiki/examples
diff --git a/net/exabgp/pkg-plist b/net/exabgp/pkg-plist
index cf716ffb5544..26bf26776e1c 100644
--- a/net/exabgp/pkg-plist
+++ b/net/exabgp/pkg-plist
@@ -2,20 +2,13 @@
etc/exabgp/exabgp.env
sbin/exabgp
%%PYTHON_SITELIBDIR%%/exabgp/__init__.py
+%%PYTHON_SITELIBDIR%%/exabgp/api.py
+%%PYTHON_SITELIBDIR%%/exabgp/api.pyc
%%PYTHON_SITELIBDIR%%/exabgp/application.py
%%PYTHON_SITELIBDIR%%/exabgp/bgp/__init__.py
%%PYTHON_SITELIBDIR%%/exabgp/bgp/connection.py
%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/__init__.py
-%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/eor.py
%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/keepalive.py
-%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/nlri/__init__.py
-%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/nlri/eor.py
-%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/nlri/flow.py
-%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/nlri/route.py
-%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/nlri/__init__.pyc
-%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/nlri/eor.pyc
-%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/nlri/flow.pyc
-%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/nlri/route.pyc
%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/nop.py
%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/notification.py
%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/open/__init__.py
@@ -46,6 +39,9 @@ sbin/exabgp
%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/open/version.pyc
%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/refresh.py
%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/update/__init__.py
+%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/update/__init__.pyc
+%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/update/eor.py
+%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/update/eor.pyc
%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/update/attribute/__init__.py
%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/update/attribute/aggregator.py
%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/update/attribute/aspath.py
@@ -78,9 +74,15 @@ sbin/exabgp
%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/update/attribute/nexthop.pyc
%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/update/attribute/origin.pyc
%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/update/attribute/originatorid.pyc
-%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/update/__init__.pyc
+%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/update/nlri/__init__.py
+%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/update/nlri/__init__.pyc
+%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/update/nlri/eor.py
+%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/update/nlri/eor.pyc
+%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/update/nlri/flow.py
+%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/update/nlri/flow.pyc
+%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/update/nlri/route.py
+%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/update/nlri/route.pyc
%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/__init__.pyc
-%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/eor.pyc
%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/keepalive.pyc
%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/nop.pyc
%%PYTHON_SITELIBDIR%%/exabgp/bgp/message/notification.pyc
@@ -95,6 +97,10 @@ sbin/exabgp
%%PYTHON_SITELIBDIR%%/exabgp/bgp/peer.pyc
%%PYTHON_SITELIBDIR%%/exabgp/bgp/protocol.pyc
%%PYTHON_SITELIBDIR%%/exabgp/bgp/timer.pyc
+%%PYTHON_SITELIBDIR%%/exabgp/compatibility/__init__.py
+%%PYTHON_SITELIBDIR%%/exabgp/compatibility/__init__.pyc
+%%PYTHON_SITELIBDIR%%/exabgp/compatibility/ipaddress.py
+%%PYTHON_SITELIBDIR%%/exabgp/compatibility/ipaddress.pyc
%%PYTHON_SITELIBDIR%%/exabgp/debug.py
%%PYTHON_SITELIBDIR%%/exabgp/leak/__init__.py
%%PYTHON_SITELIBDIR%%/exabgp/leak/gcdump.py
@@ -123,10 +129,13 @@ sbin/exabgp
%%PYTHON_SITELIBDIR%%/exabgp/rib/__init__.py
%%PYTHON_SITELIBDIR%%/exabgp/rib/delta.py
%%PYTHON_SITELIBDIR%%/exabgp/rib/table.py
+%%PYTHON_SITELIBDIR%%/exabgp/rib/watchdog.py
%%PYTHON_SITELIBDIR%%/exabgp/rib/__init__.pyc
%%PYTHON_SITELIBDIR%%/exabgp/rib/delta.pyc
%%PYTHON_SITELIBDIR%%/exabgp/rib/table.pyc
+%%PYTHON_SITELIBDIR%%/exabgp/rib/watchdog.pyc
%%PYTHON_SITELIBDIR%%/exabgp/structure/__init__.py
+%%PYTHON_SITELIBDIR%%/exabgp/structure/cache.py
%%PYTHON_SITELIBDIR%%/exabgp/structure/configuration.py
%%PYTHON_SITELIBDIR%%/exabgp/structure/daemon.py
%%PYTHON_SITELIBDIR%%/exabgp/structure/environment.py
@@ -135,6 +144,7 @@ sbin/exabgp
%%PYTHON_SITELIBDIR%%/exabgp/structure/supervisor.py
%%PYTHON_SITELIBDIR%%/exabgp/structure/utils.py
%%PYTHON_SITELIBDIR%%/exabgp/structure/__init__.pyc
+%%PYTHON_SITELIBDIR%%/exabgp/structure/cache.pyc
%%PYTHON_SITELIBDIR%%/exabgp/structure/configuration.pyc
%%PYTHON_SITELIBDIR%%/exabgp/structure/daemon.pyc
%%PYTHON_SITELIBDIR%%/exabgp/structure/environment.pyc
@@ -162,9 +172,11 @@ sbin/exabgp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/quagga/ebgpd.conf.v6
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/quagga/ebgpd.conf.v46
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/quagga/ebgpd.conf.v4
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/exabgp/processes/watchdog-1.pl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/exabgp/processes/watchdog-1.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/exabgp/processes/tcp-server
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/exabgp/processes/syslog-1.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/exabgp/processes/dynamic-1.pl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/exabgp/processes/dynamic-1.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/exabgp/ibgp6-simple.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/exabgp/ibgp4-withdrawn.txt
@@ -208,11 +220,12 @@ sbin/exabgp
@dirrm %%PYTHON_SITELIBDIR%%/exabgp/protocol/ip
@dirrm %%PYTHON_SITELIBDIR%%/exabgp/protocol
@dirrm %%PYTHON_SITELIBDIR%%/exabgp/bgp/message/update/attribute
+@dirrm %%PYTHON_SITELIBDIR%%/exabgp/bgp/message/update/nlri
@dirrm %%PYTHON_SITELIBDIR%%/exabgp/bgp/message/update
@dirrm %%PYTHON_SITELIBDIR%%/exabgp/bgp/message/open/capability
@dirrm %%PYTHON_SITELIBDIR%%/exabgp/bgp/message/open
-@dirrm %%PYTHON_SITELIBDIR%%/exabgp/bgp/message/nlri
@dirrm %%PYTHON_SITELIBDIR%%/exabgp/bgp/message
+@dirrm %%PYTHON_SITELIBDIR%%/exabgp/compatibility
@dirrm %%PYTHON_SITELIBDIR%%/exabgp/leak
@dirrm %%PYTHON_SITELIBDIR%%/exabgp/structure
@dirrm %%PYTHON_SITELIBDIR%%/exabgp/rib