aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2008-02-18 00:10:20 +0000
committerXin LI <delphij@FreeBSD.org>2008-02-18 00:10:20 +0000
commitdd46428dfa948cbae807f4c7b5be07cb8864741f (patch)
tree4165e13321a944ddea614fa487e718cfb24a1c85
parentbbff9f27173e92a14399671b470dc01beedf94d7 (diff)
downloadports-dd46428dfa948cbae807f4c7b5be07cb8864741f.tar.gz
ports-dd46428dfa948cbae807f4c7b5be07cb8864741f.zip
Notes
-rw-r--r--mail/libvmime/Makefile8
-rw-r--r--mail/libvmime/files/patch-configure59
2 files changed, 63 insertions, 4 deletions
diff --git a/mail/libvmime/Makefile b/mail/libvmime/Makefile
index 4d1d149b30e0..e708d46264d5 100644
--- a/mail/libvmime/Makefile
+++ b/mail/libvmime/Makefile
@@ -7,9 +7,9 @@
PORTNAME= libvmime
PORTVERSION= 0.8.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= mail
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITES= SF
MASTER_SITE_SUBDIR= vmime
MAINTAINER= delphij@FreeBSD.org
@@ -25,14 +25,14 @@ USE_GCC= 3.3+
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= -I${LOCALBASE}/include -D_GLIBCXX__PTHREADS
LDFLAGS+= -L${LOCALBASE}/lib
.ifndef DEBUG
CONFIGURE_ARGS+=--disable-debug
.endif
-CONFIGURE_ENV+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV+= EXTRA_CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
DOCSDIR= ${PREFIX}/share/doc/vmime
diff --git a/mail/libvmime/files/patch-configure b/mail/libvmime/files/patch-configure
new file mode 100644
index 000000000000..44ccd5bc6a3d
--- /dev/null
+++ b/mail/libvmime/files/patch-configure
@@ -0,0 +1,59 @@
+--- configure.orig 2006-12-20 11:27:52.000000000 -0800
++++ configure 2008-02-17 15:53:22.664811475 -0800
+@@ -3455,13 +3455,13 @@
+ CFLAGS=$ac_save_CFLAGS
+ elif test $ac_cv_prog_cc_g = yes; then
+ if test "$GCC" = yes; then
+- CFLAGS="-g -O2"
++ CFLAGS="-g"
+ else
+ CFLAGS="-g"
+ fi
+ else
+ if test "$GCC" = yes; then
+- CFLAGS="-O2"
++ CFLAGS=""
+ else
+ CFLAGS=
+ fi
+@@ -4108,13 +4108,13 @@
+ CXXFLAGS=$ac_save_CXXFLAGS
+ elif test $ac_cv_prog_cxx_g = yes; then
+ if test "$GXX" = yes; then
+- CXXFLAGS="-g -O2"
++ CXXFLAGS="-g"
+ else
+ CXXFLAGS="-g"
+ fi
+ else
+ if test "$GXX" = yes; then
+- CXXFLAGS="-O2"
++ CXXFLAGS=""
+ else
+ CXXFLAGS=
+ fi
+@@ -7107,13 +7107,13 @@
+ FFLAGS=$ac_save_FFLAGS
+ elif test $ac_cv_prog_f77_g = yes; then
+ if test "x$ac_cv_f77_compiler_gnu" = xyes; then
+- FFLAGS="-g -O2"
++ FFLAGS="-g"
+ else
+ FFLAGS="-g"
+ fi
+ else
+ if test "x$ac_cv_f77_compiler_gnu" = xyes; then
+- FFLAGS="-O2"
++ FFLAGS=""
+ else
+ FFLAGS=
+ fi
+@@ -24916,7 +24916,7 @@
+ else
+ # -O2
+ OLD_CXXFLAGS="$CXXFLAGS"
+- CXXFLAGS="$CXXFLAGS -O2"
++ CXXFLAGS="$CXXFLAGS"
+ { echo "$as_me:$LINENO: checking whether cc accepts -O2" >&5
+ echo $ECHO_N "checking whether cc accepts -O2... $ECHO_C" >&6; }
+ cat >conftest.$ac_ext <<_ACEOF