aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2012-02-14 10:47:37 +0000
committerMartin Matuska <mm@FreeBSD.org>2012-02-14 10:47:37 +0000
commite24792fc914d567a90f9eaadaf80dc89f6454ab9 (patch)
tree13e6b47701fc43125c86261292ab94e16b609f9f
parent6f578f8bc06a6e3f1835cc3e94078cf26412b2cd (diff)
downloadports-e24792fc914d567a90f9eaadaf80dc89f6454ab9.tar.gz
ports-e24792fc914d567a90f9eaadaf80dc89f6454ab9.zip
Notes
-rw-r--r--GIDs1
-rw-r--r--UIDs1
-rw-r--r--mail/sqlgrey/Makefile8
-rw-r--r--mail/sqlgrey/distinfo4
-rw-r--r--mail/sqlgrey/files/pkg-install.in27
-rw-r--r--mail/sqlgrey/files/sqlgrey.in13
6 files changed, 17 insertions, 37 deletions
diff --git a/GIDs b/GIDs
index 1845f476691e..7e18eea2f43a 100644
--- a/GIDs
+++ b/GIDs
@@ -109,6 +109,7 @@ hg:*:212:
drizzle:*:213:
bs:*:220:
postgrey:*:225:
+sqlgrey:*:226:
kismet:*:229:
aprsd:*:240:
tnc:*:241:
diff --git a/UIDs b/UIDs
index b514a0ecba64..31f5788fb845 100644
--- a/UIDs
+++ b/UIDs
@@ -116,6 +116,7 @@ hg:*:212:212::0:0:mercurial-server user:/usr/local/hg:/bin/sh
drizzle:*:213:213::0:0:Drizzle daemon:/var/db/drizzle:/usr/sbin/nologin
bs:*:220:220::0:0:Big Sister:/usr/local/bigsister:/bin/sh
postgrey:*:225:225::0:0:Postgrey Owner:/nonexistent:/usr/sbin/nologin
+sqlgrey:*:226:226::0:0:SQLgrey Owner:/nonexistent:/usr/sbin/nologin
aprsd:*:240:240::0:0:aprsd:/nonexistent:/bin/sh
tnc:*:241:241::0:0:aprsd:/nonexistent:/bin/sh
prosody:*:242:242::0:0:Prosody Jabber Server:/nonexistent:/usr/sbin/nologin
diff --git a/mail/sqlgrey/Makefile b/mail/sqlgrey/Makefile
index 7857c85336ee..755decb74bf5 100644
--- a/mail/sqlgrey/Makefile
+++ b/mail/sqlgrey/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sqlgrey
-DISTVERSION= 1.8.0-rc2
+PORTVERSION= 1.8.0
CATEGORIES= mail
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-1.8%20%28stable%29
@@ -22,12 +22,12 @@ USE_RC_SUBR= sqlgrey
NO_BUILD= yes
ETCFILES= clients_fqdn_whitelist clients_ip_whitelist dyn_fqdn.regexp smtp_server.regexp sqlgrey.conf
-SGY_USERNAME?= sqlgrey
-SGY_GROUPNAME?= ${SGY_USERNAME}
+USERS= sqlgrey
+GROUPS= ${USERS}
ETCDIR?= etc/sqlgrey
SUB_FILES= pkg-install
-MY_SUB_LIST= ETCDIR=${ETCDIR} ETCFILES="${ETCFILES}" USER=${SGY_USERNAME} GROUP=${SGY_GROUPNAME} PERL=${PERL}
+MY_SUB_LIST= ETCDIR=${ETCDIR} ETCFILES="${ETCFILES}" USER=${USERS} GROUP=${GROUPS} PERL=${PERL}
SUB_LIST+= ${MY_SUB_LIST}
PLIST_SUB= TOUCH=${TOUCH} ${MY_SUB_LIST}
diff --git a/mail/sqlgrey/distinfo b/mail/sqlgrey/distinfo
index 7e264b92feee..4cc0eca85587 100644
--- a/mail/sqlgrey/distinfo
+++ b/mail/sqlgrey/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sqlgrey-1.8.0-rc2.tar.gz) = c109aab28c9dcf798beb708d1efa37facfb3dfacd0f15fa87b5f6c1f023d2068
-SIZE (sqlgrey-1.8.0-rc2.tar.gz) = 68821
+SHA256 (sqlgrey-1.8.0.tar.gz) = 94e0fa191b30d672b748e934728ca73383bf9b36e4b17618b01adaaba40280e2
+SIZE (sqlgrey-1.8.0.tar.gz) = 69476
diff --git a/mail/sqlgrey/files/pkg-install.in b/mail/sqlgrey/files/pkg-install.in
index 4c5fc0a5e787..9c7fc94636ef 100644
--- a/mail/sqlgrey/files/pkg-install.in
+++ b/mail/sqlgrey/files/pkg-install.in
@@ -15,23 +15,6 @@ case $2 in
exit 1
fi
- # Create group if required
- if /usr/sbin/pw group show "%%GROUP%%" >/dev/null 2>&1; then
- echo "---> Using existing group \"%%GROUP%%\""
- else
- echo "---> Adding group \"%%GROUP%%\""
- /usr/sbin/pw groupadd %%GROUP%% || exit 1
- fi
-
- # Create user if required
- if /usr/sbin/pw user show "%%USER%%" >/dev/null 2>&1; then
- echo "---> Using existing user \"%%USER%%\""
- else
- echo "---> Adding user \"%%USER%%\""
- /usr/sbin/pw useradd "%%USER%%" -g "%%GROUP%%" -h - \
- -d "%%DATADIR%%" -s "/sbin/nologin" -c "Sqlgrey Owner" || exit 1
- fi
-
# Create home directory if required
if [ -d "%%DATADIR%%" ]; then
echo "---> Using existing Sqlgrey database directory (%%DATADIR%%)"
@@ -47,14 +30,8 @@ case $2 in
POST-DEINSTALL)
- echo "---> Please, remember to remove the user and the group with :"
- if /usr/sbin/pw user show "%%USER%%" >/dev/null 2>&1; then
- echo " /usr/sbin/pw userdel -n %%USER%%"
- fi
- if /usr/sbin/pw group show "%%GROUP%%" >/dev/null 2>&1; then
- echo " /usr/sbin/pw groupdel -n %%GROUP%%"
- fi
- echo " as well as the databases."
+ echo "---> Please, remember to remove the database directory:"
+ echo " %%DATADIR%%"
echo " If you're only updating, you can leave the things as they are."
;;
diff --git a/mail/sqlgrey/files/sqlgrey.in b/mail/sqlgrey/files/sqlgrey.in
index bb2652bddb7f..2c807ba4fd62 100644
--- a/mail/sqlgrey/files/sqlgrey.in
+++ b/mail/sqlgrey/files/sqlgrey.in
@@ -24,16 +24,17 @@ command_interpreter=%%PERL%%
stop_postcmd=${name}_poststop
-sqlgrey_poststop()
-{
- rm -f $pidfile
-}
-
load_rc_config $name
sqlgrey_enable=${sqlgrey_enable-"NO"}
required_files=${sqlgrey_config-"%%PREFIX%%/%%ETCDIR%%/sqlgrey.conf"}
+pidfile=${sqlgrey_pidfile-"/var/run/sqlgrey.pid"}
-command_args="--configfile=${required_files} --daemonize"
+command_args="--configfile=${required_files} --pidfile=${pidfile} --daemonize"
+
+sqlgrey_poststop()
+{
+ rm -f $pidfile
+}
run_rc_command "$1"