aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woods <woodsb02@FreeBSD.org>2016-05-18 16:50:21 +0000
committerBen Woods <woodsb02@FreeBSD.org>2016-05-18 16:50:21 +0000
commitf509104ec9c20b9fcf74c8a08863bfc011264b96 (patch)
treeb3ae63b0626178bc5c53d13333687a3cfdc573c3
parent1d479ec4cd6a62a70904a31173b159f7d13860cb (diff)
downloadports-f509104ec9c20b9fcf74c8a08863bfc011264b96.tar.gz
ports-f509104ec9c20b9fcf74c8a08863bfc011264b96.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-nose/Makefile4
-rw-r--r--devel/py3-nose/Makefile8
3 files changed, 11 insertions, 2 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5d8dbe1c1569..da63668b0f12 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4616,6 +4616,7 @@
SUBDIR += py3-gobject3
SUBDIR += py3-jsonschema
SUBDIR += py3-libpeas
+ SUBDIR += py3-nose
SUBDIR += py3-pyicu
SUBDIR += py3-python-magic
SUBDIR += py3-pytz
diff --git a/devel/py-nose/Makefile b/devel/py-nose/Makefile
index b8d4cb57c59d..a4fae7c42727 100644
--- a/devel/py-nose/Makefile
+++ b/devel/py-nose/Makefile
@@ -13,7 +13,7 @@ COMMENT= Discovery-based unittest extension
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/lgpl.txt
-USES= python
+USES?= python
USE_PYTHON= autoplist concurrent distutils
.include <bsd.port.pre.mk>
@@ -23,6 +23,6 @@ regression-test: build
.if ${PYTHON_REL} >= 3000
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} build_tests
.endif
- @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+ @cd ${WRKSRC} && ${PYTHON_CMD} selftest.py
.include <bsd.port.post.mk>
diff --git a/devel/py3-nose/Makefile b/devel/py3-nose/Makefile
new file mode 100644
index 000000000000..20accbe4378c
--- /dev/null
+++ b/devel/py3-nose/Makefile
@@ -0,0 +1,8 @@
+# Created by: Ben Woods <woodsb02@FreeBSD.org>
+# $FreeBSD$
+
+MASTERDIR= ${.CURDIR}/../py-nose
+
+USES= python:3.1+
+
+.include "${MASTERDIR}/Makefile"