aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-09-16 16:58:41 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-09-16 16:58:41 +0000
commitf56f112403e0108e4a1caa3b8bd8197282cda9a6 (patch)
treef51a8ccd4c67dd7b906626d688870d3bd461a7d4
parent8bbe36048e84f63c2f9b313aa70806d28f88d82e (diff)
downloadports-f56f112403e0108e4a1caa3b8bd8197282cda9a6.tar.gz
ports-f56f112403e0108e4a1caa3b8bd8197282cda9a6.zip
Notes
-rw-r--r--deskutils/dailystrips/Makefile2
-rw-r--r--security/amavisd-new/Makefile3
-rw-r--r--security/axTLS/Makefile4
-rw-r--r--security/bro/Makefile3
-rw-r--r--security/ca_root_nss/Makefile3
-rw-r--r--security/ccrypt/Makefile5
-rw-r--r--security/courier-authlib/Makefile10
-rw-r--r--security/krb5/Makefile5
-rw-r--r--security/logcheck/Makefile2
-rw-r--r--security/maia/Makefile3
-rw-r--r--security/makepasswd/Makefile9
-rw-r--r--security/nikto/Makefile3
-rw-r--r--security/nss/Makefile4
-rw-r--r--security/p5-Digest-SHA-PurePerl/Makefile3
-rw-r--r--security/rkhunter/Makefile2
-rw-r--r--security/shishi/Makefile4
-rw-r--r--x11-wm/windowmaker/Makefile3
-rw-r--r--x11-wm/xfce4-panel/Makefile4
18 files changed, 32 insertions, 40 deletions
diff --git a/deskutils/dailystrips/Makefile b/deskutils/dailystrips/Makefile
index 9124372a9a9b..e89e6770ad02 100644
--- a/deskutils/dailystrips/Makefile
+++ b/deskutils/dailystrips/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-TimeDate>=0:${PORTSDIR}/devel/p5-TimeDate
NO_BUILD= yes
-USE_PERL5= yes
+USES= perl5
PORTDOCS= *
PLIST_FILES= bin/dailystrips \
diff --git a/security/amavisd-new/Makefile b/security/amavisd-new/Makefile
index 53da96ddbc53..4eb892cb95c5 100644
--- a/security/amavisd-new/Makefile
+++ b/security/amavisd-new/Makefile
@@ -22,7 +22,8 @@ RUN_DEPENDS= p5-Unix-Syslog>=0:${PORTSDIR}/sysutils/p5-Unix-Syslog \
p5-Net-Server>=0.93:${PORTSDIR}/net/p5-Net-Server \
p5-Mail-DKIM>=0.33:${PORTSDIR}/mail/p5-Mail-DKIM
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
NO_BUILD= yes
diff --git a/security/axTLS/Makefile b/security/axTLS/Makefile
index 0e12a423f80d..039fc0ff26f7 100644
--- a/security/axTLS/Makefile
+++ b/security/axTLS/Makefile
@@ -38,7 +38,7 @@ HIGH_DESC= Use the strongest cipher(s) at the cost of speed
CONFIG_SUB= PREFIX=\"${PREFIX}\" WWWDIR=\"${WWWDIR}\" \
HTTP_PORT=${WITH_HTTP_PORT} SSL_PORT=${WITH_SSL_PORT}
NO_OPTIONS_SORT=yes
-USE_GMAKE= yes
+USES= gmake
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
STAGE= ${WRKSRC}/_stage
@@ -122,7 +122,7 @@ CONFIG_SUB+= X509="\# "
BUILD_DEPENDS+= swig:${PORTSDIR}/devel/swig13
CONFIG_SUB+= PERL=""
PLIST_SUB+= PERL=""
-USE_PERL5= yes
+USES+= perl5
.else
CONFIG_SUB+= PERL="\# "
PLIST_SUB+= PERL="@comment "
diff --git a/security/bro/Makefile b/security/bro/Makefile
index f4718b7e7140..ae36078d4057 100644
--- a/security/bro/Makefile
+++ b/security/bro/Makefile
@@ -14,8 +14,7 @@ BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison \
swig:${PORTSDIR}/devel/swig13
LIB_DEPENDS= GeoIP:${PORTSDIR}/net/GeoIP
-USE_PERL5= yes
-USES= cmake
+USES= cmake perl5
CONFIGURE_WRKSRC= ${WRKSRC}/build
BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
diff --git a/security/ca_root_nss/Makefile b/security/ca_root_nss/Makefile
index e105bb8b203d..27fef7422b95 100644
--- a/security/ca_root_nss/Makefile
+++ b/security/ca_root_nss/Makefile
@@ -14,7 +14,8 @@ COMMENT= The root certificate bundle from the Mozilla Project
OPTIONS_DEFINE= ETCSYMLINK
ETCSYMLINK_DESC= Add symlink to /etc/ssl/cert.pem
-USE_PERL5_BUILD= yes
+USES= perl5
+USE_PERL5= build
NO_WRKSUBDIR= yes
CERTDIR?= share/certs
diff --git a/security/ccrypt/Makefile b/security/ccrypt/Makefile
index cd5e04921ffc..a6ab9d4b49f3 100644
--- a/security/ccrypt/Makefile
+++ b/security/ccrypt/Makefile
@@ -10,6 +10,7 @@ MASTER_SITES= SF \
MAINTAINER= dev2@heesakkers.info
COMMENT= Command-line utility for encrypting and decrypting files and streams
+USES= gmake
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
@@ -17,12 +18,12 @@ PLIST_SUB+= NLS=""
USES+= gettext
.else
PLIST_SUB+= NLS="@comment "
-USE_PERL5_BUILD= yes
+USES+= perl5
+USE_PERL5= build
CONFIGURE_ARGS+= --disable-nls
.endif
GNU_CONFIGURE= yes
-USE_GMAKE= yes
MAN1= ccrypt.1 ccguess.1
MLINKS= ccrypt.1 ccencrypt.1 \
diff --git a/security/courier-authlib/Makefile b/security/courier-authlib/Makefile
index 398538eb89c8..e7702a0b1c80 100644
--- a/security/courier-authlib/Makefile
+++ b/security/courier-authlib/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: courier-authlib
-# Date created: 19 Dec 2004
-# Whom: Oliver Lehmann
-#
+# Created by: Oliver Lehmann
# $FreeBSD$
-#
PORTNAME= courier-authlib
PORTVERSION= 0.65.0
@@ -34,12 +30,10 @@ OPTIONS_DEFINE+= GDBM
.else # !defined(PKGNAMESUFFIX)
-USES= iconv
+USES= iconv gmake perl5
USE_AUTOTOOLS= libltdl
USE_BZIP2= yes
-USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_PERL5= yes
USE_SUBMAKE= yes
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
#slave ports should have different UNIQUENAME, it is utilized by USE_LDCONFIG
diff --git a/security/krb5/Makefile b/security/krb5/Makefile
index 13438df4c9c6..aa65130853c1 100644
--- a/security/krb5/Makefile
+++ b/security/krb5/Makefile
@@ -23,12 +23,11 @@ CONFLICTS= heimdal-[0-9]* srp-[0-9]*
LATEST_LINK= ${PORTNAME}-19
KERBEROSV_URL= http://web.mit.edu/kerberos/
-USE_GMAKE= yes
-USE_PERL5_BUILD= yes
+USE_PERL5= build
USE_LDCONFIG= yes
USE_CSTD= gnu99
USE_AUTOTOOLS= libtool
-USES= gettext
+USES= gettext gmake perl5
CONFIGURE_ARGS?= --enable-shared --without-system-verto
CONFIGURE_ENV= INSTALL="${INSTALL}" YACC="${YACC}"
MAKE_ARGS= INSTALL="${INSTALL}"
diff --git a/security/logcheck/Makefile b/security/logcheck/Makefile
index 8ffb6506faea..ad36dbefc9f9 100644
--- a/security/logcheck/Makefile
+++ b/security/logcheck/Makefile
@@ -33,7 +33,7 @@ OPTIONS_DEFAULT=CRON
.endif
# Enable Perl dependency for logtail script
-USE_PERL5= yes
+USES= perl5
WRKSRC= ${WRKDIR}/${DISTNAME:S!_!-!}
BINMODE= 755
diff --git a/security/maia/Makefile b/security/maia/Makefile
index d1442e66202c..a25fb4778ac6 100644
--- a/security/maia/Makefile
+++ b/security/maia/Makefile
@@ -27,7 +27,8 @@ RUN_DEPENDS= p5-Unix-Syslog>=0.94:${PORTSDIR}/sysutils/p5-Unix-Syslog \
# SVN source: https://www.maiamailguard.com/svn/branches/1.0
SVNREVISION= r1575
WRKSRC= ${WRKDIR}/${PORTNAME}-1.0-${SVNREVISION}
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
NO_BUILD= yes
DOCS= LICENSE README maiad.conf.dist maia-mysql.sql maia-pgsql.sql maia.conf.dist
diff --git a/security/makepasswd/Makefile b/security/makepasswd/Makefile
index 925da105e577..026865272d55 100644
--- a/security/makepasswd/Makefile
+++ b/security/makepasswd/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: makepasswd
-# Date created: 7 March 2003
-# Whom: Toni Viemerö <toni.viemero@iki.fi>
-#
+# Created by: Toni Viemerö <toni.viemero@iki.fi>
# $FreeBSD$
-#
PORTNAME= makepasswd
PORTVERSION= 1.10
@@ -23,7 +19,8 @@ COMMENT= Random password generator
LICENSE= GPLv1
NO_BUILD= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
RUN_DEPENDS+= p5-Crypt-PasswdMD5>=0:${PORTSDIR}/security/p5-Crypt-PasswdMD5 \
p5-Crypt-OpenSSL-Random>=0:${PORTSDIR}/security/p5-Crypt-OpenSSL-Random
diff --git a/security/nikto/Makefile b/security/nikto/Makefile
index a4f6587f3a14..207177ed6e79 100644
--- a/security/nikto/Makefile
+++ b/security/nikto/Makefile
@@ -20,7 +20,8 @@ SSLEAY_DESC= Use NET::SSLeay for ssl scanning
NO_BUILD= yes
USE_BZIP2= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
MAN1= nikto.1
diff --git a/security/nss/Makefile b/security/nss/Makefile
index a14556f9202a..fd71e5c5a905 100644
--- a/security/nss/Makefile
+++ b/security/nss/Makefile
@@ -20,8 +20,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/nss
MAKE_JOBS_UNSAFE= yes
USE_LDCONFIG= ${PREFIX}/lib/nss
-USE_GMAKE= yes
-USE_PERL5_BUILD=yes
+USES= gmake perl5
+USE_PERL5= build
MAKE_ENV= LIBRARY_PATH="${LOCALBASE}/lib" \
SQLITE_INCLUDE_DIR="${LOCALBASE}/include" \
NSS_ENABLE_ECC=1 NSS_USE_SYSTEM_SQLITE=1
diff --git a/security/p5-Digest-SHA-PurePerl/Makefile b/security/p5-Digest-SHA-PurePerl/Makefile
index 40a0e25b6721..6b7eb960dadc 100644
--- a/security/p5-Digest-SHA-PurePerl/Makefile
+++ b/security/p5-Digest-SHA-PurePerl/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ashish@FreeBSD.org
COMMENT= Perl extension for SHA-1/224/256/384/512 in pure Perl
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
PORTEXAMPLES= dups
MAN3= Digest::SHA::PurePerl.3
diff --git a/security/rkhunter/Makefile b/security/rkhunter/Makefile
index 0d1a249c5067..796e8493474d 100644
--- a/security/rkhunter/Makefile
+++ b/security/rkhunter/Makefile
@@ -17,7 +17,7 @@ OPTIONS_DEFAULT=LSOF
RUN_DEPENDS+= p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
${LOCALBASE}/bin/wget:${PORTSDIR}/ftp/wget
-USE_PERL5= yes
+USES= perl5
NO_BUILD= yes
SUB_FILES= 415.${PORTNAME}
diff --git a/security/shishi/Makefile b/security/shishi/Makefile
index 2ad322746ba4..5920a6758227 100644
--- a/security/shishi/Makefile
+++ b/security/shishi/Makefile
@@ -15,8 +15,8 @@ LIB_DEPENDS= idn:${PORTSDIR}/dns/libidn \
gnutls:${PORTSDIR}/security/gnutls
USE_AUTOTOOLS= libtool
-USE_PERL5_BUILD= yes
-USES= pathfix pkgconfig iconv
+USE_PERL5= build
+USES= pathfix pkgconfig iconv perl5
GNU_CONFIGURE= yes
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
CONFIGURE_ARGS= --with-db-dir=/var/shishi
diff --git a/x11-wm/windowmaker/Makefile b/x11-wm/windowmaker/Makefile
index 61046fa2575e..870fe3394c98 100644
--- a/x11-wm/windowmaker/Makefile
+++ b/x11-wm/windowmaker/Makefile
@@ -21,10 +21,9 @@ LIB_DEPENDS= gif:${PORTSDIR}/graphics/giflib \
wraster:${PORTSDIR}/x11-wm/libwraster
RUN_DEPENDS= ${LOCALBASE}/share/WindowMaker/Themes/LeetWM.themed/style:${PORTSDIR}/graphics/wmicons
-USES= pathfix pkgconfig
+USES= pathfix perl5 pkgconfig
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
-USE_PERL5= yes
USE_XORG= xft xinerama xmu xpm
CONFIGURE_ARGS= --with-pixmapdir=${PREFIX}/include/X11/pixmaps \
--with-nlsdir=${PREFIX}/share/locale \
diff --git a/x11-wm/xfce4-panel/Makefile b/x11-wm/xfce4-panel/Makefile
index 27d28846f28c..c7ba57628ea6 100644
--- a/x11-wm/xfce4-panel/Makefile
+++ b/x11-wm/xfce4-panel/Makefile
@@ -15,14 +15,12 @@ LIB_DEPENDS= wnck-1:${PORTSDIR}/x11-toolkits/libwnck \
cairo:${PORTSDIR}/graphics/cairo \
dbus-glib-1:${PORTSDIR}/devel/dbus-glib
-USES= desktop-file-utils pathfix pkgconfig
+USES= desktop-file-utils gmake pathfix perl5 pkgconfig
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_BZIP2= yes
-USE_GMAKE= yes
USE_GNOME= glib20 gtk20 intltool intlhack
USE_LDCONFIG= yes
-USE_PERL5= yes
USE_XFCE= configenv garcon libexo libmenu libutil xfconf
USE_XORG= x11 sm