aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-09-24 19:11:35 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-09-24 19:11:35 +0000
commitf67a16a964e9b5fd1b27b4c4e926c1b4de442b8e (patch)
tree7d20f5ee81160e4175af3857b005c7fc6ebd9623
parent4addbbcf2a7f1a1d3b146ae9a246817f2582903c (diff)
downloadports-f67a16a964e9b5fd1b27b4c4e926c1b4de442b8e.tar.gz
ports-f67a16a964e9b5fd1b27b4c4e926c1b4de442b8e.zip
Notes
-rw-r--r--games/Makefile1
-rw-r--r--games/qwdtools/Makefile30
-rw-r--r--games/qwdtools/distinfo1
-rw-r--r--games/qwdtools/files/patch-Makefile14
-rw-r--r--games/qwdtools/pkg-descr7
-rw-r--r--games/qwdtools/pkg-plist5
6 files changed, 58 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index c914d16fc1f2..671385529464 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -303,6 +303,7 @@
SUBDIR += quakeforge
SUBDIR += quakeserver
SUBDIR += quit
+ SUBDIR += qwdtools
SUBDIR += race
SUBDIR += rfksay
SUBDIR += robocode
diff --git a/games/qwdtools/Makefile b/games/qwdtools/Makefile
new file mode 100644
index 000000000000..bf6df34242f0
--- /dev/null
+++ b/games/qwdtools/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: QWDtools
+# Date created: 24 Sen 2003
+# Whom: Alexey Dokuchaev <danfe@regency.nsu.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qwdtools
+PORTVERSION= 0.02
+CATEGORIES= games converters
+MASTER_SITES= http://www.helsinki.fi/~sandvik/qwdlinux/ \
+ http://freebsd.nsu.ru/distfiles/
+DISTNAME= ${PORTNAME}-unix-source-${PORTVERSION}
+
+MAINTAINER= danfe@regency.nsu.ru
+COMMENT= Converts QuakeWorld demos from QWD format to MVD format
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-unix
+ALL_TARGET= ${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+. for file in INSTALL README NEWS
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/qwdtools/distinfo b/games/qwdtools/distinfo
new file mode 100644
index 000000000000..9ed627a6b914
--- /dev/null
+++ b/games/qwdtools/distinfo
@@ -0,0 +1 @@
+MD5 (qwdtools-unix-source-0.02.tar.gz) = c38678c68db9f745c86018c816ada4fd
diff --git a/games/qwdtools/files/patch-Makefile b/games/qwdtools/files/patch-Makefile
new file mode 100644
index 000000000000..9aa7d4b12b68
--- /dev/null
+++ b/games/qwdtools/files/patch-Makefile
@@ -0,0 +1,14 @@
+--- Makefile.orig Wed Sep 24 12:29:55 2003
++++ Makefile Wed Sep 24 12:30:19 2003
+@@ -1,9 +1,9 @@
+ #Put the C compiler (eg gcc) you used after =
+-CC=gcc
++CC?=gcc
+
+ #put the options (eg -Wall) after =
+ # CFLAGS=-Wall -ansi -pedantic -g
+-CFLAGS=-Wall -ansi -pedantic
++#CFLAGS=-Wall -ansi -pedantic
+
+ #put .c program files (eg main.c, trunk.c) after=
+ SRC=dem_parse.c dem_send.c ini.c init.c main.c qwz.c tools.c
diff --git a/games/qwdtools/pkg-descr b/games/qwdtools/pkg-descr
new file mode 100644
index 000000000000..55ffd39782cd
--- /dev/null
+++ b/games/qwdtools/pkg-descr
@@ -0,0 +1,7 @@
+QWDtools is a powerful utility to convert regular uncompressed
+QuakeWorld demo files (in QWD format) to new-era multi-view format.
+
+No QWZ format support yet, but one can always convert them to QWD
+manually with Qizmo and run them through QWDtools after that.
+
+WWW: http://www.helsinki.fi/~sandvik/qwdlinux/
diff --git a/games/qwdtools/pkg-plist b/games/qwdtools/pkg-plist
new file mode 100644
index 000000000000..348ceb9819a2
--- /dev/null
+++ b/games/qwdtools/pkg-plist
@@ -0,0 +1,5 @@
+bin/qwdtools
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%@dirrm %%DOCSDIR%%