aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2009-09-10 09:09:03 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2009-09-10 09:09:03 +0000
commitf8f6e71cf29ec118c12a19e0df5fdafdbbf15722 (patch)
tree5e3e2fa16c5d6ede5cdd8b8e6e6413a9cb86529f
parentf635266299cbd549009a4da6ac10bae99c176789 (diff)
downloadports-f8f6e71cf29ec118c12a19e0df5fdafdbbf15722.tar.gz
ports-f8f6e71cf29ec118c12a19e0df5fdafdbbf15722.zip
Notes
-rw-r--r--net-p2p/eiskaltdc/Makefile27
-rw-r--r--net-p2p/eiskaltdc/distinfo3
-rw-r--r--net-p2p/eiskaltdc/files/patch-dcfilebrowser.cpp11
-rw-r--r--net-p2p/eiskaltdc/files/patch-dcinotify.cpp205
-rw-r--r--net-p2p/eiskaltdc/files/patch-eiskaltdc__docs__en__Makefile.in11
-rw-r--r--net-p2p/eiskaltdc/pkg-descr6
-rw-r--r--net-p2p/eiskaltdc/pkg-plist196
7 files changed, 459 insertions, 0 deletions
diff --git a/net-p2p/eiskaltdc/Makefile b/net-p2p/eiskaltdc/Makefile
new file mode 100644
index 000000000000..bb4c14088ea7
--- /dev/null
+++ b/net-p2p/eiskaltdc/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: net-p2p/eiskaltdc
+# Date created: 28 Aug 2009
+# Whom: Stas Timokhin <stast@bsdportal.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= eiskaltdc
+PORTVERSION= 1.0.0
+CATEGORIES= net-p2p
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
+
+MAINTAINER= stast@bsdportal.ru
+COMMENT= A Direct Connect client QT GUI
+
+LIB_DEPENDS= dc.5:${PORTSDIR}/net-p2p/dclib
+
+USE_BZIP2= yes
+USE_QT_VER= 4
+QT_COMPONENTS= corelib gui network qt3support \
+ moc_build uic_build rcc_build linguist_build
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= DCLIB_CFLAGS=-I${LOCALBASE}/include
+QTCFGLIBS+= ${PTHREAD_LIBS}
+
+.include <bsd.port.mk>
diff --git a/net-p2p/eiskaltdc/distinfo b/net-p2p/eiskaltdc/distinfo
new file mode 100644
index 000000000000..b96aabd77a0f
--- /dev/null
+++ b/net-p2p/eiskaltdc/distinfo
@@ -0,0 +1,3 @@
+MD5 (eiskaltdc-1.0.0.tar.bz2) = 475a5cd65d0c140689f674d153058fe9
+SHA256 (eiskaltdc-1.0.0.tar.bz2) = dc8d264832a14eb76140ca5626dd5eadbae74542b8ec5f68a1b149f773e60ec9
+SIZE (eiskaltdc-1.0.0.tar.bz2) = 1931695
diff --git a/net-p2p/eiskaltdc/files/patch-dcfilebrowser.cpp b/net-p2p/eiskaltdc/files/patch-dcfilebrowser.cpp
new file mode 100644
index 000000000000..a21381f1ead4
--- /dev/null
+++ b/net-p2p/eiskaltdc/files/patch-dcfilebrowser.cpp
@@ -0,0 +1,11 @@
+--- eiskaltdc/dcfilebrowser.cpp.orig 2009-08-28 10:26:38.000000000 +0700
++++ eiskaltdc/dcfilebrowser.cpp 2009-08-28 10:26:57.000000000 +0700
+@@ -37,7 +37,7 @@
+
+ #include <set>
+
+-#include <malloc.h>
++#include <stdlib.h>
+
+ #include "dcmenuhandler.h"
+ #include "dcconfig.h"
diff --git a/net-p2p/eiskaltdc/files/patch-dcinotify.cpp b/net-p2p/eiskaltdc/files/patch-dcinotify.cpp
new file mode 100644
index 000000000000..0995919dbd68
--- /dev/null
+++ b/net-p2p/eiskaltdc/files/patch-dcinotify.cpp
@@ -0,0 +1,205 @@
+--- eiskaltdc/dcinotify.cpp.orig 2009-09-01 09:45:17.000000000 +0700
++++ eiskaltdc/dcinotify.cpp 2009-09-01 09:46:21.000000000 +0700
+@@ -2,7 +2,201 @@
+
+ #include "dcinotify.h"
+
+-#include <sys/inotify.h>
++/* inotify_local.h injected directly into dcinotify.cpp
++
++/*
++ * inotify_local.h - wrapping of libc features and kernel defines
++ *
++ * Copyright (C) 2005-2006 Kay Sievers <kay.sievers at vrfy.org>
++ *
++ * This program is free software; you can redistribute it and/or modify it
++ * under the terms of the GNU General Public License as published by the
++ * Free Software Foundation version 2 of the License.
++ *
++ * This program is distributed in the hope that it will be useful, but
++ * WITHOUT ANY WARRANTY; without even the implied warranty of
++ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
++ * General Public License for more details.
++ *
++ * You should have received a copy of the GNU General Public License along
++ * with this program; if not, write to the Free Software Foundation, Inc.,
++ * 675 Mass Ave, Cambridge, MA 02139, USA.
++ *
++ */
++
++#ifndef _INOTIFY_LOCAL_H_
++#define _INOTIFY_LOCAL_H_
++
++#include <string.h>
++#include <unistd.h>
++#include <stdint.h>
++
++/* needed until Inotify! syscalls reach glibc */
++#include <sys/syscall.h>
++#ifndef __NR_inotify_init
++#if defined(__i386__)
++# define __NR_inotify_init 291
++# define __NR_inotify_add_watch 292
++# define __NR_inotify_rm_watch 293
++#elif defined(__x86_64__)
++# define __NR_inotify_init 253
++# define __NR_inotify_add_watch 254
++# define __NR_inotify_rm_watch 255
++#elif defined(__powerpc__) || defined(__powerpc64__)
++# define __NR_inotify_init 275
++# define __NR_inotify_add_watch 276
++# define __NR_inotify_rm_watch 277
++#elif defined (__ia64__)
++# define __NR_inotify_init 1277
++# define __NR_inotify_add_watch 1278
++# define __NR_inotify_rm_watch 1279
++#elif defined (__s390__)
++# define __NR_inotify_init 284
++# define __NR_inotify_add_watch 285
++# define __NR_inotify_rm_watch 286
++#elif defined (__mc68000__)
++# define __NR_inotify_init 284
++# define __NR_inotify_add_watch 285
++# define __NR_inotify_rm_watch 286
++#elif defined (__alpha__)
++# define __NR_inotify_init 444
++# define __NR_inotify_add_watch 445
++# define __NR_inotify_rm_watch 446
++#elif defined (__sparc__) || defined (__sparc64__)
++# define __NR_inotify_init 151
++# define __NR_inotify_add_watch 152
++# define __NR_inotify_rm_watch 156
++#elif defined (__arm__)
++# define __NR_inotify_init __NR_SYSCALL_BASE+316
++# define __NR_inotify_add_watch __NR_SYSCALL_BASE+317
++# define __NR_inotify_rm_watch __NR_SYSCALL_BASE+318
++#elif defined (__sh__)
++# define __NR_inotify_init 290
++# define __NR_inotify_add_watch 291
++# define __NR_inotify_rm_watch 292
++#elif defined (__m32r__)
++# define __NR_inotify_init 290
++# define __NR_inotify_add_watch 291
++# define __NR_inotify_rm_watch 292
++#elif defined (__hppa__)
++# define __NR_inotify_init 269
++# define __NR_inotify_add_watch 270
++# define __NR_inotify_rm_watch 271
++#elif defined (__mips__)
++# include <sgidefs.h>
++# if _MIPS_SIM == _MIPS_SIM_ABI32
++# define __NR_Linux 4000
++# define __NR_inotify_init (__NR_Linux + 284)
++# define __NR_inotify_add_watch (__NR_Linux + 285)
++# define __NR_inotify_rm_watch (__NR_Linux + 286)
++# elif _MIPS_SIM == _MIPS_SIM_ABI64
++# define __NR_Linux 5000
++# define __NR_inotify_init (__NR_Linux + 243)
++# define __NR_inotify_add_watch (__NR_Linux + 244)
++# define __NR_inotify_rm_watch (__NR_Linux + 245)
++# elif _MIPS_SIM == _MIPS_SIM_NABI32
++# define __NR_Linux 6000
++# define __NR_inotify_init (__NR_Linux + 247)
++# define __NR_inotify_add_watch (__NR_Linux + 248)
++# define __NR_inotify_rm_watch (__NR_Linux + 249)
++# endif
++#else
++# warning "inotify unsupported on this architecture!"
++#endif
++#endif /* __NR_inotify_init */
++
++/* dummy if we don't have the syscalls defined */
++#ifndef __NR_inotify_init
++static inline int inotify_init(void)
++{
++ return -1;
++}
++
++static inline int inotify_add_watch(int fd, const char *name, uint32_t mask)
++{
++ return -1;
++}
++
++static inline int inotify_rm_watch(int fd, uint32_t wd)
++{
++ return -1;
++}
++#else
++static inline int inotify_init(void)
++{
++ return syscall(__NR_inotify_init);
++}
++
++static inline int inotify_add_watch(int fd, const char *name, uint32_t mask)
++{
++ return syscall(__NR_inotify_add_watch, fd, name, mask);
++}
++
++static inline int inotify_rm_watch(int fd, uint32_t wd)
++{
++ return syscall(__NR_inotify_rm_watch, fd, wd);
++}
++#endif /* __NR_inotify_init */
++
++#ifndef IN_CREATE
++#define IN_CREATE 0x00000100 /* Subfile was created */
++#define IN_MOVED_FROM 0x00000040 /* File was moved from X */
++#define IN_MOVED_TO 0x00000080 /* File was moved to Y */
++#define IN_DELETE 0x00000200 /* Subfile was deleted */
++#define IN_CLOSE_WRITE 0x00000008 /* Writtable file was closed */
++#define IN_MOVE (IN_MOVED_FROM | IN_MOVED_TO) /* moves */
++#endif /* IN_CREATE */
++
++struct inotify_event {
++ int wd;
++ uint32_t mask;
++ uint32_t cookie;
++ uint32_t len;
++ char *name;
++};
++
++/* the following are legal, implemented events that user-space can watch for */
++#define IN_ACCESS 0x00000001 /* File was accessed */
++#define IN_MODIFY 0x00000002 /* File was modified */
++#define IN_ATTRIB 0x00000004 /* Metadata changed */
++#define IN_CLOSE_WRITE 0x00000008 /* Writtable file was closed */
++#define IN_CLOSE_NOWRITE 0x00000010 /* Unwrittable file closed */
++#define IN_OPEN 0x00000020 /* File was opened */
++#define IN_MOVED_FROM 0x00000040 /* File was moved from X */
++#define IN_MOVED_TO 0x00000080 /* File was moved to Y */
++#define IN_CREATE 0x00000100 /* Subfile was created */
++#define IN_DELETE 0x00000200 /* Subfile was deleted */
++#define IN_DELETE_SELF 0x00000400 /* Self was deleted */
++#define IN_MOVE_SELF 0x00000800 /* Self was moved */
++
++/* the following are legal events. they are sent as needed to any watch */
++#define IN_UNMOUNT 0x00002000 /* Backing fs was unmounted */
++#define IN_Q_OVERFLOW 0x00004000 /* Event queued overflowed */
++#define IN_IGNORED 0x00008000 /* File was ignored */
++
++/* helper events */
++#define IN_CLOSE (IN_CLOSE_WRITE | IN_CLOSE_NOWRITE) /* close */
++#define IN_MOVE (IN_MOVED_FROM | IN_MOVED_TO) /* moves */
++
++/* special flags */
++#define IN_ONLYDIR 0x01000000 /* only watch the path if it is a directory */
++#define IN_DONT_FOLLOW 0x02000000 /* don't follow a sym link */
++#define IN_MASK_ADD 0x20000000 /* add to the mask of an already existing watch */
++#define IN_ISDIR 0x40000000 /* event occurred against dir */
++#define IN_ONESHOT 0x80000000 /* only send event once */
++
++/*
++ * All of the events - we build the list by hand so that we can add flags in
++ * the future and not break backward compatibility. Apps will get only the
++ * events that they originally wanted. Be sure to add new events here!
++ */
++#define IN_ALL_EVENTS (IN_ACCESS | IN_MODIFY | IN_ATTRIB | IN_CLOSE_WRITE | \
++ IN_CLOSE_NOWRITE | IN_OPEN | IN_MOVED_FROM | \
++ IN_MOVED_TO | IN_DELETE | IN_CREATE | IN_DELETE_SELF | \
++ IN_MOVE_SELF)
++
++#endif /* _INOTIFY_LOCAL_H_ */
++
+ #include <sys/ioctl.h>
+ #include <sys/types.h>
+ #include <sys/select.h>
diff --git a/net-p2p/eiskaltdc/files/patch-eiskaltdc__docs__en__Makefile.in b/net-p2p/eiskaltdc/files/patch-eiskaltdc__docs__en__Makefile.in
new file mode 100644
index 000000000000..cce77f34fafe
--- /dev/null
+++ b/net-p2p/eiskaltdc/files/patch-eiskaltdc__docs__en__Makefile.in
@@ -0,0 +1,11 @@
+--- ./eiskaltdc/docs/en/Makefile.in.orig 2009-08-25 22:23:16.000000000 +0400
++++ ./eiskaltdc/docs/en/Makefile.in 2009-09-09 21:46:47.000000000 +0400
+@@ -371,8 +371,6 @@
+ uninstall uninstall-am
+
+ install-data-local:
+- $(mkinstalldirs) $(DESTDIR)$(mandir)/man1/
+- $(INSTALL_DATA) $(srcdir)/valknut.1 $(DESTDIR)$(mandir)/man1/
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/net-p2p/eiskaltdc/pkg-descr b/net-p2p/eiskaltdc/pkg-descr
new file mode 100644
index 000000000000..48839eaab143
--- /dev/null
+++ b/net-p2p/eiskaltdc/pkg-descr
@@ -0,0 +1,6 @@
+EiskaltDC++ is a fork of Valknut client for the Direct Connect
+network. It is compatible with other DC clients, such as the original
+DC from Neomodus, DC++ and derivatives. EiskaltDC++ also interoperates
+with all common DC hub software.
+
+WWW: http://eiskaltdc.sourceforge.net
diff --git a/net-p2p/eiskaltdc/pkg-plist b/net-p2p/eiskaltdc/pkg-plist
new file mode 100644
index 000000000000..9106f849c35d
--- /dev/null
+++ b/net-p2p/eiskaltdc/pkg-plist
@@ -0,0 +1,196 @@
+bin/eiskaltdc
+share/applications/eiskaltdc.desktop
+%%DATADIR%%/COPYING
+%%DATADIR%%/icons/appl/default/back.png
+%%DATADIR%%/icons/appl/default/ball_green.png
+%%DATADIR%%/icons/appl/default/ball_red.png
+%%DATADIR%%/icons/appl/default/ball_yellow.png
+%%DATADIR%%/icons/appl/default/bookmark_add.png
+%%DATADIR%%/icons/appl/default/bookmark_folder.png
+%%DATADIR%%/icons/appl/default/chat.png
+%%DATADIR%%/icons/appl/default/choose-language.png
+%%DATADIR%%/icons/appl/default/clear.png
+%%DATADIR%%/icons/appl/default/client.png
+%%DATADIR%%/icons/appl/default/colors.png
+%%DATADIR%%/icons/appl/default/configure.png
+%%DATADIR%%/icons/appl/default/configure_22x22.png
+%%DATADIR%%/icons/appl/default/configure_32x32.png
+%%DATADIR%%/icons/appl/default/connect.png
+%%DATADIR%%/icons/appl/default/connect_creating.png
+%%DATADIR%%/icons/appl/default/connect_no.png
+%%DATADIR%%/icons/appl/default/connected.png
+%%DATADIR%%/icons/appl/default/debug.png
+%%DATADIR%%/icons/appl/default/down.png
+%%DATADIR%%/icons/appl/default/download.png
+%%DATADIR%%/icons/appl/default/download_as.png
+%%DATADIR%%/icons/appl/default/edit.png
+%%DATADIR%%/icons/appl/default/editadd.png
+%%DATADIR%%/icons/appl/default/editcopy.png
+%%DATADIR%%/icons/appl/default/editdelete.png
+%%DATADIR%%/icons/appl/default/emoticon.png
+%%DATADIR%%/icons/appl/default/exit.png
+%%DATADIR%%/icons/appl/default/fileclose.png
+%%DATADIR%%/icons/appl/default/filefind.png
+%%DATADIR%%/icons/appl/default/filetype-application.png
+%%DATADIR%%/icons/appl/default/filetype-archive.png
+%%DATADIR%%/icons/appl/default/filetype-audio.png
+%%DATADIR%%/icons/appl/default/filetype-document.png
+%%DATADIR%%/icons/appl/default/filetype-picture.png
+%%DATADIR%%/icons/appl/default/filetype-unknown.png
+%%DATADIR%%/icons/appl/default/filetype-video.png
+%%DATADIR%%/icons/appl/default/filter.png
+%%DATADIR%%/icons/appl/default/find.png
+%%DATADIR%%/icons/appl/default/find_22x22.png
+%%DATADIR%%/icons/appl/default/find_32x32.png
+%%DATADIR%%/icons/appl/default/flag_bosnia.png
+%%DATADIR%%/icons/appl/default/flag_brazil.png
+%%DATADIR%%/icons/appl/default/flag_britain.png
+%%DATADIR%%/icons/appl/default/flag_czech.png
+%%DATADIR%%/icons/appl/default/flag_denmark.png
+%%DATADIR%%/icons/appl/default/flag_finland.png
+%%DATADIR%%/icons/appl/default/flag_france.png
+%%DATADIR%%/icons/appl/default/flag_germany.png
+%%DATADIR%%/icons/appl/default/flag_greece.png
+%%DATADIR%%/icons/appl/default/flag_hungary.png
+%%DATADIR%%/icons/appl/default/flag_iceland.png
+%%DATADIR%%/icons/appl/default/flag_italy.png
+%%DATADIR%%/icons/appl/default/flag_latvia.png
+%%DATADIR%%/icons/appl/default/flag_netherlands.png
+%%DATADIR%%/icons/appl/default/flag_norway.png
+%%DATADIR%%/icons/appl/default/flag_poland.png
+%%DATADIR%%/icons/appl/default/flag_romania.png
+%%DATADIR%%/icons/appl/default/flag_russia.png
+%%DATADIR%%/icons/appl/default/flag_serbia.png
+%%DATADIR%%/icons/appl/default/flag_slovakia.png
+%%DATADIR%%/icons/appl/default/flag_spain.png
+%%DATADIR%%/icons/appl/default/flag_sweden.png
+%%DATADIR%%/icons/appl/default/folder_blue.png
+%%DATADIR%%/icons/appl/default/folder_blue_open.png
+%%DATADIR%%/icons/appl/default/folder_red.png
+%%DATADIR%%/icons/appl/default/globe.png
+%%DATADIR%%/icons/appl/default/gui.png
+%%DATADIR%%/icons/appl/default/help.png
+%%DATADIR%%/icons/appl/default/icon_22x22.png
+%%DATADIR%%/icons/appl/default/icons.png
+%%DATADIR%%/icons/appl/default/info.png
+%%DATADIR%%/icons/appl/default/inotify.png
+%%DATADIR%%/icons/appl/default/isaway.png
+%%DATADIR%%/icons/appl/default/log.png
+%%DATADIR%%/icons/appl/default/menu.png
+%%DATADIR%%/icons/appl/default/message.png
+%%DATADIR%%/icons/appl/default/next.png
+%%DATADIR%%/icons/appl/default/notconnected.png
+%%DATADIR%%/icons/appl/default/onlinemanual.png
+%%DATADIR%%/icons/appl/default/open.png
+%%DATADIR%%/icons/appl/default/other.png
+%%DATADIR%%/icons/appl/default/player_pause.png
+%%DATADIR%%/icons/appl/default/player_play.png
+%%DATADIR%%/icons/appl/default/quickoptions.png
+%%DATADIR%%/icons/appl/default/reload.png
+%%DATADIR%%/icons/appl/default/reload_22x22.png
+%%DATADIR%%/icons/appl/default/reload_32x32.png
+%%DATADIR%%/icons/appl/default/reload_plugins.png
+%%DATADIR%%/icons/appl/default/save.png
+%%DATADIR%%/icons/appl/default/server.png
+%%DATADIR%%/icons/appl/default/sort-down-arrow.png
+%%DATADIR%%/icons/appl/default/spam.png
+%%DATADIR%%/icons/appl/default/splash.png
+%%DATADIR%%/icons/appl/default/spy.png
+%%DATADIR%%/icons/appl/default/ssl_no.png
+%%DATADIR%%/icons/appl/default/ssl_yes.png
+%%DATADIR%%/icons/appl/default/support.png
+%%DATADIR%%/icons/appl/default/text-select-all.png
+%%DATADIR%%/icons/appl/default/transfer.png
+%%DATADIR%%/icons/appl/default/translate.png
+%%DATADIR%%/icons/appl/default/up.png
+%%DATADIR%%/icons/appl/default/update.png
+%%DATADIR%%/icons/appl/default/users.png
+%%DATADIR%%/icons/appl/default/users_22x22.png
+%%DATADIR%%/icons/appl/default/users_32x32.png
+%%DATADIR%%/icons/appl/default/view_sidetree.png
+%%DATADIR%%/icons/appl/default/vru.png
+%%DATADIR%%/icons/appl/default/windows_cl_all.png
+%%DATADIR%%/icons/appl/default/windows_cl_find.png
+%%DATADIR%%/icons/appl/default/windows_cl_hubs.png
+%%DATADIR%%/icons/appl/default/windows_cl_lists.png
+%%DATADIR%%/icons/appl/default/windows_cl_offline.png
+%%DATADIR%%/icons/appl/default/windows_horiz.png
+%%DATADIR%%/icons/appl/default/windows_icon.png
+%%DATADIR%%/icons/appl/default/windows_lists.png
+%%DATADIR%%/icons/appl/default/windows_tiled.png
+%%DATADIR%%/icons/appl/default/windows_undock.png
+%%DATADIR%%/icons/appl/default/windows_vert.png
+%%DATADIR%%/icons/appl/default/zoom-in.png
+%%DATADIR%%/icons/appl/default/zoom-out.png
+%%DATADIR%%/icons/emot/default/default.png
+%%DATADIR%%/icons/emot/default/emoticons-v2.xml
+%%DATADIR%%/icons/emot/flylink/emoticons-v2.xml
+%%DATADIR%%/icons/emot/flylink/flylink.png
+%%DATADIR%%/icons/emot/kolobok/emoticons-v2.xml
+%%DATADIR%%/icons/emot/kolobok/kolobok.png
+%%DATADIR%%/icons/emot/simple-gnome/emoticons-v2.xml
+%%DATADIR%%/icons/emot/simple-gnome/simple-gnome.png
+%%DATADIR%%/icons/user/default/usericons.png
+%%DATADIR%%/icons/user/valknut/usericons.png
+%%DATADIR%%/translation/eiskaltdc.bs.qm
+%%DATADIR%%/translation/eiskaltdc.cs.qm
+%%DATADIR%%/translation/eiskaltdc.da.qm
+%%DATADIR%%/translation/eiskaltdc.de.qm
+%%DATADIR%%/translation/eiskaltdc.el.qm
+%%DATADIR%%/translation/eiskaltdc.en.qm
+%%DATADIR%%/translation/eiskaltdc.es.qm
+%%DATADIR%%/translation/eiskaltdc.fi.qm
+%%DATADIR%%/translation/eiskaltdc.fr.qm
+%%DATADIR%%/translation/eiskaltdc.hu.qm
+%%DATADIR%%/translation/eiskaltdc.is.qm
+%%DATADIR%%/translation/eiskaltdc.it.qm
+%%DATADIR%%/translation/eiskaltdc.lv.qm
+%%DATADIR%%/translation/eiskaltdc.nb.qm
+%%DATADIR%%/translation/eiskaltdc.nl.qm
+%%DATADIR%%/translation/eiskaltdc.pl.qm
+%%DATADIR%%/translation/eiskaltdc.pt_br.qm
+%%DATADIR%%/translation/eiskaltdc.ro.qm
+%%DATADIR%%/translation/eiskaltdc.ru.qm
+%%DATADIR%%/translation/eiskaltdc.sr.qm
+%%DATADIR%%/translation/eiskaltdc.sr@latin.qm
+%%DATADIR%%/translation/eiskaltdc.sv.qm
+share/icons/hicolor/128x128/apps/eiskaltdc.png
+share/icons/hicolor/16x16/apps/eiskaltdc.png
+share/icons/hicolor/22x22/apps/eiskaltdc.png
+share/icons/hicolor/24x24/apps/eiskaltdc.png
+share/icons/hicolor/32x32/apps/eiskaltdc.png
+share/icons/hicolor/48x48/apps/eiskaltdc.png
+share/icons/hicolor/64x64/apps/eiskaltdc.png
+share/pixmaps/eiskaltdc.png
+@dirrmtry share/icons/hicolor/64x64/apps
+@dirrmtry share/icons/hicolor/64x64
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor/24x24/apps
+@dirrmtry share/icons/hicolor/24x24
+@dirrmtry share/icons/hicolor/22x22/apps
+@dirrmtry share/icons/hicolor/22x22
+@dirrmtry share/icons/hicolor/16x16/apps
+@dirrmtry share/icons/hicolor/16x16
+@dirrmtry share/icons/hicolor/128x128/apps
+@dirrmtry share/icons/hicolor/128x128
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrmtry share/applications
+@dirrm %%DATADIR%%/translation
+@dirrm %%DATADIR%%/sounds/default
+@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%/icons/user/valknut
+@dirrm %%DATADIR%%/icons/user/default
+@dirrm %%DATADIR%%/icons/user
+@dirrm %%DATADIR%%/icons/emot/simple-gnome
+@dirrm %%DATADIR%%/icons/emot/kolobok
+@dirrm %%DATADIR%%/icons/emot/flylink
+@dirrm %%DATADIR%%/icons/emot/default
+@dirrm %%DATADIR%%/icons/emot
+@dirrm %%DATADIR%%/icons/appl/default
+@dirrm %%DATADIR%%/icons/appl
+@dirrm %%DATADIR%%/icons
+@dirrm %%DATADIR%%