aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-07-27 13:18:41 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-07-27 13:18:41 +0000
commitffaa1bfe8a9a5c076f0cf6e5c434d0a5285aae2d (patch)
tree73ba22119f9d193d7b1289b87dd11cbbd4f12105
parentc13b98c55f0a47c490318324b4659416bb0d8dd5 (diff)
downloadports-ffaa1bfe8a9a5c076f0cf6e5c434d0a5285aae2d.tar.gz
ports-ffaa1bfe8a9a5c076f0cf6e5c434d0a5285aae2d.zip
Notes
-rw-r--r--palm/synce-libsynce/Makefile38
-rw-r--r--palm/synce-libsynce/distinfo6
-rw-r--r--palm/synce-libsynce/files/patch-Makefile.in11
-rw-r--r--palm/synce-libsynce/pkg-plist5
4 files changed, 35 insertions, 25 deletions
diff --git a/palm/synce-libsynce/Makefile b/palm/synce-libsynce/Makefile
index 0e6b69eedb67..60f97f679b9d 100644
--- a/palm/synce-libsynce/Makefile
+++ b/palm/synce-libsynce/Makefile
@@ -4,22 +4,42 @@
#
# $FreeBSD$
-PORTNAME= synce-libsynce
-PORTVERSION= 0.9.3
+PORTNAME= libsynce
+PORTVERSION= 0.12
CATEGORIES= palm
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= synce
+MASTER_SITES= SF/synce
+PKGNAMEPREFIX= synce-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= webmaster@kibab.com
COMMENT= Library to support communication with WinCE devices
-MAN1= synce.1
+LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
+ hal.1:${PORTSDIR}/sysutils/hal
-USE_ICONV= yes
GNU_CONFIGURE= yes
-WRKSRC= ${WRKDIR}/libsynce-${PORTVERSION}
+USE_AUTOTOOLS= libtool:15
+USE_ICONV= yes
+USE_GNOME= gnomehack gnometarget
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS+= --with-libiconv-prefix=${LOCALBASE}
+CONFIGURE_ARGS+= --with-libiconv-prefix="${LOCALBASE}" \
+ --enable-dccm-file-support=no \
+ --enable-hal-support=yes \
+ --enable-odccm-support=no
+
+MAN3= synce_info_new.3 wstrlen.3 wstrcpy.3 wstrdup.3 \
+ synce_get_directory.3 synce_get_connection_filename.3 \
+ synce_strerror.3 wstr_to_ascii.3 time_fields_from_filetime.3 \
+ date_from_tm.3 synce_error.3 synce_info_destroy.3 \
+ synce_get_subdirectory.3 synce_get_script_directory.3 \
+ synce_set_connection_filename.3 wstr_to_current.3 \
+ synce_set_default_connection_filename.3 wstr_to_utf8.3 \
+ wstr_from_ascii.3 wstr_from_utf8.3 wstr_from_current.3 \
+ wstr_free_string.3 wstr_append.3 wstr_equal.3 \
+ time_fields_to_filetime.3 date_to_tm.3 synce_warning.3 \
+ synce_info.3 synce_debug.3 synce_trace.3 \
+ synce_warning_unless.3 synce_log_set_level.3 \
+ synce_log_use_syslog.3
+MAN7= synce.7
USE_LDCONFIG= yes
diff --git a/palm/synce-libsynce/distinfo b/palm/synce-libsynce/distinfo
index 1d1e7d91e76e..2ed1e66c6fb8 100644
--- a/palm/synce-libsynce/distinfo
+++ b/palm/synce-libsynce/distinfo
@@ -1,3 +1,3 @@
-MD5 (synce-libsynce-0.9.3.tar.gz) = 9b793d1ef241fa7fca6ca7832b3b4811
-SHA256 (synce-libsynce-0.9.3.tar.gz) = eebaf90c4de0992f94a7d665e656d75f34831868e377acb3f57264c1eb63ed8c
-SIZE (synce-libsynce-0.9.3.tar.gz) = 368963
+MD5 (libsynce-0.12.tar.gz) = fd473d3deceda7912af4427dede1736f
+SHA256 (libsynce-0.12.tar.gz) = 8c8890a3b85343bb5a1ea904bf26012a1339569ff037c2a38c23b6f9e77149b3
+SIZE (libsynce-0.12.tar.gz) = 409685
diff --git a/palm/synce-libsynce/files/patch-Makefile.in b/palm/synce-libsynce/files/patch-Makefile.in
deleted file mode 100644
index 53e194f2aa91..000000000000
--- a/palm/synce-libsynce/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in Fri Jan 26 01:31:36 2007
-+++ Makefile.in Fri Jan 26 01:31:25 2007
-@@ -200,7 +200,7 @@
- target_vendor = @target_vendor@
- AUTOMAKE_OPTIONS = foreign 1.4
- pcfiles = libsynce.pc
--pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfigdir = $(prefix)/libdata/pkgconfig
- pkgconfig_DATA = $(pcfiles)
- EXTRA_DIST = libsynce.pc.in
- CLEANFILES = $(pcfiles)
diff --git a/palm/synce-libsynce/pkg-plist b/palm/synce-libsynce/pkg-plist
index 0ecc95389f2d..f9d65d8f1bda 100644
--- a/palm/synce-libsynce/pkg-plist
+++ b/palm/synce-libsynce/pkg-plist
@@ -5,8 +5,9 @@ include/synce_log.h
include/synce_socket.h
include/synce_types.h
include/synce_vector_template.h
-lib/libsynce.a
-lib/libsynce.la
+include/synce_sys_error.h
lib/libsynce.so
+lib/libsynce.la
+lib/libsynce.a
lib/libsynce.so.0
libdata/pkgconfig/libsynce.pc