aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2020-12-24 09:03:39 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2020-12-24 09:03:39 +0000
commit14be7bd191de0d71e48770d90738e82928fad6aa (patch)
tree55c9720bb839ecfb49fdc99ca948c3d8041f2dcd
parent8ca43586e1b57397f3b522748b91497f7c61df19 (diff)
downloadports-14be7bd191de0d71e48770d90738e82928fad6aa.tar.gz
ports-14be7bd191de0d71e48770d90738e82928fad6aa.zip
Notes
-rw-r--r--benchmarks/py-naarad/Makefile2
-rw-r--r--benchmarks/py-zopkio/Makefile2
-rw-r--r--biology/checkm/Makefile2
-rw-r--r--biology/groopm/Makefile2
-rw-r--r--comms/apitran/Makefile2
-rw-r--r--devel/cpp2py/Makefile2
-rw-r--r--math/py-CyLP/Makefile2
-rw-r--r--math/py-apgl/Makefile2
-rw-r--r--math/py-chaospy/Makefile2
-rw-r--r--math/py-cvxpy/Makefile2
-rw-r--r--math/py-cyipopt/Makefile2
-rw-r--r--math/py-ecos/Makefile2
-rw-r--r--math/py-fastcluster/Makefile2
-rw-r--r--math/py-keras/Makefile2
-rw-r--r--math/py-luminol/Makefile2
-rw-r--r--math/py-osqp/Makefile2
-rw-r--r--math/py-scikit-umfpack/Makefile2
-rw-r--r--math/py-scs/Makefile2
-rw-r--r--math/py-statsmodels010/Makefile2
-rw-r--r--math/py-theano/Makefile2
-rw-r--r--misc/py-eemeter/Makefile2
-rw-r--r--misc/py-scikit-fusion/Makefile2
-rw-r--r--ports-mgmt/porttree/Makefile2
-rw-r--r--science/dvc/Makefile2
-rw-r--r--science/py-GPy/Makefile2
-rw-r--r--science/py-GPyOpt/Makefile2
-rw-r--r--science/py-paramz/Makefile2
-rw-r--r--science/py-pysal/Makefile2
-rw-r--r--science/py-qspin/Makefile2
-rw-r--r--science/py-rmsd/Makefile2
-rw-r--r--science/py-scikit-sparse/Makefile2
-rw-r--r--science/py-scipy/Makefile2
-rw-r--r--science/py-scoria/Makefile2
-rw-r--r--science/pybrain/Makefile2
34 files changed, 34 insertions, 34 deletions
diff --git a/benchmarks/py-naarad/Makefile b/benchmarks/py-naarad/Makefile
index 4691e8d0e358..17e66d1c1409 100644
--- a/benchmarks/py-naarad/Makefile
+++ b/benchmarks/py-naarad/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytz>=2013.8,1:devel/py-pytz@${PY_FLAVOR} \
bash:shells/bash \
gawk:lang/gawk
-USES= shebangfix python
+USES= shebangfix python:3.6+
SHEBANG_LANG= gawk
SHEBANG_FILES= bin/naarad_metric_collector.sh bin/PrintGCStats
diff --git a/benchmarks/py-zopkio/Makefile b/benchmarks/py-zopkio/Makefile
index e7c6ce51b048..7b9d3fbbfe88 100644
--- a/benchmarks/py-zopkio/Makefile
+++ b/benchmarks/py-zopkio/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}naarad>=1.0.15:benchmarks/py-naarad@${PY_FLA
${PYTHON_PKGNAMEPREFIX}paramiko>=1.10.1:security/py-paramiko@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}junit-xml>0:textproc/py-junit-xml@${PY_FLAVOR} \
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
USE_GITHUB= yes
GH_ACCOUNT= linkedin
diff --git a/biology/checkm/Makefile b/biology/checkm/Makefile
index 705846a24d98..fe9ba640c641 100644
--- a/biology/checkm/Makefile
+++ b/biology/checkm/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}pysam>=0.8.3:biology/py-pysam@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scipy>=0.9.0:science/py-scipy@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_GITHUB= yes
GH_ACCOUNT= Ecogenomics
USE_PYTHON= distutils noflavors autoplist
diff --git a/biology/groopm/Makefile b/biology/groopm/Makefile
index 89d1d96deabe..f576b18e1eb3 100644
--- a/biology/groopm/Makefile
+++ b/biology/groopm/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>=0.10.1:science/py-scipy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tables>=2.3:devel/py-tables@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= distutils noflavors autoplist
NO_ARCH= yes
diff --git a/comms/apitran/Makefile b/comms/apitran/Makefile
index e6804e8485a3..4cab62f3bc0b 100644
--- a/comms/apitran/Makefile
+++ b/comms/apitran/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVO
sox:audio/sox \
display:graphics/ImageMagick6
-USES= python:run shebangfix
+USES= python:3.6+,run shebangfix
USE_GITHUB= yes
GH_ACCOUNT= rsj56
GH_PROJECT= apitran
diff --git a/devel/cpp2py/Makefile b/devel/cpp2py/Makefile
index e66d0ec38c35..342cb0eca21f 100644
--- a/devel/cpp2py/Makefile
+++ b/devel/cpp2py/Makefile
@@ -22,7 +22,7 @@ BUILD_DEPENDS= ${PY_DEPENDS} \
RUN_DEPENDS= ${PY_DEPENDS} \
llvm${LLVM_VER}>0:devel/llvm${LLVM_VER}
-USES= cmake compiler:c++14-lang gettext-runtime python shebangfix
+USES= cmake compiler:c++14-lang gettext-runtime python:3.6+ shebangfix
USE_LDCONFIG= yes
USE_GITHUB= yes
diff --git a/math/py-CyLP/Makefile b/math/py-CyLP/Makefile
index e09adbd3c5ab..4ae6c3d97cd1 100644
--- a/math/py-CyLP/Makefile
+++ b/math/py-CyLP/Makefile
@@ -24,7 +24,7 @@ LIB_DEPENDS= libblas.so:math/blas \
liblapack.so:math/lapack
RUN_DEPENDS= ${PY_DEPENDS}
-USES= compiler:c++11-lang python
+USES= compiler:c++11-lang python:3.6+
USE_PYTHON= distutils cython autoplist
USE_GITHUB= yes
diff --git a/math/py-apgl/Makefile b/math/py-apgl/Makefile
index 321bb44ba46f..685429116c28 100644
--- a/math/py-apgl/Makefile
+++ b/math/py-apgl/Makefile
@@ -17,7 +17,7 @@ BUILD_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>0.7.0:science/py-scipy@${PY_FLAVOR}
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/math/py-chaospy/Makefile b/math/py-chaospy/Makefile
index fd85b4ab6654..fe36c49632fb 100644
--- a/math/py-chaospy/Makefile
+++ b/math/py-chaospy/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}numpoly>0:math/py-numpoly@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= distutils autoplist
NO_ARCH= yes
diff --git a/math/py-cvxpy/Makefile b/math/py-cvxpy/Makefile
index e8cf46245776..6a0d7419a70e 100644
--- a/math/py-cvxpy/Makefile
+++ b/math/py-cvxpy/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>=1.1.0:science/py-scipy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scs>=1.1.6:math/py-scs@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= distutils autoplist
post-install:
diff --git a/math/py-cyipopt/Makefile b/math/py-cyipopt/Makefile
index bc1ed20166d4..8de9fd3d71d9 100644
--- a/math/py-cyipopt/Makefile
+++ b/math/py-cyipopt/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
-USES= fortran python pkgconfig # fortran because ipopt's pkg-config returns gcc libs
+USES= fortran python:3.6+ pkgconfig # fortran because ipopt's pkg-config returns gcc libs
USE_GITHUB= yes
GH_ACCOUNT= matthias-k
USE_PYTHON= distutils cython autoplist
diff --git a/math/py-ecos/Makefile b/math/py-ecos/Makefile
index 3ccdefb06dae..54a412af5c52 100644
--- a/math/py-ecos/Makefile
+++ b/math/py-ecos/Makefile
@@ -18,7 +18,7 @@ BUILD_DEPENDS= ${PYNUMPY}
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>=0.9:science/py-scipy@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/math/py-fastcluster/Makefile b/math/py-fastcluster/Makefile
index 30b6e29072ed..6a622584bd09 100644
--- a/math/py-fastcluster/Makefile
+++ b/math/py-fastcluster/Makefile
@@ -17,7 +17,7 @@ BUILD_DEPENDS= ${PYNUMPY}
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>=0:science/py-scipy@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
PORTDOCS= CITATION.txt INSTALL.txt NEWS.txt README.txt
diff --git a/math/py-keras/Makefile b/math/py-keras/Makefile
index c7bbe2dd0aee..102e204730de 100644
--- a/math/py-keras/Makefile
+++ b/math/py-keras/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}theano>=0.8.0:math/py-theano@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/math/py-luminol/Makefile b/math/py-luminol/Makefile
index c50956c01de6..4581a9cafa1c 100644
--- a/math/py-luminol/Makefile
+++ b/math/py-luminol/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}numpy>=1.6.2,1:math/py-numpy@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist distutils
USE_GITHUB= yes
GH_ACCOUNT= linkedin
diff --git a/math/py-osqp/Makefile b/math/py-osqp/Makefile
index c2a84e820848..af4ca2bde14f 100644
--- a/math/py-osqp/Makefile
+++ b/math/py-osqp/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}future>0:devel/py-future@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scipy>=0.13.2:science/py-scipy@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_GITHUB= yes
GH_ACCOUNT= oxfordcontrol
GH_PROJECT= ${PORTNAME}-python
diff --git a/math/py-scikit-umfpack/Makefile b/math/py-scikit-umfpack/Makefile
index 406aa64719c2..65ad137e64f9 100644
--- a/math/py-scikit-umfpack/Makefile
+++ b/math/py-scikit-umfpack/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= libumfpack.so:math/suitesparse
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= distutils cython autoplist
post-extract: # workaround for https://github.com/scikit-umfpack/scikit-umfpack/issues/53
diff --git a/math/py-scs/Makefile b/math/py-scs/Makefile
index 2ddfa3c9ee96..cb9dec51a08d 100644
--- a/math/py-scs/Makefile
+++ b/math/py-scs/Makefile
@@ -15,7 +15,7 @@ BUILD_DEPENDS= ${PYNUMPY}
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>=0.13.2:science/py-scipy@${PY_FLAVOR}
-USES= python blaslapack:openblas fortran # fortran is for openblas
+USES= python:3.6+ blaslapack:openblas fortran # fortran is for openblas
USE_PYTHON= distutils autoplist
CONFIGURE_ENV= BLAS_LAPACK_LIBS="openblas"
diff --git a/math/py-statsmodels010/Makefile b/math/py-statsmodels010/Makefile
index 7638f47be024..a1862535f12a 100644
--- a/math/py-statsmodels010/Makefile
+++ b/math/py-statsmodels010/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}patsy>=0.4.0:math/py-patsy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scipy>=0.18:science/py-scipy@${PY_FLAVOR}
-USES= python shebangfix
+USES= python:3.6+ shebangfix
USE_PYTHON= autoplist concurrent cython distutils
# statsmodels 0.11.0+ requires Python 3.5+
diff --git a/math/py-theano/Makefile b/math/py-theano/Makefile
index 3fcb4c0e56e0..355b247603bd 100644
--- a/math/py-theano/Makefile
+++ b/math/py-theano/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>=0.8.0:science/py-scipy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=1.9.0:devel/py-six@${PY_FLAVOR}
-USES= compiler:openmp python
+USES= compiler:openmp python:3.6+
USE_PYTHON= concurrent distutils autoplist
NO_ARCH= yes
diff --git a/misc/py-eemeter/Makefile b/misc/py-eemeter/Makefile
index 0ea3f111c3b7..192616452dee 100644
--- a/misc/py-eemeter/Makefile
+++ b/misc/py-eemeter/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>0:devel/py-click@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pandas>0:math/py-pandas@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_GITHUB= yes # PyPI doesn't have the latest version for some reason
GH_ACCOUNT= openeemeter
USE_PYTHON= distutils concurrent autoplist
diff --git a/misc/py-scikit-fusion/Makefile b/misc/py-scikit-fusion/Makefile
index e73465c4fc9d..60164fc3f628 100644
--- a/misc/py-scikit-fusion/Makefile
+++ b/misc/py-scikit-fusion/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}joblib>=0.8.4:devel/py-joblib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scipy>=0.12.0:science/py-scipy@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/ports-mgmt/porttree/Makefile b/ports-mgmt/porttree/Makefile
index d49aab6bf8d7..dd04f5be19ca 100644
--- a/ports-mgmt/porttree/Makefile
+++ b/ports-mgmt/porttree/Makefile
@@ -15,7 +15,7 @@ LICENSE= MIT
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}networkx>=2.0:math/py-networkx@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}configargparse>0:devel/py-configargparse@${PY_FLAVOR}
-USES= python tar:bzip2 shebangfix
+USES= python:3.6+ tar:bzip2 shebangfix
#USE_PYTHON= concurrent
SVN_REV= 114
diff --git a/science/dvc/Makefile b/science/dvc/Makefile
index aa03b69b2ee4..3ee2da1a6edc 100644
--- a/science/dvc/Makefile
+++ b/science/dvc/Makefile
@@ -30,7 +30,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}appdirs>=1.4.3:devel/py-appdirs@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}schema>=0.6.7:devel/py-schema@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}zclockfile>0:devel/py-zclockfile@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= distutils autoplist noflavors
NO_ARCH= yes
diff --git a/science/py-GPy/Makefile b/science/py-GPy/Makefile
index fd87fb461499..8da71a729b43 100644
--- a/science/py-GPy/Makefile
+++ b/science/py-GPy/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}paramz>=0.9.0:science/py-paramz@${PY_FLAVOR}
-USES= localbase python
+USES= localbase python:3.6+
USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/science/py-GPyOpt/Makefile b/science/py-GPyOpt/Makefile
index 6c2f8640adfe..e198031cd5a6 100644
--- a/science/py-GPyOpt/Makefile
+++ b/science/py-GPyOpt/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>=0.16:science/py-scipy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}GPy>=1.8:science/py-GPy@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= distutils concurrent autoplist
NO_ARCH= yes
diff --git a/science/py-paramz/Makefile b/science/py-paramz/Makefile
index efd90d36e8a9..7267567c29f9 100644
--- a/science/py-paramz/Makefile
+++ b/science/py-paramz/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= distutils autoplist
NO_ARCH= yes
diff --git a/science/py-pysal/Makefile b/science/py-pysal/Makefile
index db8f7ea434c6..d4c637194ea9 100644
--- a/science/py-pysal/Makefile
+++ b/science/py-pysal/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>=0.11:science/py-scipy@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=0:devel/py-nose@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/science/py-qspin/Makefile b/science/py-qspin/Makefile
index 9cc18af7e8cb..ff58050b1bdf 100644
--- a/science/py-qspin/Makefile
+++ b/science/py-qspin/Makefile
@@ -14,7 +14,7 @@ LICENSE= MIT
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/science/py-rmsd/Makefile b/science/py-rmsd/Makefile
index e44390cfdbdf..932ed007bb33 100644
--- a/science/py-rmsd/Makefile
+++ b/science/py-rmsd/Makefile
@@ -14,7 +14,7 @@ LICENSE= BSD2CLAUSE
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= distutils autoplist concurrent
.include <bsd.port.mk>
diff --git a/science/py-scikit-sparse/Makefile b/science/py-scikit-sparse/Makefile
index 7092cba38063..bcc25abae422 100644
--- a/science/py-scikit-sparse/Makefile
+++ b/science/py-scikit-sparse/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= ${PYNUMPY} \
BUILD_DEPENDS= ${RUN_DEPENDS}
LIB_DEPENDS= libumfpack.so:math/suitesparse
-USES= fortran python
+USES= fortran python:3.6+
USE_PYTHON= distutils cython autoplist
CFLAGS+= -I${LOCALBASE}/include/suitesparse
diff --git a/science/py-scipy/Makefile b/science/py-scipy/Makefile
index 3e666107a0b1..a8f17bcfd2c2 100644
--- a/science/py-scipy/Makefile
+++ b/science/py-scipy/Makefile
@@ -24,7 +24,7 @@ BUILD_DEPENDS= ${PYNUMPY} \
LIB_DEPENDS= libblas.so:math/blas
RUN_DEPENDS= ${PYNUMPY}
-USES= blaslapack:openblas fortran python shebangfix
+USES= blaslapack:openblas fortran python:3.6+ shebangfix
USE_PYTHON= autoplist concurrent distutils
FFLAGS+= -std=legacy
diff --git a/science/py-scoria/Makefile b/science/py-scoria/Makefile
index fbcbeec425f1..b907b442456e 100644
--- a/science/py-scoria/Makefile
+++ b/science/py-scoria/Makefile
@@ -14,7 +14,7 @@ LICENSE= APACHE20
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/science/pybrain/Makefile b/science/pybrain/Makefile
index fdc96c83b7e2..4213c5d8763f 100644
--- a/science/pybrain/Makefile
+++ b/science/pybrain/Makefile
@@ -15,7 +15,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}scipy>=0.7.1:science/py-scipy@${PY_FLAVOR}
USE_GITHUB= yes
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist distutils concurrent optsuffix
.include <bsd.port.mk>