aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2021-12-20 17:23:35 +0000
committerBernard Spil <brnrd@FreeBSD.org>2021-12-20 17:43:33 +0000
commit1507509936f2d411fa565907a42b09040ad421f7 (patch)
tree4019d693897d3777b4d6a825bf9e804fc11d7809
parent60c5a136f63abb7e00ca8f32c4e93f3e810ecb1a (diff)
downloadports-1507509936f2d411fa565907a42b09040ad421f7.tar.gz
ports-1507509936f2d411fa565907a42b09040ad421f7.zip
www/apache24: Update to 2.4.52
Security: ca982e2d-61a9-11ec-8be6-d4c9ef517024 MFH: 2021Q4 (cherry picked from commit e721e5aeffbd529fb28aeae0bf0b90b128a965e8)
-rw-r--r--www/apache24/Makefile2
-rw-r--r--www/apache24/distinfo6
-rw-r--r--www/apache24/files/patch-modules_ssl_ssl__engine__io.c27
3 files changed, 4 insertions, 31 deletions
diff --git a/www/apache24/Makefile b/www/apache24/Makefile
index 4af09c60ded3..64160a1d7b53 100644
--- a/www/apache24/Makefile
+++ b/www/apache24/Makefile
@@ -1,5 +1,5 @@
PORTNAME= apache24
-PORTVERSION= 2.4.51
+PORTVERSION= 2.4.52
CATEGORIES= www
MASTER_SITES= APACHE_HTTPD
DISTNAME= httpd-${PORTVERSION}
diff --git a/www/apache24/distinfo b/www/apache24/distinfo
index 27f7dd9c0d1c..a7ee86ebea2a 100644
--- a/www/apache24/distinfo
+++ b/www/apache24/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1633625239
-SHA256 (apache24/httpd-2.4.51.tar.bz2) = 20e01d81fecf077690a4439e3969a9b22a09a8d43c525356e863407741b838f4
-SIZE (apache24/httpd-2.4.51.tar.bz2) = 7653609
+TIMESTAMP = 1640014080
+SHA256 (apache24/httpd-2.4.52.tar.bz2) = 0127f7dc497e9983e9c51474bed75e45607f2f870a7675a86dc90af6d572f5c9
+SIZE (apache24/httpd-2.4.52.tar.bz2) = 7439184
diff --git a/www/apache24/files/patch-modules_ssl_ssl__engine__io.c b/www/apache24/files/patch-modules_ssl_ssl__engine__io.c
index 70923c6beaa3..ec2beb1f9e38 100644
--- a/www/apache24/files/patch-modules_ssl_ssl__engine__io.c
+++ b/www/apache24/files/patch-modules_ssl_ssl__engine__io.c
@@ -9,30 +9,3 @@
bio_filter_out_ctx_t *outctx = (bio_filter_out_ctx_t *)BIO_get_data(bio);
switch (cmd) {
-@@ -542,7 +542,7 @@ static int bio_filter_in_gets(BIO *bio, char *buf, int
-
- static long bio_filter_in_ctrl(BIO *bio, int cmd, long num, void *ptr)
- {
-- return -1;
-+ return 0;
- }
-
- #if MODSSL_USE_OPENSSL_PRE_1_1_API
-@@ -567,7 +567,7 @@ static BIO_METHOD bio_filter_in_method = {
- bio_filter_in_read,
- bio_filter_in_puts, /* puts is never called */
- bio_filter_in_gets, /* gets is never called */
-- bio_filter_in_ctrl, /* ctrl is never called */
-+ bio_filter_in_ctrl,
- bio_filter_create,
- bio_filter_destroy,
- NULL
-@@ -594,7 +594,7 @@ void init_bio_methods(void)
- BIO_meth_set_read(bio_filter_in_method, &bio_filter_in_read);
- BIO_meth_set_puts(bio_filter_in_method, &bio_filter_in_puts); /* puts is never called */
- BIO_meth_set_gets(bio_filter_in_method, &bio_filter_in_gets); /* gets is never called */
-- BIO_meth_set_ctrl(bio_filter_in_method, &bio_filter_in_ctrl); /* ctrl is never called */
-+ BIO_meth_set_ctrl(bio_filter_in_method, &bio_filter_in_ctrl);
- BIO_meth_set_create(bio_filter_in_method, &bio_filter_create);
- BIO_meth_set_destroy(bio_filter_in_method, &bio_filter_destroy);
- }