aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2008-07-18 13:20:51 +0000
committerWesley Shields <wxs@FreeBSD.org>2008-07-18 13:20:51 +0000
commit1f0de0e8e8e6aa695ab0d63bcedec6d8b94855c6 (patch)
tree0bb5c55458b057a31ca41b075b02aee2b2f2951c
parentb16eff54df864356a56b96ae96ffe2b5ddc37d1a (diff)
downloadports-1f0de0e8e8e6aa695ab0d63bcedec6d8b94855c6.tar.gz
ports-1f0de0e8e8e6aa695ab0d63bcedec6d8b94855c6.zip
Notes
-rw-r--r--security/Makefile1
-rw-r--r--security/flowtag/Makefile28
-rw-r--r--security/flowtag/distinfo3
-rw-r--r--security/flowtag/pkg-descr8
-rw-r--r--security/flowtag/pkg-plist10
5 files changed, 50 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 7620130e4d04..c7f9ee8d27ac 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -131,6 +131,7 @@
SUBDIR += firewalk
SUBDIR += fl0p
SUBDIR += flawfinder
+ SUBDIR += flowtag
SUBDIR += fpc-hash
SUBDIR += fpc-openssl
SUBDIR += fpm
diff --git a/security/flowtag/Makefile b/security/flowtag/Makefile
new file mode 100644
index 000000000000..bea505ce5abc
--- /dev/null
+++ b/security/flowtag/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: flowtag
+# Date created: 14 July 2008
+# Whom: Lee Hinman <lee@writequit.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= flowtag
+PORTVERSION= 2.0.5
+CATEGORIES= security
+MASTER_SITES= http://hexbit.csc.gatech.edu/portfiles/ \
+ http://writequit.org/misc/files/ \
+ http://chrislee.dhs.org/pages/research/flowtag/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= lee@writequit.org
+COMMENT= A collaborative attack-analysis tool for security researchers
+
+BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby18
+RUN_DEPENDS= ${LOCALBASE}/lib/ruby/1.8/tk/canvas.rb:${PORTSDIR}/x11-toolkits/ruby-tk
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+
+MAN1= flowtag.1 listflows.1 pcap2flowdb.1 printflow.1
+MANCOMPRESSED= yes
+
+.include <bsd.port.mk>
diff --git a/security/flowtag/distinfo b/security/flowtag/distinfo
new file mode 100644
index 000000000000..a827085ae6a7
--- /dev/null
+++ b/security/flowtag/distinfo
@@ -0,0 +1,3 @@
+MD5 (flowtag-2.0.5.tgz) = 21a1c8cd1c1488dea5e480d0f38e43ea
+SHA256 (flowtag-2.0.5.tgz) = a87f5d47a481cd0e4d282cf0b75e08af0b46530c40b6f48a9b76689f309c368f
+SIZE (flowtag-2.0.5.tgz) = 44652
diff --git a/security/flowtag/pkg-descr b/security/flowtag/pkg-descr
new file mode 100644
index 000000000000..c162b0e35565
--- /dev/null
+++ b/security/flowtag/pkg-descr
@@ -0,0 +1,8 @@
+FlowTag is a GUI interface for exploring the TCP flows in a PCAP
+(network trace recorded by libpcap, tcpdump, ethereal, or wireshark)
+file. It's strengths lie in:
+
+ * rapid reconstruction of flows (via indexing),
+ * visual selection of source IP and destination TCP ports;
+ * filtering by time, packet count, and/or byte count
+ * tagging flows with keywords
diff --git a/security/flowtag/pkg-plist b/security/flowtag/pkg-plist
new file mode 100644
index 000000000000..36a1b53cc545
--- /dev/null
+++ b/security/flowtag/pkg-plist
@@ -0,0 +1,10 @@
+bin/flowtag
+bin/listflows
+bin/pcap2flowdb
+bin/printflow
+lib/ruby/site_ruby/%%RUBY_VER%%/flowcanvas.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/flowdb.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/flowtable.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/parallelcoordinates.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/pcapparser.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/tkdoubleslider.rb