aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2016-09-16 04:27:51 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2016-09-16 04:27:51 +0000
commit23316beafd29338da142cf65316bffc6455eae2b (patch)
tree299bd6e994fb4bdd5c62ba48612722a1993aab1d
parent5c4b1a26300550065be76ae1ad7b52ed9395cecd (diff)
Notes
-rw-r--r--sysutils/pftop/Makefile4
-rw-r--r--sysutils/pftop/files/patch-bpf_filter.c13
-rw-r--r--sysutils/pftop/files/patch-bpf_image.c11
3 files changed, 25 insertions, 3 deletions
diff --git a/sysutils/pftop/Makefile b/sysutils/pftop/Makefile
index 5488f386fba8..db4a802e956b 100644
--- a/sysutils/pftop/Makefile
+++ b/sysutils/pftop/Makefile
@@ -3,15 +3,13 @@
PORTNAME= pftop
PORTVERSION= 0.7
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= sysutils net
MASTER_SITES= http://www.eee.metu.edu.tr/~canacar/
MAINTAINER= araujo@FreeBSD.org
COMMENT= Utility for real-time display of statistics for pf
-BROKEN_powerpc64= Does not build
-
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 1100080
diff --git a/sysutils/pftop/files/patch-bpf_filter.c b/sysutils/pftop/files/patch-bpf_filter.c
new file mode 100644
index 000000000000..7c6855930263
--- /dev/null
+++ b/sysutils/pftop/files/patch-bpf_filter.c
@@ -0,0 +1,13 @@
+--- bpf_filter.c.orig 2016-09-12 16:50:11.454297000 +0200
++++ bpf_filter.c 2016-09-12 16:43:28.150188000 +0200
+@@ -143,8 +143,8 @@
+ */
+ u_int
+ bpf_filter(pc, p, wirelen, buflen)
+- struct bpf_insn *pc;
+- u_char *p;
++ const struct bpf_insn *pc;
++ const u_char *p;
+ u_int wirelen;
+ u_int buflen;
+ {
diff --git a/sysutils/pftop/files/patch-bpf_image.c b/sysutils/pftop/files/patch-bpf_image.c
new file mode 100644
index 000000000000..d2a8d3bfade6
--- /dev/null
+++ b/sysutils/pftop/files/patch-bpf_image.c
@@ -0,0 +1,11 @@
+--- bpf_image.c.orig 2016-09-12 16:51:21.704680000 +0200
++++ bpf_image.c 2016-09-12 16:43:28.038646000 +0200
+@@ -36,7 +36,7 @@
+
+ char *
+ bpf_image(p, n)
+- struct bpf_insn *p;
++ const struct bpf_insn *p;
+ int n;
+ {
+ int v;