aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-04-07 14:48:39 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-04-07 14:48:39 +0000
commit2566156f4c321b9e17412bbaf50cc9ffe13a17ad (patch)
tree4a60bd769e0657aa212b49191c2780b6d8edc4f6
parentf90e0fb6e5a88ea869965965a55607618fb94626 (diff)
downloadports-2566156f4c321b9e17412bbaf50cc9ffe13a17ad.tar.gz
ports-2566156f4c321b9e17412bbaf50cc9ffe13a17ad.zip
Notes
-rw-r--r--MOVED1
-rw-r--r--audio/Makefile1
-rw-r--r--audio/rebler/Makefile44
-rw-r--r--audio/rebler/distinfo2
-rw-r--r--audio/rebler/files/patch-rebler.cpp51
-rw-r--r--audio/rebler/pkg-descr18
6 files changed, 1 insertions, 116 deletions
diff --git a/MOVED b/MOVED
index 7ba3d9cc42f7..8bf73c08ace4 100644
--- a/MOVED
+++ b/MOVED
@@ -1439,3 +1439,4 @@ www/konqueror-nsplugins|x11/kdebase3|2005-03-20|moved back into kdebase3
science/mxp|graphics/mxp|2005-03-25|fix category
misc/kfile_torrent|net/kdenetwork3|2005-03-27|kfile_torrent included in kdenetwork package
multimedia/linux-divxplayer||2005-04-02|developer's dropped the application
+audio/rebler||2005-04-07|Project dead and disappeared
diff --git a/audio/Makefile b/audio/Makefile
index 2d34b2dde16c..6527d718d422 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -370,7 +370,6 @@
SUBDIR += raproxy
SUBDIR += rawrec
SUBDIR += rbscrobbler
- SUBDIR += rebler
SUBDIR += replay
SUBDIR += resid
SUBDIR += rexima
diff --git a/audio/rebler/Makefile b/audio/rebler/Makefile
deleted file mode 100644
index da9027beb8b6..000000000000
--- a/audio/rebler/Makefile
+++ /dev/null
@@ -1,44 +0,0 @@
-# ex:ts=8
-# New ports collection makefile for: rebler
-# Date created: Nov 3, 2001
-# Whom: ijliao
-#
-# $FreeBSD$
-#
-
-PORTNAME= rebler
-PORTVERSION= 1.0
-PORTREVISION= 2
-CATEGORIES= audio
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A program to convert mpeg2 and ac3 into DivX with ac3 audio
-
-LIB_DEPENDS= mpeg2:${PORTSDIR}/multimedia/libmpeg2 \
- aviplay.0:${PORTSDIR}/multimedia/avifile \
- popt:${PORTSDIR}/devel/popt
-
-PLIST_FILES= bin/rebler
-USE_BZIP2= yes
-AVIFILE_CONFIG?= ${LOCALBASE}/bin/avifile-config
-CFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS} \
- `${AVIFILE_CONFIG} --cflags`
-LIBS+= -L${LOCALBASE}/lib -lm -lmpeg2 ${PTHREAD_LIBS} \
- `${AVIFILE_CONFIG} --libs` -lpopt
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
-do-build:
- @(cd ${WRKSRC} ; \
- ${CXX} ${CXXFLAGS} rebler.cpp -o rebler ${LIBS})
-
-do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/rebler ${PREFIX}/bin
-
-.include <bsd.port.post.mk>
diff --git a/audio/rebler/distinfo b/audio/rebler/distinfo
deleted file mode 100644
index 82ec1089e2b6..000000000000
--- a/audio/rebler/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (rebler-1.0.tar.bz2) = a68de698cc4aa8a04951116287bbd899
-SIZE (rebler-1.0.tar.bz2) = 12173
diff --git a/audio/rebler/files/patch-rebler.cpp b/audio/rebler/files/patch-rebler.cpp
deleted file mode 100644
index e500efb7aba7..000000000000
--- a/audio/rebler/files/patch-rebler.cpp
+++ /dev/null
@@ -1,51 +0,0 @@
---- rebler.cpp.orig Mon Aug 6 22:59:36 2001
-+++ rebler.cpp Sun Apr 13 04:09:49 2003
-@@ -29,6 +29,7 @@
- ******************************************************************************/
-
-
-+#include <vector>
- #include <string>
- #include <iostream>
- #include <fstream>
-@@ -281,8 +282,8 @@
- void dumpCodec( const CodecInfo* ci )
- {
- cerr << "-------------------------------------------" << endl;
-- cerr << "Name : " << ci->text << endl;
-- cerr << "About : " << ci->about << endl;
-+ cerr << "Name : " << ci->GetName() << endl;
-+ cerr << "About : " << ci->GetAbout() << endl;
- cerr << "Win32DLL : " << ci->dll << endl;
- // cerr << "GUID : " << ci->guid << endl;
- cerr << "module name: " << ci->modulename << endl;
-@@ -303,7 +304,6 @@
- case CodecInfo::Plugin: cerr << "Plugin "; break;
- case CodecInfo::Win32: cerr << "Win32 "; break;
- case CodecInfo::DShow_Dec: cerr << "DShow_Dec"; break;
-- case CodecInfo::DShow_Enc: cerr << "DShow_Enc"; break;
- default:
- cerr << "Unknown";
- break;
-@@ -325,8 +325,8 @@
- iter != ci->encoder_info.end();
- iter++)
- {
-- cerr << " " << "name : " << iter->name << endl;
-- cerr << " " << "about : " << iter->about << endl;
-+ cerr << " " << "name : " << iter->GetName() << endl;
-+ cerr << " " << "about : " << iter->GetAbout() << endl;
- cerr << " " << "kind : ";
- switch(iter->kind)
- {
-@@ -338,8 +338,8 @@
- {
- cerr << "Select from: ";
- for( std::vector<std::string>::const_iterator i =
-- iter->options.begin();
-- i != iter->options.end();
-+ (std::vector<std::string>::const_iterator)iter->options.begin();
-+ i != (std::vector<std::string>::const_iterator)iter->options.end();
- i++ )
- {
- cerr << *i << " ";
diff --git a/audio/rebler/pkg-descr b/audio/rebler/pkg-descr
deleted file mode 100644
index 3bae2c9d4062..000000000000
--- a/audio/rebler/pkg-descr
+++ /dev/null
@@ -1,18 +0,0 @@
-A program to convert mpeg2 and ac3 into DivX with ac3 audio multiplexed
-into it.
-
-rebler is mainly intended for people to digitize their home handy cam videos
-and preserve them online. For example tapes of weddings and other times that
-one might wish to watch over and over. Though there may be other uses for
-rebler than this.
-
-Some examples of usage:
-
-./rebler --input-ac3=music.ac3 --output-avi=snakes.avi \
---output-fourcc=DIV3 </tmp/silly-big-pgppipe-file
-
-mpeg2dec -o pgmpipe -s /store/Jan2001Holiday.mpg | ./rebler \
---input-ac3=classic-music.ac3 --output-avi=Jan2001Holiday.avi \
---output-fourcc=DIV3
-
-WWW: http://sourceforge.net/projects/rebler/