aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-05-05 11:35:57 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-05-05 11:35:57 +0000
commit2f018cf3e95418402a3258d3756263f99566f450 (patch)
treedef40ba664ed6093a1b4243898d84128e0cd430c
parent88a8000653d2c5df9a05d11477dc54488bdc312c (diff)
downloadports-2f018cf3e95418402a3258d3756263f99566f450.tar.gz
ports-2f018cf3e95418402a3258d3756263f99566f450.zip
Notes
-rw-r--r--comms/usbmuxd/files/patch-ppoll25
1 files changed, 25 insertions, 0 deletions
diff --git a/comms/usbmuxd/files/patch-ppoll b/comms/usbmuxd/files/patch-ppoll
new file mode 100644
index 000000000000..6e72aa8eacf1
--- /dev/null
+++ b/comms/usbmuxd/files/patch-ppoll
@@ -0,0 +1,25 @@
+diff --git configure.ac configure.ac
+index 6c2481a..d204ba0 100644
+--- configure.ac
++++ configure.ac
+@@ -96,6 +96,7 @@ AC_TYPE_UINT8_T
+ AC_FUNC_MALLOC
+ AC_FUNC_REALLOC
+ AC_CHECK_FUNCS([strcasecmp strdup strerror strndup stpcpy])
++AC_CHECK_FUNCS([ppoll])
+
+ # Check for operating system
+ AC_MSG_CHECKING([whether to enable WIN32 build settings])
+diff --git src/main.c src/main.c
+index 2e4439c..cfe6acc 100644
+--- src/main.c
++++ src/main.c
+@@ -159,7 +159,7 @@ static void set_signal_handlers(void)
+ sigaction(SIGUSR2, &sa, NULL);
+ }
+
+-#if defined(__FreeBSD__) || defined(__APPLE__)
++#ifndef HAVE_PPOLL
+ static int ppoll(struct pollfd *fds, nfds_t nfds, const struct timespec *timeout, const sigset_t *sigmask)
+ {
+ int ready;