aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-12-10 23:56:58 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-12-10 23:56:58 +0000
commit34387509d2249c2e0dba2fd21a4991fe1ffe9b97 (patch)
tree36e5eb5b645b6cb92ef2a0a3bd4d56215632c474
parent6fdf473cae06ccb4290ad2ea4016bfaf04ab3657 (diff)
downloadports-34387509d2249c2e0dba2fd21a4991fe1ffe9b97.tar.gz
ports-34387509d2249c2e0dba2fd21a4991fe1ffe9b97.zip
Notes
-rw-r--r--net-p2p/mldonkey-devel/files/patch-config__Makefile.in20
-rw-r--r--net-p2p/mldonkey-devel/files/patch-config__configure.in31
-rw-r--r--net-p2p/mldonkey-devel/files/patch-src__daemon__common__commonInteractive.ml30
-rw-r--r--net-p2p/mldonkey-devel/files/patch-src__utils__lib__fst_hash.c14
-rw-r--r--net/mldonkey-devel/files/patch-config__Makefile.in20
-rw-r--r--net/mldonkey-devel/files/patch-config__configure.in31
-rw-r--r--net/mldonkey-devel/files/patch-src__daemon__common__commonInteractive.ml30
-rw-r--r--net/mldonkey-devel/files/patch-src__utils__lib__fst_hash.c14
8 files changed, 190 insertions, 0 deletions
diff --git a/net-p2p/mldonkey-devel/files/patch-config__Makefile.in b/net-p2p/mldonkey-devel/files/patch-config__Makefile.in
new file mode 100644
index 000000000000..370ec93a3486
--- /dev/null
+++ b/net-p2p/mldonkey-devel/files/patch-config__Makefile.in
@@ -0,0 +1,20 @@
+--- ../mldonkey.orig/config/Makefile.in Wed Nov 30 21:46:02 2005
++++ config/Makefile.in Sat Dec 10 17:44:06 2005
+@@ -19,7 +19,7 @@
+
+ ##################################################################
+
+-DEVFLAGS= -warn-error Am
++DEVFLAGS= #-warn-error Am
+ # -dtypes
+
+ NO_LIBS_byte=
+@@ -1722,7 +1722,7 @@
+ PA_ZOG_FILES=tools/zoggy/zog_types.ml tools/zoggy/zog_messages.ml tools/zoggy/zog_misc.ml tools/zoggy/pa_zog.ml
+
+ pa_zog.cma: $(PA_ZOG_FILES)
+- $(OCAMLC) -I tools/zoggy -I +camlp4 -pp "$(CAMLP4) pa_o.cmo pr_dump.cmo" -a -o pa_zog.cma $(PA_ZOG_FILES)
++ $(OCAMLC) -I tools/zoggy -I +camlp4 -pp "$(CAMLP4) pa_o.cmo pr_dump.cmo -loc loc" -a -o pa_zog.cma $(PA_ZOG_FILES)
+
+
+ OCAMLPP=./ocamlpp.byte
diff --git a/net-p2p/mldonkey-devel/files/patch-config__configure.in b/net-p2p/mldonkey-devel/files/patch-config__configure.in
new file mode 100644
index 000000000000..3cc74a1998c1
--- /dev/null
+++ b/net-p2p/mldonkey-devel/files/patch-config__configure.in
@@ -0,0 +1,31 @@
+--- ../mldonkey.orig/config/configure.in Tue Dec 6 18:43:02 2005
++++ config/configure.in Sat Dec 10 17:44:06 2005
+@@ -133,9 +133,9 @@
+ if test ! -z "$SUB_VERSION3"; then
+ MLDONKEY_VERSION=$MLDONKEY_VERSION.$SUB_VERSION3
+ fi
+-REQUIRED_OCAML=3.08.4
+-DOWNLOAD_OCAML_MAJOR=3.08
+-DOWNLOAD_OCAML=3.08.4
++REQUIRED_OCAML=3.09.0
++DOWNLOAD_OCAML_MAJOR=3.09
++DOWNLOAD_OCAML=3.09.0
+
+ REQUIRED_LABLGTK=1.2.7
+
+@@ -332,6 +332,7 @@
+ OCAMLVERSION=`$OCAMLC -v | sed -n -e 's|.*version* *\(.*\)$|\1|p' `
+ case "$OCAMLVERSION" in
+ "$REQUIRED_OCAML"*) ;;
++ 3.08.4*) ;;
+ 3.08.3*) ;;
+ 3.08.2*)
+ if test "$system" = "rhapsody"; then
+@@ -503,6 +504,7 @@
+ REBUILD_OCAML=no
+ case "$OCAMLVERSION" in
+ "$REQUIRED_OCAML"*) ;;
++ 3.08.4*) ;;
+ 3.08.3*) ;;
+ 3.08.2*)
+ if test "$system" = "rhapsody"; then
diff --git a/net-p2p/mldonkey-devel/files/patch-src__daemon__common__commonInteractive.ml b/net-p2p/mldonkey-devel/files/patch-src__daemon__common__commonInteractive.ml
new file mode 100644
index 000000000000..85a1bdf20571
--- /dev/null
+++ b/net-p2p/mldonkey-devel/files/patch-src__daemon__common__commonInteractive.ml
@@ -0,0 +1,30 @@
+--- ../mldonkey.orig/src/daemon/common/commonInteractive.ml Fri Dec 2 10:08:04 2005
++++ src/daemon/common/commonInteractive.ml Fri Dec 9 21:23:18 2005
+@@ -106,7 +106,7 @@
+ let file_id = Filename.basename temp_name in
+ let size = Int64.to_string (file_size file) in
+ let duration =
+- Date.time_to_string_long ((BasicSocket.last_time ()) - info.G.file_age)
++ string_of_int ((BasicSocket.last_time ()) - info.G.file_age)
+ in
+ let network = network_find_by_num info.G.file_network in
+ let filename = Filename.basename new_name in
+@@ -117,6 +117,7 @@
+ (Int64.to_string (file_size file))
+ (Md4.to_string info.G.file_md4)
+ in
++ begin try
+ MlUnix.fork_and_exec !!file_completed_cmd
+ [| (* keep those for compatibility *)
+ "";
+@@ -133,6 +134,10 @@
+ ("INCOMING", incoming);
+ ("NETWORK", network.network_name);
+ ("ED2K_HASH", ed2k_hash)]
++ with e ->
++ lprintf_nl "[cInt] Exception %s while executing %s"
++ (Printexc2.to_string e) !!file_completed_cmd
++ end
+
+ (********
+ These two functions 'file_commit' and 'file_cancel' should be the two only
diff --git a/net-p2p/mldonkey-devel/files/patch-src__utils__lib__fst_hash.c b/net-p2p/mldonkey-devel/files/patch-src__utils__lib__fst_hash.c
new file mode 100644
index 000000000000..734763f18da4
--- /dev/null
+++ b/net-p2p/mldonkey-devel/files/patch-src__utils__lib__fst_hash.c
@@ -0,0 +1,14 @@
+--- ../mldonkey.orig/src/utils/lib/fst_hash.c Mon Aug 1 20:53:33 2005
++++ src/utils/lib/fst_hash.c Sat Dec 10 17:44:06 2005
+@@ -181,9 +181,9 @@
+ #include "caml/mlvalues.h"
+
+ /* returns checksum of fzhash */
+-uint16 fst_hash_checksum (unsigned char *hash)
++unsigned short fst_hash_checksum (unsigned char *hash)
+ {
+- uint16 sum = 0;
++ unsigned short sum = 0;
+ int i;
+
+ /* calculate 2 byte checksum used in the URL from 20 byte fthash */
diff --git a/net/mldonkey-devel/files/patch-config__Makefile.in b/net/mldonkey-devel/files/patch-config__Makefile.in
new file mode 100644
index 000000000000..370ec93a3486
--- /dev/null
+++ b/net/mldonkey-devel/files/patch-config__Makefile.in
@@ -0,0 +1,20 @@
+--- ../mldonkey.orig/config/Makefile.in Wed Nov 30 21:46:02 2005
++++ config/Makefile.in Sat Dec 10 17:44:06 2005
+@@ -19,7 +19,7 @@
+
+ ##################################################################
+
+-DEVFLAGS= -warn-error Am
++DEVFLAGS= #-warn-error Am
+ # -dtypes
+
+ NO_LIBS_byte=
+@@ -1722,7 +1722,7 @@
+ PA_ZOG_FILES=tools/zoggy/zog_types.ml tools/zoggy/zog_messages.ml tools/zoggy/zog_misc.ml tools/zoggy/pa_zog.ml
+
+ pa_zog.cma: $(PA_ZOG_FILES)
+- $(OCAMLC) -I tools/zoggy -I +camlp4 -pp "$(CAMLP4) pa_o.cmo pr_dump.cmo" -a -o pa_zog.cma $(PA_ZOG_FILES)
++ $(OCAMLC) -I tools/zoggy -I +camlp4 -pp "$(CAMLP4) pa_o.cmo pr_dump.cmo -loc loc" -a -o pa_zog.cma $(PA_ZOG_FILES)
+
+
+ OCAMLPP=./ocamlpp.byte
diff --git a/net/mldonkey-devel/files/patch-config__configure.in b/net/mldonkey-devel/files/patch-config__configure.in
new file mode 100644
index 000000000000..3cc74a1998c1
--- /dev/null
+++ b/net/mldonkey-devel/files/patch-config__configure.in
@@ -0,0 +1,31 @@
+--- ../mldonkey.orig/config/configure.in Tue Dec 6 18:43:02 2005
++++ config/configure.in Sat Dec 10 17:44:06 2005
+@@ -133,9 +133,9 @@
+ if test ! -z "$SUB_VERSION3"; then
+ MLDONKEY_VERSION=$MLDONKEY_VERSION.$SUB_VERSION3
+ fi
+-REQUIRED_OCAML=3.08.4
+-DOWNLOAD_OCAML_MAJOR=3.08
+-DOWNLOAD_OCAML=3.08.4
++REQUIRED_OCAML=3.09.0
++DOWNLOAD_OCAML_MAJOR=3.09
++DOWNLOAD_OCAML=3.09.0
+
+ REQUIRED_LABLGTK=1.2.7
+
+@@ -332,6 +332,7 @@
+ OCAMLVERSION=`$OCAMLC -v | sed -n -e 's|.*version* *\(.*\)$|\1|p' `
+ case "$OCAMLVERSION" in
+ "$REQUIRED_OCAML"*) ;;
++ 3.08.4*) ;;
+ 3.08.3*) ;;
+ 3.08.2*)
+ if test "$system" = "rhapsody"; then
+@@ -503,6 +504,7 @@
+ REBUILD_OCAML=no
+ case "$OCAMLVERSION" in
+ "$REQUIRED_OCAML"*) ;;
++ 3.08.4*) ;;
+ 3.08.3*) ;;
+ 3.08.2*)
+ if test "$system" = "rhapsody"; then
diff --git a/net/mldonkey-devel/files/patch-src__daemon__common__commonInteractive.ml b/net/mldonkey-devel/files/patch-src__daemon__common__commonInteractive.ml
new file mode 100644
index 000000000000..85a1bdf20571
--- /dev/null
+++ b/net/mldonkey-devel/files/patch-src__daemon__common__commonInteractive.ml
@@ -0,0 +1,30 @@
+--- ../mldonkey.orig/src/daemon/common/commonInteractive.ml Fri Dec 2 10:08:04 2005
++++ src/daemon/common/commonInteractive.ml Fri Dec 9 21:23:18 2005
+@@ -106,7 +106,7 @@
+ let file_id = Filename.basename temp_name in
+ let size = Int64.to_string (file_size file) in
+ let duration =
+- Date.time_to_string_long ((BasicSocket.last_time ()) - info.G.file_age)
++ string_of_int ((BasicSocket.last_time ()) - info.G.file_age)
+ in
+ let network = network_find_by_num info.G.file_network in
+ let filename = Filename.basename new_name in
+@@ -117,6 +117,7 @@
+ (Int64.to_string (file_size file))
+ (Md4.to_string info.G.file_md4)
+ in
++ begin try
+ MlUnix.fork_and_exec !!file_completed_cmd
+ [| (* keep those for compatibility *)
+ "";
+@@ -133,6 +134,10 @@
+ ("INCOMING", incoming);
+ ("NETWORK", network.network_name);
+ ("ED2K_HASH", ed2k_hash)]
++ with e ->
++ lprintf_nl "[cInt] Exception %s while executing %s"
++ (Printexc2.to_string e) !!file_completed_cmd
++ end
+
+ (********
+ These two functions 'file_commit' and 'file_cancel' should be the two only
diff --git a/net/mldonkey-devel/files/patch-src__utils__lib__fst_hash.c b/net/mldonkey-devel/files/patch-src__utils__lib__fst_hash.c
new file mode 100644
index 000000000000..734763f18da4
--- /dev/null
+++ b/net/mldonkey-devel/files/patch-src__utils__lib__fst_hash.c
@@ -0,0 +1,14 @@
+--- ../mldonkey.orig/src/utils/lib/fst_hash.c Mon Aug 1 20:53:33 2005
++++ src/utils/lib/fst_hash.c Sat Dec 10 17:44:06 2005
+@@ -181,9 +181,9 @@
+ #include "caml/mlvalues.h"
+
+ /* returns checksum of fzhash */
+-uint16 fst_hash_checksum (unsigned char *hash)
++unsigned short fst_hash_checksum (unsigned char *hash)
+ {
+- uint16 sum = 0;
++ unsigned short sum = 0;
+ int i;
+
+ /* calculate 2 byte checksum used in the URL from 20 byte fthash */