aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-08-11 04:26:43 +0000
committerPatrick Li <pat@FreeBSD.org>2002-08-11 04:26:43 +0000
commit37708c9db6c6b71a916aff0ef67a864694759f74 (patch)
tree1efd057ed100dda7cf3b446408d0b5aa572b967a
parentf3b0e3a51cca42e00d9f69f4db580ce234907ddd (diff)
downloadports-37708c9db6c6b71a916aff0ef67a864694759f74.tar.gz
ports-37708c9db6c6b71a916aff0ef67a864694759f74.zip
Notes
-rw-r--r--security/steghide/Makefile20
-rw-r--r--security/steghide/distinfo2
-rw-r--r--security/steghide/files/patch-aa18
-rw-r--r--security/steghide/pkg-descr6
-rw-r--r--security/steghide/pkg-plist15
5 files changed, 36 insertions, 25 deletions
diff --git a/security/steghide/Makefile b/security/steghide/Makefile
index 1a04a3fc4983..d3dea4986069 100644
--- a/security/steghide/Makefile
+++ b/security/steghide/Makefile
@@ -6,19 +6,31 @@
#
PORTNAME= steghide
-PORTVERSION= 0.4.4
+PORTVERSION= 0.4.6.b
CATEGORIES= security
MASTER_SITES= http://steghide.sourceforge.net/download/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.b/b/}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= freebsdports@arved.de
LIB_DEPENDS= mcrypt.7:${PORTSDIR}/security/libmcrypt \
- mhash.2:${PORTSDIR}/security/mhash
+ mhash.2:${PORTSDIR}/security/mhash \
+ intl.4:${PORTSDIR}/devel/gettext
GNU_CONFIGURE= yes
+CONFIGURE_TARGET=
+CONFIGURE_ARGS= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
-CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -lintl"
+USE_REINPLACE= yes
MAN1= steghide.1
+post-patch:
+.ifdef(NOPORTDOCS)
+ ${REINPLACE_CMD} -e 's|install-data-am\: install-docDATA||' \
+ ${WRKSRC}/Makefile.in
+.endif
+
.include <bsd.port.mk>
diff --git a/security/steghide/distinfo b/security/steghide/distinfo
index 249cd41828ef..952d351079b5 100644
--- a/security/steghide/distinfo
+++ b/security/steghide/distinfo
@@ -1 +1 @@
-MD5 (steghide-0.4.4.tar.gz) = 32d81a5c3aaca70db37cff558602e699
+MD5 (steghide-0.4.6b.tar.gz) = 72be8f0cdd6c0d03c455f6854eeb5a2b
diff --git a/security/steghide/files/patch-aa b/security/steghide/files/patch-aa
index 62bd61b00470..c7116ebe3f77 100644
--- a/security/steghide/files/patch-aa
+++ b/security/steghide/files/patch-aa
@@ -1,13 +1,13 @@
---- Makefile.in.orig Wed Dec 5 19:27:13 2001
-+++ Makefile.in Wed Dec 5 19:27:01 2001
-@@ -67,8 +67,8 @@
- bin_PROGRAMS = steghide
- steghide_SOURCES = bufmanag.c crypto.c ff_au.c ff_bmp.c ff_wav.c hash.c io.c main.c msg.c stegano.c support.c
- man_MANS = steghide.1
+--- Makefile.in.orig Tue May 14 08:50:09 2002
++++ Makefile.in Sat Aug 10 22:12:35 2002
+@@ -99,8 +99,8 @@
+
+ EXTRA_DIST = ABOUT-NLS BUGS CREDITS HISTORY depcomp
+ SUBDIRS = doc intl po src
-docdir = $(prefix)/doc/$(PACKAGE)-$(VERSION)
--doc_DATA = BUGS COPYING CREDITS HISTORY INSTALL README TODO
+-doc_DATA = ABOUT-NLS BUGS COPYING CREDITS HISTORY INSTALL README TODO
+docdir = $(prefix)/share/doc/$(PACKAGE)
-+doc_DATA = BUGS CREDITS HISTORY INSTALL README TODO
++doc_DATA = BUGS CREDITS HISTORY README TODO
+ subdir = .
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
- CONFIG_CLEAN_FILES =
diff --git a/security/steghide/pkg-descr b/security/steghide/pkg-descr
index b9b23fcfb666..f20cddc2b057 100644
--- a/security/steghide/pkg-descr
+++ b/security/steghide/pkg-descr
@@ -7,7 +7,5 @@ in bmp, wav and au files, blowfish encryption, MD5 hashing of passphrases to
blowfish keys and pseudo-random distribution of hidden bits ("stego bits") in
the container data.
-WWW: http://steghide.sourceforge.net/
-
-- Rasputin
-rasputin@submonkey.net
+WWW: http://steghide.sourceforge.net/
+Author: Stefan Hetzl <shetzl@teleweb.at>
diff --git a/security/steghide/pkg-plist b/security/steghide/pkg-plist
index 02bcce98d8c4..7f6a244be650 100644
--- a/security/steghide/pkg-plist
+++ b/security/steghide/pkg-plist
@@ -1,8 +1,9 @@
bin/steghide
-share/doc/steghide/BUGS
-share/doc/steghide/CREDITS
-share/doc/steghide/HISTORY
-share/doc/steghide/INSTALL
-share/doc/steghide/README
-share/doc/steghide/TODO
-@dirrm share/doc/steghide
+%%PORTDOCS%%share/doc/steghide/BUGS
+%%PORTDOCS%%share/doc/steghide/CREDITS
+%%PORTDOCS%%share/doc/steghide/HISTORY
+%%PORTDOCS%%share/doc/steghide/README
+%%PORTDOCS%%share/doc/steghide/TODO
+share/locale/de/LC_MESSAGES/steghide.mo
+share/locale/fr/LC_MESSAGES/steghide.mo
+%%PORTDOCS%%@dirrm share/doc/steghide