aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2007-06-07 15:08:09 +0000
committerMichael Johnson <ahze@FreeBSD.org>2007-06-07 15:08:09 +0000
commit3f66d90e8181c9d2aa9eaf7436711b2b3014ff4d (patch)
tree744dc8f012aaafbd478098572ca7c25aab91432b
parent794f096bf9bd73aab6d500a04feda040ab8029c8 (diff)
downloadports-3f66d90e8181c9d2aa9eaf7436711b2b3014ff4d.tar.gz
ports-3f66d90e8181c9d2aa9eaf7436711b2b3014ff4d.zip
Notes
-rw-r--r--mail/Makefile1
-rw-r--r--mail/p5-GMail-IMAPD/Makefile32
-rw-r--r--mail/p5-GMail-IMAPD/pkg-descr9
-rw-r--r--mail/p5-GMail-IMAPD/pkg-plist5
4 files changed, 47 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 15f0c59760c5..3516a783186b 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -317,6 +317,7 @@
SUBDIR += p5-Email-Valid-Loose
SUBDIR += p5-FuzzyOcr
SUBDIR += p5-FuzzyOcr-devel
+ SUBDIR += p5-GMail-IMAPD
SUBDIR += p5-IMAP-Admin
SUBDIR += p5-IMAP-Client
SUBDIR += p5-IMAP-Sieve
diff --git a/mail/p5-GMail-IMAPD/Makefile b/mail/p5-GMail-IMAPD/Makefile
new file mode 100644
index 000000000000..7c68e525cf83
--- /dev/null
+++ b/mail/p5-GMail-IMAPD/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: GMail-IMAPD
+# Date created: Jun 4, 2007
+# Whom: Ali Mashtizadeh <ali@mashtizadeh.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= GMail-IMAPD
+PORTVERSION= 0.94
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= GMail
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mashtizadeh@gmail.com
+COMMENT= Perl IMAP4 gateway to Google's webmail service
+
+BUILD_DEPENDS= ${SITE_PERL}/Mail/Webmail/Gmail.pm:${PORTSDIR}/mail/p5-Mail-Webmail-Gmail
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= GMail::IMAPD.3
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+.if ${PERL_LEVEL} < 500601
+ @${PERL} -pi -e 's/\r//g;s/^our/my/g' ${WRKSRC}/lib/GMail/IMAPD.pm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/p5-GMail-IMAPD/pkg-descr b/mail/p5-GMail-IMAPD/pkg-descr
new file mode 100644
index 000000000000..f324c842279f
--- /dev/null
+++ b/mail/p5-GMail-IMAPD/pkg-descr
@@ -0,0 +1,9 @@
+This module allows users to access their Gmail messages with an IMAP
+client by running a server which accepts IMAP connections.
+
+Currently this module supports only a subset of the IMAP4 protocol.
+
+WWW: http://search.cpan.org/dist/GMail-IMAPD/
+
+- Ali Mashtizadeh
+ali@mashtizadeh.org
diff --git a/mail/p5-GMail-IMAPD/pkg-plist b/mail/p5-GMail-IMAPD/pkg-plist
new file mode 100644
index 000000000000..c50b460be0bc
--- /dev/null
+++ b/mail/p5-GMail-IMAPD/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/GMail/IMAPD.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/GMail/IMAPD/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/GMail/IMAPD
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/GMail
+@dirrm %%SITE_PERL%%/GMail