aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-02-10 16:28:42 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-02-10 16:28:42 +0000
commit4212a766e0a21c243ffddd91a0fc117bad838df6 (patch)
tree57615d3ca8ea296a48ba2369939ea6a6d8322ce4
parent733a3873f03f505d0efae36ef398893bafefcd74 (diff)
downloadports-4212a766e0a21c243ffddd91a0fc117bad838df6.tar.gz
ports-4212a766e0a21c243ffddd91a0fc117bad838df6.zip
Notes
-rw-r--r--math/Makefile1
-rw-r--r--math/octave-forge-fl-core/Makefile22
-rw-r--r--math/octave-forge-fl-core/distinfo2
-rw-r--r--math/octave-forge-fl-core/pkg-descr10
-rw-r--r--math/octave-forge-fl-core/pkg-plist1
5 files changed, 36 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 85739e25684a..7618bb8caba6 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -234,6 +234,7 @@
SUBDIR += octave-forge-fenv
SUBDIR += octave-forge-financial
SUBDIR += octave-forge-fits
+ SUBDIR += octave-forge-fl-core
SUBDIR += octave-forge-fpl
SUBDIR += octave-forge-ga
SUBDIR += octave-forge-general
diff --git a/math/octave-forge-fl-core/Makefile b/math/octave-forge-fl-core/Makefile
new file mode 100644
index 000000000000..2d198c13fd67
--- /dev/null
+++ b/math/octave-forge-fl-core/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: octave-forge-fl-core
+# Date created: 8 September 2008
+# Whom: Stephen Montgomery-Smith <stephen@math.missouri.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= octave-forge-fl-core
+PORTVERSION= 1.0.0
+CATEGORIES= math
+
+MAINTAINER= stephen@missouri.edu
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+WRKSRC= ${WRKDIR}/${OCTAVE_PKGNAME}/src
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.octave.mk"
+post-build:
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTAVE_PKGNAME}
+
+.include <bsd.port.post.mk>
diff --git a/math/octave-forge-fl-core/distinfo b/math/octave-forge-fl-core/distinfo
new file mode 100644
index 000000000000..66f5aef85601
--- /dev/null
+++ b/math/octave-forge-fl-core/distinfo
@@ -0,0 +1,2 @@
+SHA256 (octave-forge/fl-core-1.0.0.tar.gz) = 5ec025ecdc05aede186fad48c28fe8053888e6571ba557a22173649f7c0c0a1d
+SIZE (octave-forge/fl-core-1.0.0.tar.gz) = 10357
diff --git a/math/octave-forge-fl-core/pkg-descr b/math/octave-forge-fl-core/pkg-descr
new file mode 100644
index 000000000000..8029091bf2cb
--- /dev/null
+++ b/math/octave-forge-fl-core/pkg-descr
@@ -0,0 +1,10 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is fl-core.
+
+ The package contains code for basic functions in Fuzzy Logic for Octave.
+
+WWW: http://octave.sourceforge.net/
diff --git a/math/octave-forge-fl-core/pkg-plist b/math/octave-forge-fl-core/pkg-plist
new file mode 100644
index 000000000000..a999ec86c07e
--- /dev/null
+++ b/math/octave-forge-fl-core/pkg-plist
@@ -0,0 +1 @@
+@comment This file intentionally left empty