aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2019-08-20 10:55:50 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2019-08-20 10:55:50 +0000
commit432ea66a47faf7e90ecac0140e2391ed1222351d (patch)
tree598c7006740c6ed677f50b64c6a1516dd40a76ea
parent691977e492395b6ed17603e686852cd91186c558 (diff)
Notes
-rw-r--r--devel/simgear/Makefile7
-rw-r--r--devel/simgear/pkg-plist6
-rw-r--r--games/flightgear-terragear/Makefile7
-rw-r--r--games/flightgear/Makefile7
4 files changed, 15 insertions, 12 deletions
diff --git a/devel/simgear/Makefile b/devel/simgear/Makefile
index c5818986c1b8..023ca4ed127f 100644
--- a/devel/simgear/Makefile
+++ b/devel/simgear/Makefile
@@ -2,7 +2,7 @@
PORTNAME= simgear
PORTVERSION= 2018.3.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel games
MASTER_SITES= SF/flightgear/release-${PORTVERSION:R}
@@ -14,7 +14,8 @@ LICENSE= GPLv2
BUILD_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:x11-toolkits/plib
RUN_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:x11-toolkits/plib
LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
- libosg.so:graphics/osg
+ libosg.so:graphics/osg \
+ libexpat.so:textproc/expat2
USES= alias cmake compiler:c++11-lib cpe gl jpeg openal:al,alut \
tar:bzip2
@@ -24,6 +25,8 @@ USE_GL= gl glu glut
LDFLAGS_gcc= -losgDB
LDFLAGS+= ${LDFLAGS_${CHOSEN_COMPILER_TYPE}}
+CMAKE_ARGS+= -DSYSTEM_EXPAT:BOOL=ON
+
post-patch:
# Avoid conflict with C++20 <version> by adding .txt suffix
@${MV} ${WRKSRC}/version ${WRKSRC}/version.txt
diff --git a/devel/simgear/pkg-plist b/devel/simgear/pkg-plist
index c8b3823a57d2..ed3fe6335fa2 100644
--- a/devel/simgear/pkg-plist
+++ b/devel/simgear/pkg-plist
@@ -332,9 +332,11 @@ include/simgear/timing/timestamp.hxx
include/simgear/timing/timezone.h
include/simgear/version.h
include/simgear/xml/easyxml.hxx
-lib/libSimGearCore.a
-lib/libSimGearScene.a
lib/cmake/SimGear/SimGearConfig.cmake
lib/cmake/SimGear/SimGearConfigVersion.cmake
lib/cmake/SimGear/SimGearTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/SimGear/SimGearTargets.cmake
+lib/libSimGearCore.so
+lib/libSimGearCore.so.2018.3.2
+lib/libSimGearScene.so
+lib/libSimGearScene.so.2018.3.2
diff --git a/games/flightgear-terragear/Makefile b/games/flightgear-terragear/Makefile
index 5559501f3bc0..b1d9e9a6f4c8 100644
--- a/games/flightgear-terragear/Makefile
+++ b/games/flightgear-terragear/Makefile
@@ -2,7 +2,7 @@
PORTNAME= flightgear-terragear
PORTVERSION= 20171007
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= games
MAINTAINER= mike.d.ft402@gmail.com
@@ -10,7 +10,6 @@ COMMENT= Tools for building scenery for the FlightGear project
LICENSE= GPLv2
-BUILD_DEPENDS= ${LOCALBASE}/lib/libSimGearCore.a:devel/simgear
LIB_DEPENDS= libCGAL.so:math/cgal \
libgdal.so:graphics/gdal \
libmpfr.so:math/mpfr \
@@ -20,8 +19,8 @@ LIB_DEPENDS= libCGAL.so:math/cgal \
libboost_chrono.so:devel/boost-libs \
libboost_date_time.so:devel/boost-libs \
libboost_atomic.so:devel/boost-libs \
- libtiff.so:graphics/tiff
-RUN_DEPENDS= ${LOCALBASE}/lib/libSimGearCore.a:devel/simgear
+ libtiff.so:graphics/tiff \
+ libSimGearCore.so:devel/simgear
USES= cmake compiler:c++11-lang
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index 9707566fe401..6f4b25c99840 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -3,7 +3,7 @@
PORTNAME= flightgear
PORTVERSION= 2018.3.2
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= games
MASTER_SITES= SF/flightgear/release-${PORTVERSION:R}
@@ -20,12 +20,11 @@ LIB_DEPENDS= libpng.so:graphics/png \
libspeex.so:audio/speex \
libspeexdsp.so:audio/speexdsp \
libcurl.so:ftp/curl \
- libudev.so:devel/libudev-devd
+ libudev.so:devel/libudev-devd \
+ libSimGearCore.so:devel/simgear
BUILD_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:x11-toolkits/plib \
- ${LOCALBASE}/lib/libSimGearCore.a:devel/simgear \
${LOCALBASE}/include/linux/input.h:devel/evdev-proto
RUN_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:x11-toolkits/plib \
- ${LOCALBASE}/lib/libSimGearCore.a:devel/simgear \
${LOCALBASE}/share/flightgear/version:games/flightgear-data
# Disable ninja, see https://sourceforge.net/p/flightgear/codetickets/2118/