aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-12-03 18:15:40 +0000
committerWill Andrews <will@FreeBSD.org>2000-12-03 18:15:40 +0000
commit49b80109c5e434af4b0a1042bb257953afd49a23 (patch)
tree9a58f085db4d57b67a67099254241175f0046722
parent738eda67e3143a5b7d93b8ddf15edb9a3370b00a (diff)
downloadports-49b80109c5e434af4b0a1042bb257953afd49a23.tar.gz
ports-49b80109c5e434af4b0a1042bb257953afd49a23.zip
Notes
-rw-r--r--devel/Makefile2
-rw-r--r--devel/p5-Config-IniFiles/Makefile (renamed from devel/p5-IniConf/Makefile)15
-rw-r--r--devel/p5-Config-IniFiles/distinfo1
-rw-r--r--devel/p5-Config-IniFiles/pkg-comment (renamed from devel/p5-IniConf/pkg-comment)0
-rw-r--r--devel/p5-Config-IniFiles/pkg-descr20
-rw-r--r--devel/p5-Config-IniFiles/pkg-plist3
-rw-r--r--devel/p5-IniConf/distinfo1
-rw-r--r--devel/p5-IniConf/files/patch-aa36
-rw-r--r--devel/p5-IniConf/pkg-descr17
-rw-r--r--devel/p5-IniConf/pkg-plist3
10 files changed, 32 insertions, 66 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ebf00669429b..5b48578d47c6 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -195,6 +195,7 @@
SUBDIR += p5-C-Scan
SUBDIR += p5-Class-MethodMaker
SUBDIR += p5-ConfigReader
+ SUBDIR += p5-Config-IniFiles
SUBDIR += p5-Curses
SUBDIR += p5-Data-Flow
SUBDIR += p5-Data-ShowTable
@@ -219,7 +220,6 @@
SUBDIR += p5-IO-stringy
SUBDIR += p5-IPC-Shareable
SUBDIR += p5-Include
- SUBDIR += p5-IniConf
SUBDIR += p5-Locale-Maketext
SUBDIR += p5-Locale-PGetText
SUBDIR += p5-Locale-gettext
diff --git a/devel/p5-IniConf/Makefile b/devel/p5-Config-IniFiles/Makefile
index 689deb06de06..4a96da1d5830 100644
--- a/devel/p5-IniConf/Makefile
+++ b/devel/p5-Config-IniFiles/Makefile
@@ -1,26 +1,25 @@
-# New ports collection makefile for: p5-IniConf
+# New ports collection makefile for: p5-Config-IniFiles
# Date created: October 21st 1996
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
# $FreeBSD$
#
-PORTNAME= IniConf
-PORTVERSION= 0.92
+PORTNAME= Config-IniFiles
+PORTVERSION= 1.8
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
-MASTER_SITE_SUBDIR= IniConf
+MASTER_SITE_SUBDIR= Config
PKGNAMEPREFIX= p5-
-DISTNAME= ${PORTNAME}.pm-${PORTVERSION}
-MAINTAINER= demon@FreeBSD.org
+MAINTAINER= jeremy@external.org
USE_PERL5= YES
-MAN3= IniConf.pm.3
+MAN3= Config::IniFiles.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
.include <bsd.port.mk>
diff --git a/devel/p5-Config-IniFiles/distinfo b/devel/p5-Config-IniFiles/distinfo
new file mode 100644
index 000000000000..f8616d36011a
--- /dev/null
+++ b/devel/p5-Config-IniFiles/distinfo
@@ -0,0 +1 @@
+MD5 (Config-IniFiles-1.8.tar.gz) = 2f76f242fac3a6c8975c41bec8ce0b86
diff --git a/devel/p5-IniConf/pkg-comment b/devel/p5-Config-IniFiles/pkg-comment
index b52d9066dddd..b52d9066dddd 100644
--- a/devel/p5-IniConf/pkg-comment
+++ b/devel/p5-Config-IniFiles/pkg-comment
diff --git a/devel/p5-Config-IniFiles/pkg-descr b/devel/p5-Config-IniFiles/pkg-descr
new file mode 100644
index 000000000000..64ae3110ddd2
--- /dev/null
+++ b/devel/p5-Config-IniFiles/pkg-descr
@@ -0,0 +1,20 @@
+Config::IniFiles provides a way to have readable configuration files
+outside your Perl script. The configuration can be safely reloaded upon
+receipt of a signal. Configurations can be imported (inherited,
+stacked,...), sections can be grouped, and settings can be accessed from
+a tied hash.
+
+USAGE
+
+Get a new Config::IniFiles object with the *new* method:
+
+ $cfg = Config::IniFiles->new( -file => "/path/configfile.ini" );
+ $cfg = new Config::IniFiles -file => "/path/configfile.ini";
+
+Optional named parameters may be specified after the configuration file
+name. See the *new* in the METHODS section, below.
+
+INI files consist of a number of sections, each preceeded with the
+section name in square brackets. Parameters are specified in each section
+as Name=Value. Any spaces around the equals sign will be i gnored, and the
+value extends to the end of the line.
diff --git a/devel/p5-Config-IniFiles/pkg-plist b/devel/p5-Config-IniFiles/pkg-plist
new file mode 100644
index 000000000000..e9784a9d1be6
--- /dev/null
+++ b/devel/p5-Config-IniFiles/pkg-plist
@@ -0,0 +1,3 @@
+lib/perl5/site_perl/%%PERL_VER%%/Config/IniFiles.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Config/IniFiles/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Config/IniFiles
diff --git a/devel/p5-IniConf/distinfo b/devel/p5-IniConf/distinfo
deleted file mode 100644
index 08e6c91a4722..000000000000
--- a/devel/p5-IniConf/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (IniConf.pm-0.92.tar.gz) = 0057de0a61aacf1de8ec966fd70c9ded
diff --git a/devel/p5-IniConf/files/patch-aa b/devel/p5-IniConf/files/patch-aa
deleted file mode 100644
index 40db38b51881..000000000000
--- a/devel/p5-IniConf/files/patch-aa
+++ /dev/null
@@ -1,36 +0,0 @@
-*** IniConf.pm.orig Fri Jul 11 09:39:59 1997
---- IniConf.pm Thu Sep 10 04:49:00 1998
-***************
-*** 203,209 ****
- \$SIG{$sig} = 'IGNORE';
- \$${class}::instance[$instnum]->ReadConfig;
- if (\$oldhandler[$instnum] && \$oldhandler[$instnum] ne 'IGNORE') {
-! eval '&$oldhandler[$instnum];';
- }
- \$SIG{$sig} = '$newhandler'
- }
---- 203,209 ----
- \$SIG{$sig} = 'IGNORE';
- \$${class}::instance[$instnum]->ReadConfig;
- if (\$oldhandler[$instnum] && \$oldhandler[$instnum] ne 'IGNORE') {
-! eval '&\$oldhandler[$instnum];';
- }
- \$SIG{$sig} = '$newhandler'
- }
-***************
-*** 346,352 ****
- $self->{v}{$sect} = {};
- }
- }
-! elsif (($parm, $val) = /\s*(\S+)\s*=\s*(.*)/) { # new parameter
- $parm = lc($parm) if $nocase;
- $self->{pCMT}{$sect}{$parm} = [@cmts];
- @cmts = ( );
---- 346,352 ----
- $self->{v}{$sect} = {};
- }
- }
-! elsif (($parm, $val) = /\s*([^\s=]+)\s*=\s*(.*)/) { # new parameter
- $parm = lc($parm) if $nocase;
- $self->{pCMT}{$sect}{$parm} = [@cmts];
- @cmts = ( );
diff --git a/devel/p5-IniConf/pkg-descr b/devel/p5-IniConf/pkg-descr
deleted file mode 100644
index 2b247d9e949a..000000000000
--- a/devel/p5-IniConf/pkg-descr
+++ /dev/null
@@ -1,17 +0,0 @@
-IniConf provides a way to have readable configuration files outside your
-Perl script. The configuration can be safely reloaded upon receipt of a
-signal.
-
-USAGE
-
-Get a new IniConf object with the new method:
-
- $cfg = IniConf->new( -file => "/path/configfile.ini" );
- $cfg = new IniConf -file => "/path/configfile.ini";
-
-Optional named parameters may be specified after the configuration file
-name. See the new in the METHODS section, below. INI files consist of a
-number of sections, each preceeded with the section name in square brackets.
-Parameters are specified in each section as Name=Value. Any spaces around
-the equals sign will be ignored, and the value extends to the end of the
-line
diff --git a/devel/p5-IniConf/pkg-plist b/devel/p5-IniConf/pkg-plist
deleted file mode 100644
index e3fe23216cb8..000000000000
--- a/devel/p5-IniConf/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-lib/perl5/site_perl/%%PERL_VER%%/IniConf.pm
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IniConf.pm/.packlist
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IniConf.pm