aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2020-11-20 20:35:54 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2020-11-20 20:35:54 +0000
commit52ed178304218a253b69a8b6235eed84cd9462e5 (patch)
tree6098b2c3ff6014bf623eab27ef6f3c1e3dc941cf
parenta27077f47d13113a2697c2a02edd7001f6e41a03 (diff)
downloadports-52ed178304218a253b69a8b6235eed84cd9462e5.tar.gz
ports-52ed178304218a253b69a8b6235eed84cd9462e5.zip
Notes
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/libquotient/Makefile25
-rw-r--r--net-im/libquotient/distinfo3
-rw-r--r--net-im/libquotient/pkg-descr5
-rw-r--r--net-im/libquotient/pkg-plist133
5 files changed, 167 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 66fb1114228d..4c131bacfe24 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -59,6 +59,7 @@
SUBDIR += libpurple
SUBDIR += libqmatrixclient
SUBDIR += libqtelegram-ae
+ SUBDIR += libquotient
SUBDIR += libsignon-glib
SUBDIR += libstrophe
SUBDIR += licq
diff --git a/net-im/libquotient/Makefile b/net-im/libquotient/Makefile
new file mode 100644
index 000000000000..ad0c8d608314
--- /dev/null
+++ b/net-im/libquotient/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= libquotient
+DISTVERSION= 0.6.2
+CATEGORIES= net-im
+
+MAINTAINER= adridg@FreeBSD.org
+COMMENT= Matrix IM support library using Qt technologies
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+CONFLICTS= libqmatrixclient\*
+
+USES= cmake compiler:c++14-lang qt:5 tar:xz
+USE_QT= core gui multimedia network \
+ buildtools_build qmake_build
+
+USE_GITHUB= yes
+GH_ACCOUNT= quotient-im
+GH_PROJECT= libQuotient
+
+CMAKE_ARGS= -DQuotient_INSTALL_TESTS=OFF
+
+.include <bsd.port.mk>
diff --git a/net-im/libquotient/distinfo b/net-im/libquotient/distinfo
new file mode 100644
index 000000000000..d1c8571115de
--- /dev/null
+++ b/net-im/libquotient/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1605903095
+SHA256 (quotient-im-libQuotient-0.6.2_GH0.tar.gz) = afa9ee64327b9fdbf1d8514ec9b1374b797560b43315911211f723acf01ff317
+SIZE (quotient-im-libQuotient-0.6.2_GH0.tar.gz) = 557665
diff --git a/net-im/libquotient/pkg-descr b/net-im/libquotient/pkg-descr
new file mode 100644
index 000000000000..4f3ec2848d58
--- /dev/null
+++ b/net-im/libquotient/pkg-descr
@@ -0,0 +1,5 @@
+libQuotient is a Qt5-based library to make IM clients for the
+Matrix protocol. It is the backbone of Quaternion, Spectral and some
+other projects. (Previously, libQuotient was known as libQMatrixClient)
+
+WWW: https://github.com/quotient-im/libQuotient
diff --git a/net-im/libquotient/pkg-plist b/net-im/libquotient/pkg-plist
new file mode 100644
index 000000000000..b86ada3d098b
--- /dev/null
+++ b/net-im/libquotient/pkg-plist
@@ -0,0 +1,133 @@
+include/Quotient/application-service/definitions/location.h
+include/Quotient/application-service/definitions/protocol.h
+include/Quotient/application-service/definitions/user.h
+include/Quotient/avatar.h
+include/Quotient/connection.h
+include/Quotient/connectiondata.h
+include/Quotient/converters.h
+include/Quotient/csapi/account-data.h
+include/Quotient/csapi/admin.h
+include/Quotient/csapi/administrative_contact.h
+include/Quotient/csapi/appservice_room_directory.h
+include/Quotient/csapi/banning.h
+include/Quotient/csapi/capabilities.h
+include/Quotient/csapi/content-repo.h
+include/Quotient/csapi/create_room.h
+include/Quotient/csapi/definitions/auth_data.h
+include/Quotient/csapi/definitions/client_device.h
+include/Quotient/csapi/definitions/device_keys.h
+include/Quotient/csapi/definitions/event_filter.h
+include/Quotient/csapi/definitions/openid_token.h
+include/Quotient/csapi/definitions/public_rooms_response.h
+include/Quotient/csapi/definitions/push_condition.h
+include/Quotient/csapi/definitions/push_rule.h
+include/Quotient/csapi/definitions/push_ruleset.h
+include/Quotient/csapi/definitions/request_email_validation.h
+include/Quotient/csapi/definitions/request_msisdn_validation.h
+include/Quotient/csapi/definitions/request_token_response.h
+include/Quotient/csapi/definitions/room_event_filter.h
+include/Quotient/csapi/definitions/sync_filter.h
+include/Quotient/csapi/definitions/third_party_signed.h
+include/Quotient/csapi/definitions/user_identifier.h
+include/Quotient/csapi/definitions/wellknown/full.h
+include/Quotient/csapi/definitions/wellknown/homeserver.h
+include/Quotient/csapi/definitions/wellknown/identity_server.h
+include/Quotient/csapi/device_management.h
+include/Quotient/csapi/directory.h
+include/Quotient/csapi/event_context.h
+include/Quotient/csapi/filter.h
+include/Quotient/csapi/inviting.h
+include/Quotient/csapi/joining.h
+include/Quotient/csapi/keys.h
+include/Quotient/csapi/kicking.h
+include/Quotient/csapi/leaving.h
+include/Quotient/csapi/list_joined_rooms.h
+include/Quotient/csapi/list_public_rooms.h
+include/Quotient/csapi/login.h
+include/Quotient/csapi/logout.h
+include/Quotient/csapi/message_pagination.h
+include/Quotient/csapi/notifications.h
+include/Quotient/csapi/openid.h
+include/Quotient/csapi/peeking_events.h
+include/Quotient/csapi/presence.h
+include/Quotient/csapi/profile.h
+include/Quotient/csapi/pusher.h
+include/Quotient/csapi/pushrules.h
+include/Quotient/csapi/read_markers.h
+include/Quotient/csapi/receipts.h
+include/Quotient/csapi/redaction.h
+include/Quotient/csapi/registration.h
+include/Quotient/csapi/report_content.h
+include/Quotient/csapi/room_send.h
+include/Quotient/csapi/room_state.h
+include/Quotient/csapi/room_upgrades.h
+include/Quotient/csapi/rooms.h
+include/Quotient/csapi/sso_login_redirect.h
+include/Quotient/csapi/tags.h
+include/Quotient/csapi/third_party_lookup.h
+include/Quotient/csapi/third_party_membership.h
+include/Quotient/csapi/to_device.h
+include/Quotient/csapi/typing.h
+include/Quotient/csapi/users.h
+include/Quotient/csapi/versions.h
+include/Quotient/csapi/voip.h
+include/Quotient/csapi/wellknown.h
+include/Quotient/csapi/whoami.h
+include/Quotient/e2ee.h
+include/Quotient/encryptionmanager.h
+include/Quotient/eventitem.h
+include/Quotient/events/accountdataevents.h
+include/Quotient/events/callanswerevent.h
+include/Quotient/events/callcandidatesevent.h
+include/Quotient/events/callhangupevent.h
+include/Quotient/events/callinviteevent.h
+include/Quotient/events/directchatevent.h
+include/Quotient/events/encryptedevent.h
+include/Quotient/events/encryptionevent.h
+include/Quotient/events/event.h
+include/Quotient/events/eventcontent.h
+include/Quotient/events/eventloader.h
+include/Quotient/events/reactionevent.h
+include/Quotient/events/receiptevent.h
+include/Quotient/events/redactionevent.h
+include/Quotient/events/roomavatarevent.h
+include/Quotient/events/roomcanonicalaliasevent.h
+include/Quotient/events/roomcreateevent.h
+include/Quotient/events/roomevent.h
+include/Quotient/events/roomkeyevent.h
+include/Quotient/events/roommemberevent.h
+include/Quotient/events/roommessageevent.h
+include/Quotient/events/roompowerlevelsevent.h
+include/Quotient/events/roomtombstoneevent.h
+include/Quotient/events/simplestateevents.h
+include/Quotient/events/stateevent.h
+include/Quotient/events/typingevent.h
+include/Quotient/identity/definitions/request_email_validation.h
+include/Quotient/identity/definitions/request_msisdn_validation.h
+include/Quotient/jobs/basejob.h
+include/Quotient/jobs/downloadfilejob.h
+include/Quotient/jobs/mediathumbnailjob.h
+include/Quotient/jobs/postreadmarkersjob.h
+include/Quotient/jobs/requestdata.h
+include/Quotient/jobs/syncjob.h
+include/Quotient/joinstate.h
+include/Quotient/logging.h
+include/Quotient/networkaccessmanager.h
+include/Quotient/networksettings.h
+include/Quotient/qt_connection_util.h
+include/Quotient/quotient_common.h
+include/Quotient/room.h
+include/Quotient/settings.h
+include/Quotient/ssosession.h
+include/Quotient/syncdata.h
+include/Quotient/uri.h
+include/Quotient/uriresolver.h
+include/Quotient/user.h
+include/Quotient/util.h
+lib/cmake/Quotient/QuotientConfig.cmake
+lib/cmake/Quotient/QuotientConfigVersion.cmake
+lib/cmake/Quotient/QuotientTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/Quotient/QuotientTargets.cmake
+lib/libQuotient.a
+libdata/pkgconfig/Quotient.pc
+share/ndk-modules/Android.mk