aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-01-01 01:36:26 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-01-01 01:41:48 +0000
commit5a071065b26587abe5bfa06d7ee8feecaba5c483 (patch)
tree58ea50eda52078f12654de305df20d1ed1cf9330
parent725c54a5a087e7b77eaaae14d1d2e70e5975b7fd (diff)
downloadports-5a071065b26587abe5bfa06d7ee8feecaba5c483.tar.gz
ports-5a071065b26587abe5bfa06d7ee8feecaba5c483.zip
emulators/citra: unbreak fetch after 66e2037c4970
Failover between mirrors doesn't work if file exists but is different. => Attempting to fetch https://api.citra-emu.org/gamedb/?dummy=/citra/compatibility_list.json [...] => SHA256 Checksum mismatch for citra/compatibility_list.json. [...] ===> Giving up on fetching files: citra/compatibility_list.json Reported by: pkg-fallout (cherry picked from commit 84b697165ef31bd2c4cbc1f9605d4de3a507500b)
-rw-r--r--emulators/citra/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/emulators/citra/Makefile b/emulators/citra/Makefile
index 4982654322aa..b8b23b93bb0d 100644
--- a/emulators/citra/Makefile
+++ b/emulators/citra/Makefile
@@ -2,8 +2,11 @@ PORTNAME= citra
PORTVERSION= s20211218
PORTREVISION?= 0
CATEGORIES= emulators
-MASTER_SITES= https://api.citra-emu.org/gamedb/?dummy=/:gamedb \
- LOCAL/jbeich:gamedb
+.if make(makesum)
+MASTER_SITES= https://api.citra-emu.org/gamedb/?dummy=/:gamedb
+.else
+MASTER_SITES= LOCAL/jbeich:gamedb
+.endif
DISTFILES= ${PORTNAME}/compatibility_list.json:gamedb
EXTRACT_ONLY= ${DISTFILES:N*\:gamedb:C/\:.*//}