aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoger Pau Monné <royger@FreeBSD.org>2021-05-10 11:27:01 +0000
committerRoger Pau Monné <royger@FreeBSD.org>2021-05-12 08:57:22 +0000
commit5e92a126a9229daa57401425e26c83299c896623 (patch)
treedc083cb5133d675aba363d49a47f30993b57a185
parent565eb7e544c803dbaa64a3767d4c3e1e593e144c (diff)
downloadports-5e92a126a9229daa57401425e26c83299c896623.tar.gz
ports-5e92a126a9229daa57401425e26c83299c896623.zip
-rw-r--r--emulators/xen-kernel/Makefile10
-rw-r--r--emulators/xen-kernel/distinfo6
-rw-r--r--sysutils/xen-tools/Makefile11
-rw-r--r--sysutils/xen-tools/distinfo6
-rw-r--r--sysutils/xen-tools/pkg-plist42
5 files changed, 40 insertions, 35 deletions
diff --git a/emulators/xen-kernel/Makefile b/emulators/xen-kernel/Makefile
index 6abd69260873..612a23cb3462 100644
--- a/emulators/xen-kernel/Makefile
+++ b/emulators/xen-kernel/Makefile
@@ -1,6 +1,6 @@
PORTNAME= xen
-PORTVERSION= 4.14.1
-PORTREVISION= 1
+PORTVERSION= 4.15.0
+PORTREVISION= 0
CATEGORIES= emulators
MASTER_SITES= http://downloads.xenproject.org/release/xen/${PORTVERSION}/
PKGNAMESUFFIX= -kernel
@@ -23,12 +23,6 @@ STRIP= #
PLIST_FILES= /boot/xen \
lib/debug/boot/xen.debug
-# Propagate module command line passed by the loader.
-EXTRA_PATCHES+= ${PATCHDIR}/0001-x86-pvh-pass-module-command-line-to-dom0.patch:-p1
-
-# Fix EFI BS call ABI.
-EXTRA_PATCHES+= ${PATCHDIR}/0001-x86-efi-enable-MS-ABI-attribute-on-clang.patch:-p1
-
.include <bsd.port.options.mk>
.if ${OPSYS} != FreeBSD
diff --git a/emulators/xen-kernel/distinfo b/emulators/xen-kernel/distinfo
index ab008f378c59..740fd456bc18 100644
--- a/emulators/xen-kernel/distinfo
+++ b/emulators/xen-kernel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1611929407
-SHA256 (xen-4.14.1.tar.gz) = cf0d7316ad674491f49b7ef0518cb1d906a2e3bfad639deef0ef2343b119ac0c
-SIZE (xen-4.14.1.tar.gz) = 39970115
+TIMESTAMP = 1620647879
+SHA256 (xen-4.15.0.tar.gz) = 6cf41394726c9f2913edcd6707457d9b7a910a4d75d95e9ecdebf02b00f1adad
+SIZE (xen-4.15.0.tar.gz) = 40785399
diff --git a/sysutils/xen-tools/Makefile b/sysutils/xen-tools/Makefile
index a0288a1c170e..0c487b73739a 100644
--- a/sysutils/xen-tools/Makefile
+++ b/sysutils/xen-tools/Makefile
@@ -1,7 +1,7 @@
PORTNAME= xen
PKGNAMESUFFIX= -tools
-PORTVERSION= 4.14.1
-PORTREVISION= 1
+PORTVERSION= 4.15.0
+PORTREVISION= 0
CATEGORIES= sysutils emulators
MASTER_SITES= http://downloads.xenproject.org/release/xen/${PORTVERSION}/
@@ -16,8 +16,10 @@ LIB_DEPENDS= libyajl.so:devel/yajl \
libpixman-1.so:x11/pixman \
libargp.so:devel/argp-standalone \
libxml2.so:textproc/libxml2
-BUILD_DEPENDS= seabios>0:misc/seabios
-RUN_DEPENDS= seabios>0:misc/seabios
+BUILD_DEPENDS= seabios>0:misc/seabios \
+ ${LOCALBASE}/share/edk2-xen/XEN_EFI.fd:sysutils/edk2@xen
+RUN_DEPENDS= seabios>0:misc/seabios \
+ ${LOCALBASE}/share/edk2-xen/XEN_EFI.fd:sysutils/edk2@xen
OPTIONS_DEFINE= DOCS SPICE
OPTIONS_DEFAULT= DOCS
@@ -43,6 +45,7 @@ MAKE_ARGS= clang=y ARCH=x86_64
BINARY_ALIAS= python3=${PYTHON_CMD}
CONFIGURE_ARGS+= --with-system-seabios=${LOCALBASE}/share/seabios/bios.bin \
+ --with-system-ovmf=${LOCALBASE}/share/edk2-xen/XEN_EFI.fd \
--mandir=${MANPREFIX}/man
SHEBANG_FILES= tools/misc/xencov_split \
diff --git a/sysutils/xen-tools/distinfo b/sysutils/xen-tools/distinfo
index 2ac6e5207ffe..740fd456bc18 100644
--- a/sysutils/xen-tools/distinfo
+++ b/sysutils/xen-tools/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1611929626
-SHA256 (xen-4.14.1.tar.gz) = cf0d7316ad674491f49b7ef0518cb1d906a2e3bfad639deef0ef2343b119ac0c
-SIZE (xen-4.14.1.tar.gz) = 39970115
+TIMESTAMP = 1620647879
+SHA256 (xen-4.15.0.tar.gz) = 6cf41394726c9f2913edcd6707457d9b7a910a4d75d95e9ecdebf02b00f1adad
+SIZE (xen-4.15.0.tar.gz) = 40785399
diff --git a/sysutils/xen-tools/pkg-plist b/sysutils/xen-tools/pkg-plist
index d24f0f3f4fe4..17c3e224a931 100644
--- a/sysutils/xen-tools/pkg-plist
+++ b/sysutils/xen-tools/pkg-plist
@@ -15,17 +15,17 @@ bin/xenstore-rm
bin/xenstore-watch
bin/xenstore-write
bin/xentrace_format
-etc/bash_completion.d/xl.sh
+etc/bash_completion.d/xl
etc/rc.d/xencommons
etc/rc.d/xendriverdomain
%%ETCDIR%%/README
-%%ETCDIR%%/README.incompatibilities
%%ETCDIR%%/cpupool
%%ETCDIR%%/scripts/block
%%ETCDIR%%/scripts/hotplugpath.sh
%%ETCDIR%%/scripts/vif-bridge
%%ETCDIR%%/xl.conf
%%ETCDIR%%/xlexample.hvm
+%%ETCDIR%%/xlexample.pvhlinux
%%ETCDIR%%/xlexample.pvlinux
include/_libxl_list.h
include/_libxl_types.h
@@ -39,6 +39,7 @@ include/libxlutil.h
include/xen/COPYING
include/xen/arch-arm.h
include/xen/arch-arm/hvm/save.h
+include/xen/arch-arm/smccc.h
include/xen/arch-x86/cpufeatureset.h
include/xen/arch-x86/cpuid.h
include/xen/arch-x86/hvm/save.h
@@ -134,6 +135,7 @@ include/xenstore-compat/xs_lib.h
include/xenstore.h
include/xenstore_lib.h
include/xentoolcore.h
+include/xentoolcore_internal.h
include/xentoollog.h
include/xs.h
include/xs_lib.h
@@ -144,43 +146,43 @@ lib/libxencall.so.1
lib/libxencall.so.1.2
lib/libxenctrl.a
lib/libxenctrl.so
-lib/libxenctrl.so.4.14
-lib/libxenctrl.so.4.14.0
+lib/libxenctrl.so.4.15
+lib/libxenctrl.so.4.15.0
lib/libxendevicemodel.a
lib/libxendevicemodel.so
lib/libxendevicemodel.so.1
-lib/libxendevicemodel.so.1.3
+lib/libxendevicemodel.so.1.4
lib/libxenevtchn.a
lib/libxenevtchn.so
lib/libxenevtchn.so.1
-lib/libxenevtchn.so.1.1
+lib/libxenevtchn.so.1.2
lib/libxenforeignmemory.a
lib/libxenforeignmemory.so
lib/libxenforeignmemory.so.1
-lib/libxenforeignmemory.so.1.3
+lib/libxenforeignmemory.so.1.4
lib/libxenfsimage.so
-lib/libxenfsimage.so.4.14
-lib/libxenfsimage.so.4.14.0
+lib/libxenfsimage.so.4.15
+lib/libxenfsimage.so.4.15.0
lib/libxengnttab.a
lib/libxengnttab.so
lib/libxengnttab.so.1
lib/libxengnttab.so.1.2
lib/libxenguest.a
lib/libxenguest.so
-lib/libxenguest.so.4.14
-lib/libxenguest.so.4.14.0
+lib/libxenguest.so.4.15
+lib/libxenguest.so.4.15.0
lib/libxenhypfs.a
lib/libxenhypfs.so
lib/libxenhypfs.so.1
lib/libxenhypfs.so.1.0
lib/libxenlight.a
lib/libxenlight.so
-lib/libxenlight.so.4.14
-lib/libxenlight.so.4.14.0
+lib/libxenlight.so.4.15
+lib/libxenlight.so.4.15.0
lib/libxenstat.a
lib/libxenstat.so
-lib/libxenstat.so.4.14
-lib/libxenstat.so.4.14.0
+lib/libxenstat.so.4.15
+lib/libxenstat.so.4.15.0
lib/libxenstore.a
lib/libxenstore.so
lib/libxenstore.so.3.0
@@ -195,8 +197,8 @@ lib/libxentoollog.so.1
lib/libxentoollog.so.1.0
lib/libxlutil.a
lib/libxlutil.so
-lib/libxlutil.so.4.14
-lib/libxlutil.so.4.14.0
+lib/libxlutil.so.4.15
+lib/libxlutil.so.4.15.0
%%PYTHON_SITELIBDIR%%/grub/ExtLinuxConf.py
%%PYTHON_SITELIBDIR%%/grub/ExtLinuxConf.pyc
%%PYTHON_SITELIBDIR%%/grub/GrubConf.py
@@ -234,6 +236,8 @@ lib/libxlutil.so.4.14.0
%%PYTHON_SITELIBDIR%%/xenfsimage%%PYTHON_EXT_SUFFIX%%.so
lib/xen/bin/convert-legacy-stream
lib/xen/bin/depriv-fd-checker
+lib/xen/bin/ivshmem-client
+lib/xen/bin/ivshmem-server
lib/xen/bin/libxl-save-helper
lib/xen/bin/lsevtchn
lib/xen/bin/pygrub
@@ -284,6 +288,7 @@ man/man1/xentrace_format.1.gz
man/man1/xl.1.gz
man/man5/xl-disk-configuration.5.gz
man/man5/xl-network-configuration.5.gz
+man/man5/xl-pci-configuration.5.gz
man/man5/xl.cfg.5.gz
man/man5/xl.conf.5.gz
man/man5/xlcpupool.cfg.5.gz
@@ -301,6 +306,7 @@ sbin/flask-loadpolicy
sbin/flask-set-bool
sbin/flask-setenforce
sbin/gdbsx
+sbin/xen-access
sbin/xen-diag
sbin/xen-hptool
sbin/xen-hvmcrash
@@ -308,6 +314,7 @@ sbin/xen-hvmctx
sbin/xen-kdd
sbin/xen-livepatch
sbin/xen-lowmemd
+sbin/xen-memshare
sbin/xen-mfndump
sbin/xen-ucode
sbin/xenbaked
@@ -553,6 +560,7 @@ sbin/xl
%%PORTDOCS%%%%DOCSDIR%%/html/man/xl-disk-configuration.5.html
%%PORTDOCS%%%%DOCSDIR%%/html/man/xl-network-configuration.5.html
%%PORTDOCS%%%%DOCSDIR%%/html/man/xl-numa-placement.7.html
+%%PORTDOCS%%%%DOCSDIR%%/html/man/xl-pci-configuration.5.html
%%PORTDOCS%%%%DOCSDIR%%/html/man/xl.1.html
%%PORTDOCS%%%%DOCSDIR%%/html/man/xl.cfg.5.html
%%PORTDOCS%%%%DOCSDIR%%/html/man/xl.conf.5.html