aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Wunsch <joerg@FreeBSD.org>2008-01-16 09:50:58 +0000
committerJoerg Wunsch <joerg@FreeBSD.org>2008-01-16 09:50:58 +0000
commit64310253629e265041b328a77cb41c248f1d1359 (patch)
tree4d3210db5b9a5069b41bd0eaed72ec78af547001
parent4fc1e08db50bd818f483ffe1a8b4587d0fdd2f6f (diff)
downloadports-64310253629e265041b328a77cb41c248f1d1359.tar.gz
ports-64310253629e265041b328a77cb41c248f1d1359.zip
Notes
-rw-r--r--devel/gwenhywfar/Makefile35
-rw-r--r--devel/gwenhywfar/distinfo6
-rw-r--r--devel/gwenhywfar/files/patch-configure20
-rw-r--r--devel/gwenhywfar/files/patch-test_Makefile.in11
-rw-r--r--devel/gwenhywfar/files/patch-tools_dlgtest_Makefile.in11
-rw-r--r--devel/gwenhywfar/files/patch-tools_typemaker_Makefile.in11
-rw-r--r--devel/gwenhywfar/files/patch-tools_xmlmerge_Makefile.in11
-rw-r--r--devel/gwenhywfar/pkg-plist138
8 files changed, 101 insertions, 142 deletions
diff --git a/devel/gwenhywfar/Makefile b/devel/gwenhywfar/Makefile
index 9366e6329531..f36c0d705dc5 100644
--- a/devel/gwenhywfar/Makefile
+++ b/devel/gwenhywfar/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gwenhywfar
-PORTVERSION= 1.13.2
-PORTREVISION= 2
+PORTVERSION= 2.6.2
CATEGORIES= devel net security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -24,49 +23,51 @@ GNU_CONFIGURE= yes
USE_GETTEXT= yes
USE_OPENSSL= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/lib/gwenhywfar/plugins/17/dbio
-ALL_TARGET= all
+USE_LDCONFIG= ${PREFIX}/lib \
+ ${PREFIX}/lib/gwenhywfar/plugins/38/crypttoken \
+ ${PREFIX}/lib/gwenhywfar/plugins/38/dbio \
+ ${PREFIX}/lib/gwenhywfar/plugins/38/storage
+.if !defined(NOPORTEXAMPLES)
# Examples to be installed from ${WRKSRC}/doc
-EXAMPLE_FILES= STYLE \
+PORTEXAMPLES= STYLE \
apidoc.h \
db2.png \
plugindescr.xml \
plugindescr.xsd \
plugindescr.xsd.in \
testdialog.xml
+.endif
.include <bsd.port.pre.mk>
-.if defined(WITH_SSLDEBUG)
-# Enable appending of SSL connection in/output to /tmp/{read|written}.bin.
-CFLAGS+= -DGWEN_SSL_DEBUG
-.endif
-
# Enable printing of memory debugger statistic at runtime.
.if defined(WITH_MEMDEBUG)
-CFLAGS+= -DGWEN_MEMORY_DEBUG
+CONFIGURE_ARGS+= --enable-memtrace
.endif
.if defined(WITH_PORTDOCS)
BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
-ALL_TARGET+= srcdoc
+CONFIGURE_ARGS+= --enable-full-doc
PORTDOCS=*
.endif
post-install:
.if !defined(NOPORTDOCS)
- @${ECHO_CMD} Installing documentation...
- ${MKDIR} ${EXAMPLESDIR}
-.for file in ${EXAMPLE_FILES}
- ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${EXAMPLESDIR}
-.endfor
.if defined(WITH_PORTDOCS)
+ @${ECHO_CMD} Installing documentation...
${MKDIR} ${DOCSDIR}
@cd ${WRKSRC} && ${FIND} apidoc -mindepth 1 \! -type d \
-exec ${ECHO_CMD} "{} -> ${DOCSDIR}/{}" \; \
-exec ${INSTALL_DATA} ${WRKSRC}/{} ${DOCSDIR} \;
.endif
.endif
+.if !defined(NOPORTEXAMPLES)
+ @${ECHO_CMD} Installing examples...
+ ${MKDIR} ${EXAMPLESDIR}
+.for file in ${PORTEXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${EXAMPLESDIR}
+.endfor
+.endif
.include <bsd.port.post.mk>
diff --git a/devel/gwenhywfar/distinfo b/devel/gwenhywfar/distinfo
index 327ea95d890c..e1d09a6e8765 100644
--- a/devel/gwenhywfar/distinfo
+++ b/devel/gwenhywfar/distinfo
@@ -1,3 +1,3 @@
-MD5 (gwenhywfar-1.13.2.tar.gz) = d1a82b8f84fc37c41348dcf69a08cba8
-SHA256 (gwenhywfar-1.13.2.tar.gz) = d0a9cb40882da5a55468eedbb4ab211f5ad55f9782f8ed5f6d0c82a120e56478
-SIZE (gwenhywfar-1.13.2.tar.gz) = 1085838
+MD5 (gwenhywfar-2.6.2.tar.gz) = fec3bc3653b7809cc44526b6fed52ab2
+SHA256 (gwenhywfar-2.6.2.tar.gz) = 610b4d7ba6803d40b0324f2efeac862f915feb20feb36b91649328f9ad051705
+SIZE (gwenhywfar-2.6.2.tar.gz) = 1201995
diff --git a/devel/gwenhywfar/files/patch-configure b/devel/gwenhywfar/files/patch-configure
deleted file mode 100644
index 27648a07ceba..000000000000
--- a/devel/gwenhywfar/files/patch-configure
+++ /dev/null
@@ -1,20 +0,0 @@
---- configure.orig Sun May 1 07:42:05 2005
-+++ configure Sat Jun 4 23:17:50 2005
-@@ -27956,7 +27956,7 @@
- lprefix="${srcdir}"
- lprefix=`( cd ${lprefix} ; pwd )`
-
--rm -Rf gwenhywfar &>/dev/null
-+rm -Rf gwenhywfar 2>/dev/null
- mkdir gwenhywfar
- GWEN_HEADER_FILES="doc/apidoc.h"
- for d in ${GWEN_HEADER_DIRS}; do
-@@ -27981,7 +27981,7 @@
- lprefix="${srcdir}"
- lprefix=`( cd ${lprefix} ; pwd )`
- for d in ${GWEN_MODULES}; do
-- rm -Rf gwenhywfar/$d &>/dev/null
-+ rm -Rf gwenhywfar/$d 2>/dev/null
- mkdir gwenhywfar/$d
- # FIXME: This needs to be fixed again: The sources are in gwenui,
- # but the headers will be installed in gwenhywfar/ui.
diff --git a/devel/gwenhywfar/files/patch-test_Makefile.in b/devel/gwenhywfar/files/patch-test_Makefile.in
deleted file mode 100644
index 69ec72a26d4f..000000000000
--- a/devel/gwenhywfar/files/patch-test_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- test/Makefile.in.orig Sun May 1 07:42:01 2005
-+++ test/Makefile.in Sat Jun 4 23:51:47 2005
-@@ -273,7 +273,7 @@
- gwentest_SOURCES = gwentest.c
- gwentest_LDADD = \
- -L/mingw/lib -L$(top_builddir)/src $(gwenhywfar_libs) \
-- -L$(top_builddir)/gwenui $(libsui)
-+ -L$(top_builddir)/gwenui $(libsui) $(LTLIBINTL)
-
- EXTRA_DIST = README.MSVC gwentest.vcproj
- all: all-am
diff --git a/devel/gwenhywfar/files/patch-tools_dlgtest_Makefile.in b/devel/gwenhywfar/files/patch-tools_dlgtest_Makefile.in
deleted file mode 100644
index 0d5b24a4327a..000000000000
--- a/devel/gwenhywfar/files/patch-tools_dlgtest_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- tools/dlgtest/Makefile.in.orig Sun May 1 07:42:02 2005
-+++ tools/dlgtest/Makefile.in Sat Jun 4 23:47:19 2005
-@@ -276,7 +276,7 @@
- dlgtest_LDADD = \
- -L$(top_builddir)/src $(gwenhywfar_libs) \
- -L$(top_builddir)/gwenui $(gwenhywfar_libsui) \
-- -L/mingw/lib $(PROG_LIBRARIES)
-+ -L/mingw/lib $(PROG_LIBRARIES) $(LTLIBINTL)
-
- all: all-am
-
diff --git a/devel/gwenhywfar/files/patch-tools_typemaker_Makefile.in b/devel/gwenhywfar/files/patch-tools_typemaker_Makefile.in
deleted file mode 100644
index 760633a78422..000000000000
--- a/devel/gwenhywfar/files/patch-tools_typemaker_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- tools/typemaker/Makefile.in.orig Sun May 1 07:42:02 2005
-+++ tools/typemaker/Makefile.in Sat Jun 4 23:48:35 2005
-@@ -279,7 +279,7 @@
- typemaker_SOURCES = args.c main.c phc.c lhc.c ahc.c code_c.c
- typemaker_LDADD = \
- -L$(top_builddir)/src $(gwenhywfar_libs) \
-- -L/mingw/lib $(PROG_LIBRARIES)
-+ -L/mingw/lib $(PROG_LIBRARIES) $(LTLIBINTL)
-
- all: all-am
-
diff --git a/devel/gwenhywfar/files/patch-tools_xmlmerge_Makefile.in b/devel/gwenhywfar/files/patch-tools_xmlmerge_Makefile.in
deleted file mode 100644
index 33ee7bcfd6f3..000000000000
--- a/devel/gwenhywfar/files/patch-tools_xmlmerge_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- tools/xmlmerge/Makefile.in.orig Sun May 1 07:42:02 2005
-+++ tools/xmlmerge/Makefile.in Sat Jun 4 23:43:29 2005
-@@ -277,7 +277,7 @@
- xmlmerge_SOURCES = args.c main.c
- xmlmerge_LDADD = \
- -L$(top_builddir)/src $(gwenhywfar_libs) \
-- -L/mingw/lib $(PROG_LIBRARIES)
-+ -L/mingw/lib $(PROG_LIBRARIES) $(LTLIBINTL)
-
- all: all-am
-
diff --git a/devel/gwenhywfar/pkg-plist b/devel/gwenhywfar/pkg-plist
index ff2f699d8658..a9241d783277 100644
--- a/devel/gwenhywfar/pkg-plist
+++ b/devel/gwenhywfar/pkg-plist
@@ -1,7 +1,7 @@
@comment $FreeBSD$
bin/mklistdoc
bin/xmlmerge
-bin/dlgtest
+bin/gct-tool
bin/typemaker
bin/gwenhywfar-config
include/gwenhywfar/args.h
@@ -10,8 +10,10 @@ include/gwenhywfar/debug.h
include/gwenhywfar/error.h
include/gwenhywfar/i18n.h
include/gwenhywfar/idlist.h
+include/gwenhywfar/idmap.h
include/gwenhywfar/inherit.h
include/gwenhywfar/list.h
+include/gwenhywfar/list1.h
include/gwenhywfar/list1.tmpl
include/gwenhywfar/list2.h
include/gwenhywfar/list2.tmpl
@@ -23,6 +25,24 @@ include/gwenhywfar/plugin.h
include/gwenhywfar/plugindescr.h
include/gwenhywfar/refptr.h
include/gwenhywfar/ringbuffer.h
+include/gwenhywfar/smp_storage_be.h
+include/gwenhywfar/smp_type_be.h
+include/gwenhywfar/ssl_cert_descr.h
+include/gwenhywfar/ssl_cipher.h
+include/gwenhywfar/st_client.h
+include/gwenhywfar/st_client_be.h
+include/gwenhywfar/st_find.h
+include/gwenhywfar/st_find_be.h
+include/gwenhywfar/st_log.h
+include/gwenhywfar/st_object.h
+include/gwenhywfar/st_object_be.h
+include/gwenhywfar/st_plugin.h
+include/gwenhywfar/st_plugin_be.h
+include/gwenhywfar/st_storage.h
+include/gwenhywfar/st_storage_be.h
+include/gwenhywfar/st_type.h
+include/gwenhywfar/st_type_be.h
+include/gwenhywfar/st_vardef.h
include/gwenhywfar/stringlist.h
include/gwenhywfar/stringlist2.h
include/gwenhywfar/waitcallback.h
@@ -31,17 +51,16 @@ include/gwenhywfar/keymanager.h
include/gwenhywfar/keyspec.h
include/gwenhywfar/md.h
include/gwenhywfar/padd.h
-include/gwenhywfar/nettransportssl.h
include/gwenhywfar/bio_buffer.h
include/gwenhywfar/bio_file.h
include/gwenhywfar/bio_socket.h
include/gwenhywfar/bufferedio.h
include/gwenhywfar/filter.h
include/gwenhywfar/ipc.h
-include/gwenhywfar/netconnectionhttp.h
include/gwenhywfar/system.h
include/gwenhywfar/directory.h
include/gwenhywfar/fslock.h
+include/gwenhywfar/gwensignal.h
include/gwenhywfar/gwentime.h
include/gwenhywfar/inetaddr.h
include/gwenhywfar/inetsocket.h
@@ -49,79 +68,82 @@ include/gwenhywfar/libloader.h
include/gwenhywfar/process.h
include/gwenhywfar/base64.h
include/gwenhywfar/csv.h
+include/gwenhywfar/ct_file.h
include/gwenhywfar/db.h
include/gwenhywfar/dbio.h
include/gwenhywfar/msgengine.h
include/gwenhywfar/path.h
+include/gwenhywfar/pathmanager.h
+include/gwenhywfar/request.h
+include/gwenhywfar/requestmgr.h
include/gwenhywfar/text.h
-include/gwenhywfar/ui/button.h
-include/gwenhywfar/ui/checkbox.h
-include/gwenhywfar/ui/dropdownbox.h
-include/gwenhywfar/ui/editbox.h
-include/gwenhywfar/ui/event.h
-include/gwenhywfar/ui/filedialog.h
-include/gwenhywfar/ui/hline.h
-include/gwenhywfar/ui/hslider.h
-include/gwenhywfar/ui/loader.h
-include/gwenhywfar/ui/messagebox.h
-include/gwenhywfar/ui/scrollwidget.h
-include/gwenhywfar/ui/tablewidget.h
-include/gwenhywfar/ui/textwidget.h
-include/gwenhywfar/ui/ui.h
-include/gwenhywfar/ui/vslider.h
-include/gwenhywfar/ui/widget.h
-include/gwenhywfar/ui/window.h
include/gwenhywfar/tlv.h
+include/gwenhywfar/url.h
+include/gwenhywfar/urlfns.h
include/gwenhywfar/xml.h
include/gwenhywfar/xsd.h
-include/gwenhywfar/net.h
-include/gwenhywfar/netconnection.h
-include/gwenhywfar/netmsg.h
-include/gwenhywfar/nettransport.h
-include/gwenhywfar/nettransportsock.h
+include/gwenhywfar/net2.h
+include/gwenhywfar/netlayer.h
+include/gwenhywfar/nl_file.h
+include/gwenhywfar/nl_hbci.h
+include/gwenhywfar/nl_http.h
+include/gwenhywfar/nl_log.h
+include/gwenhywfar/nl_packets.h
+include/gwenhywfar/nl_socket.h
+include/gwenhywfar/nl_ssl.h
+include/gwenhywfar/nl_stdio.h
include/gwenhywfar/crypttoken.h
+include/gwenhywfar/crypttoken_context.h
+include/gwenhywfar/crypttoken_cryptinfo.h
+include/gwenhywfar/crypttoken_keyinfo.h
+include/gwenhywfar/crypttoken_plugin.h
+include/gwenhywfar/crypttoken_signinfo.h
+include/gwenhywfar/crypttoken_user.h
include/gwenhywfar/gwenhywfar.h
include/gwenhywfar/gwenhywfarapi.h
include/gwenhywfar/types.h
include/gwenhywfar/version.h
-include/gwenpp/waitcallback.h
etc/gwen-public-ca.crt
lib/libgwenhywfar.a
lib/libgwenhywfar.la
lib/libgwenhywfar.so
-lib/libgwenhywfar.so.30
-lib/libgwenpp.a
-lib/libgwenpp.la
-lib/libgwenpp.so
-lib/libgwenpp.so.16
-lib/libgwenui.a
-lib/libgwenui.la
-lib/libgwenui.so
-lib/libgwenui.so.1
-lib/gwenhywfar/plugins/17/dbio/csv.a
-lib/gwenhywfar/plugins/17/dbio/csv.la
-lib/gwenhywfar/plugins/17/dbio/csv.so
-lib/gwenhywfar/plugins/17/dbio/csv.so.0
-lib/gwenhywfar/plugins/17/dbio/csv.xml
-lib/gwenhywfar/plugins/17/dbio/olddb.a
-lib/gwenhywfar/plugins/17/dbio/olddb.la
-lib/gwenhywfar/plugins/17/dbio/olddb.so
-lib/gwenhywfar/plugins/17/dbio/olddb.so.0
-lib/gwenhywfar/plugins/17/dbio/olddb.xml
+lib/libgwenhywfar.so.48
+lib/pkgconfig/gwenhywfar.pc
+lib/gwenhywfar/plugins/38/crypttoken/ohbci.a
+lib/gwenhywfar/plugins/38/crypttoken/ohbci.la
+lib/gwenhywfar/plugins/38/crypttoken/ohbci.so
+lib/gwenhywfar/plugins/38/crypttoken/ohbci.so.0
+lib/gwenhywfar/plugins/38/crypttoken/ohbci.xml
+lib/gwenhywfar/plugins/38/dbio/csv.a
+lib/gwenhywfar/plugins/38/dbio/csv.la
+lib/gwenhywfar/plugins/38/dbio/csv.so
+lib/gwenhywfar/plugins/38/dbio/csv.so.0
+lib/gwenhywfar/plugins/38/dbio/csv.xml
+lib/gwenhywfar/plugins/38/dbio/olddb.a
+lib/gwenhywfar/plugins/38/dbio/olddb.la
+lib/gwenhywfar/plugins/38/dbio/olddb.so
+lib/gwenhywfar/plugins/38/dbio/olddb.so.0
+lib/gwenhywfar/plugins/38/dbio/olddb.xml
+lib/gwenhywfar/plugins/38/dbio/rfc822.a
+lib/gwenhywfar/plugins/38/dbio/rfc822.la
+lib/gwenhywfar/plugins/38/dbio/rfc822.so
+lib/gwenhywfar/plugins/38/dbio/rfc822.so.0
+lib/gwenhywfar/plugins/38/dbio/rfc822.xml
+lib/gwenhywfar/plugins/38/dbio/xmldb.a
+lib/gwenhywfar/plugins/38/dbio/xmldb.la
+lib/gwenhywfar/plugins/38/dbio/xmldb.so
+lib/gwenhywfar/plugins/38/dbio/xmldb.so.0
+lib/gwenhywfar/plugins/38/dbio/xmldb.xml
+lib/gwenhywfar/plugins/38/storage/localfiles.a
+lib/gwenhywfar/plugins/38/storage/localfiles.la
+lib/gwenhywfar/plugins/38/storage/localfiles.so
+lib/gwenhywfar/plugins/38/storage/localfiles.so.0
+lib/gwenhywfar/plugins/38/storage/localfiles.xml
share/aclocal/gwenhywfar.m4
-%%PORTDOCS%%%%EXAMPLESDIR%%/STYLE
-%%PORTDOCS%%%%EXAMPLESDIR%%/apidoc.h
-%%PORTDOCS%%%%EXAMPLESDIR%%/db2.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/plugindescr.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/plugindescr.xsd
-%%PORTDOCS%%%%EXAMPLESDIR%%/plugindescr.xsd.in
-%%PORTDOCS%%%%EXAMPLESDIR%%/testdialog.xml
-share/locale/de/LC_MESSAGES/gwenhywfar.mo
-@dirrm include/gwenhywfar/ui
@dirrm include/gwenhywfar
-@dirrm include/gwenpp
-@dirrm lib/gwenhywfar/plugins/17/dbio
-@dirrm lib/gwenhywfar/plugins/17
+@dirrm lib/gwenhywfar/plugins/38/crypttoken
+@dirrm lib/gwenhywfar/plugins/38/dbio
+@dirrm lib/gwenhywfar/plugins/38/storage
+@dirrm lib/gwenhywfar/plugins/38
@dirrm lib/gwenhywfar/plugins
@dirrm lib/gwenhywfar
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%