aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-12-11 23:12:29 +0000
committerMatthias Andree <mandree@FreeBSD.org>2021-12-11 23:17:18 +0000
commit687f7c6199e1e7cc2d1b4a23c5168747d756e2d9 (patch)
treef19bf9a11402098c6819012aad93e041bda3e404
parentbb52e25269ff405340401eba45c73db5c213c2be (diff)
downloadports-687f7c6199e1e7cc2d1b4a23c5168747d756e2d9.tar.gz
ports-687f7c6199e1e7cc2d1b4a23c5168747d756e2d9.zip
security/openvpn: re-enable mbedTLS build
...now that mbedTLS metadata was fixed to show the actual situation for mbedTLS 2.x.y, that it's either Apache License 2.0, or GNU General Public License 2.0 or any later version. While here, also mark the main port with mbedTLS option enabled to record it's going to lose the mbedTLS option end of March 2022. (cherry picked from commit d02b0675d0630a9ac66617becd9f9cfbbca9c524)
-rw-r--r--security/openvpn/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/security/openvpn/Makefile b/security/openvpn/Makefile
index ff080990626c..62b50ea7cc1c 100644
--- a/security/openvpn/Makefile
+++ b/security/openvpn/Makefile
@@ -44,7 +44,7 @@ OPTIONS_SINGLE_SSL= OPENSSL MBEDTLS
ASYNC_PUSH_DESC= Enable async-push support
EASYRSA_DESC= Install security/easy-rsa RSA helper package
LZO_DESC= LZO compression support (incompatible with LibreSSL)
-MBEDTLS_DESC= LICENSE BROKEN - SSL/TLS via mbedTLS (lacks TLS v1.3)
+MBEDTLS_DESC= SSL/TLS via mbedTLS (lacks TLS v1.3)
PKCS11_DESC= Use security/pkcs11-helper (OpenSSL only)
SMALL_DESC= Build a smaller executable with fewer features
TUNNELBLICK_DESC= Tunnelblick XOR scramble patch (READ HELP!)
@@ -95,7 +95,6 @@ CFLAGS+= -DLOG_OPENVPN=${LOG_OPENVPN}
.if ${PORT_OPTIONS:MMBEDTLS}
BROKEN_FreeBSD_14= OpenVPN-mbedTLS fails on FreeBSD 14
-BROKEN= License under clarification, OpenVPN is GPLv2-only and mbedTLS under Apache License 2.0, which are incompatible
_tlslibs=libmbedtls libmbedx509 libmbedcrypto
.else
# OpenSSL
@@ -122,8 +121,9 @@ pre-everything::
.if !empty(PORT_OPTIONS:MMBEDTLS)
pre-everything::
- @${ECHO_CMD} >&2 "License under clarification, OpenVPN is GPLv2-only and mbedTLS under Apache License 2.0, which are incompatible."
- @${SHELL} -c 'exit 1'
+ @${ECHO_CMD} >&2 "====================================================="
+ @${ECHO_CMD} >&2 "Note that the mbedTLS option will go away 2022-03-31."
+ @${ECHO_CMD} >&2 "====================================================="
.endif
post-patch: